aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2004-10-29 06:33:41 +0800
committercy <cy@FreeBSD.org>2004-10-29 06:33:41 +0800
commite4b337cdeaa81f69520badb1d160f1be543b616f (patch)
treefd8966a54d62563d2cc0e87f329ee42b9ed1e9dd /security
parentfeba2332d7e87b10da0913907131a4b58f5f5bcf (diff)
downloadfreebsd-ports-gnome-e4b337cdeaa81f69520badb1d160f1be543b616f.tar.gz
freebsd-ports-gnome-e4b337cdeaa81f69520badb1d160f1be543b616f.tar.zst
freebsd-ports-gnome-e4b337cdeaa81f69520badb1d160f1be543b616f.zip
Repair handling of ptys.
Diffstat (limited to 'security')
-rw-r--r--security/sudosh/Makefile1
-rw-r--r--security/sudosh/files/patch-src::sudosh.c42
-rw-r--r--security/sudosh2/Makefile1
-rw-r--r--security/sudosh2/files/patch-src::sudosh.c42
-rw-r--r--security/sudosh3/Makefile1
-rw-r--r--security/sudosh3/files/patch-src::sudosh.c42
6 files changed, 129 insertions, 0 deletions
diff --git a/security/sudosh/Makefile b/security/sudosh/Makefile
index 67496042c3ce..cd58476af25a 100644
--- a/security/sudosh/Makefile
+++ b/security/sudosh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sudosh
PORTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
diff --git a/security/sudosh/files/patch-src::sudosh.c b/security/sudosh/files/patch-src::sudosh.c
new file mode 100644
index 000000000000..9f7d3a914cb3
--- /dev/null
+++ b/security/sudosh/files/patch-src::sudosh.c
@@ -0,0 +1,42 @@
+--- src/sudosh.c.orig Tue Oct 26 18:01:24 2004
++++ src/sudosh.c Thu Oct 28 15:18:50 2004
+@@ -75,6 +75,12 @@
+ #define SIGCHLD SIGCLD
+ #endif
+
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#include <sys/ioctl.h>
++#include <libutil.h>
++#endif
++
+ static struct termios termorig;
+ static struct winsize winorig;
+
+@@ -377,15 +383,24 @@
+ {
+ if ((p->mfd = open ("/dev/ptc", O_RDWR)) == -1)
+ {
+- perror ("Cannot open cloning master pty");
+- return -1;
++#ifdef __FreeBSD__
++ if (openpty(&p->mfd, &p->sfd, sname, NULL, NULL) == -1)
++ {
++#endif
++ perror ("Cannot open cloning master pty");
++ return -1;
++#ifdef __FreeBSD__
++ }
++#endif
+ }
+ }
+
+ (void) unlockpt (p->mfd);
+ (void) grantpt (p->mfd);
+
++#ifndef __FreeBSD__
+ sname = (char *) ptsname (p->mfd);
++#endif
+
+ if ((p->sfd = open (sname, O_RDWR)) == -1)
+ {
diff --git a/security/sudosh2/Makefile b/security/sudosh2/Makefile
index 67496042c3ce..cd58476af25a 100644
--- a/security/sudosh2/Makefile
+++ b/security/sudosh2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sudosh
PORTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
diff --git a/security/sudosh2/files/patch-src::sudosh.c b/security/sudosh2/files/patch-src::sudosh.c
new file mode 100644
index 000000000000..9f7d3a914cb3
--- /dev/null
+++ b/security/sudosh2/files/patch-src::sudosh.c
@@ -0,0 +1,42 @@
+--- src/sudosh.c.orig Tue Oct 26 18:01:24 2004
++++ src/sudosh.c Thu Oct 28 15:18:50 2004
+@@ -75,6 +75,12 @@
+ #define SIGCHLD SIGCLD
+ #endif
+
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#include <sys/ioctl.h>
++#include <libutil.h>
++#endif
++
+ static struct termios termorig;
+ static struct winsize winorig;
+
+@@ -377,15 +383,24 @@
+ {
+ if ((p->mfd = open ("/dev/ptc", O_RDWR)) == -1)
+ {
+- perror ("Cannot open cloning master pty");
+- return -1;
++#ifdef __FreeBSD__
++ if (openpty(&p->mfd, &p->sfd, sname, NULL, NULL) == -1)
++ {
++#endif
++ perror ("Cannot open cloning master pty");
++ return -1;
++#ifdef __FreeBSD__
++ }
++#endif
+ }
+ }
+
+ (void) unlockpt (p->mfd);
+ (void) grantpt (p->mfd);
+
++#ifndef __FreeBSD__
+ sname = (char *) ptsname (p->mfd);
++#endif
+
+ if ((p->sfd = open (sname, O_RDWR)) == -1)
+ {
diff --git a/security/sudosh3/Makefile b/security/sudosh3/Makefile
index 67496042c3ce..cd58476af25a 100644
--- a/security/sudosh3/Makefile
+++ b/security/sudosh3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sudosh
PORTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
diff --git a/security/sudosh3/files/patch-src::sudosh.c b/security/sudosh3/files/patch-src::sudosh.c
new file mode 100644
index 000000000000..9f7d3a914cb3
--- /dev/null
+++ b/security/sudosh3/files/patch-src::sudosh.c
@@ -0,0 +1,42 @@
+--- src/sudosh.c.orig Tue Oct 26 18:01:24 2004
++++ src/sudosh.c Thu Oct 28 15:18:50 2004
+@@ -75,6 +75,12 @@
+ #define SIGCHLD SIGCLD
+ #endif
+
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#include <sys/ioctl.h>
++#include <libutil.h>
++#endif
++
+ static struct termios termorig;
+ static struct winsize winorig;
+
+@@ -377,15 +383,24 @@
+ {
+ if ((p->mfd = open ("/dev/ptc", O_RDWR)) == -1)
+ {
+- perror ("Cannot open cloning master pty");
+- return -1;
++#ifdef __FreeBSD__
++ if (openpty(&p->mfd, &p->sfd, sname, NULL, NULL) == -1)
++ {
++#endif
++ perror ("Cannot open cloning master pty");
++ return -1;
++#ifdef __FreeBSD__
++ }
++#endif
+ }
+ }
+
+ (void) unlockpt (p->mfd);
+ (void) grantpt (p->mfd);
+
++#ifndef __FreeBSD__
+ sname = (char *) ptsname (p->mfd);
++#endif
+
+ if ((p->sfd = open (sname, O_RDWR)) == -1)
+ {
At the moment 1385 ports use BUILD_DEPENDS= ${RUN_DEPENDS} and 450eadler2012-01-221-1/+1 * - fix small typos in COMMENTeadler2011-11-151-1/+1 * Mark as broken on powerpc: does not compile.linimon2011-11-111-0/+4 * - Remove WITH_FBSD10_FIX, is no longer neededmiwi2011-11-091-1/+0 * Standardize WWW: tags a bit more:dougb2011-11-071-1/+2 * - Fix build on FreeBSD 10miwi2011-10-301-0/+1 * The vast majority of pkg-descr files had the following format when theydougb2011-10-241-3/+0 * Remove more tags from pkg-descr files fo the form:dougb2011-10-243-11/+1 * - Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)amdmi32011-09-248-13/+8 * 2012-09-20 www/ruby-http-access: Deprecated upstream, please use www/rubygem-...bapt2011-09-2221-2607/+0 * - Track dependencies after databases/gdbm updategabor2011-09-121-2/+2 * Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where ...kwm2011-08-242-2/+13 * Remove USE_GNOME=gnometarget from ports. It has been a empty keyword sincekwm2011-08-126-6/+5 * - Adjust WWW line with link to new author's sitefluffy2011-08-041-1/+1 * Deprecate some ports where I can't find distfiles and upstreambapt2011-08-032-0/+6 * Now that the Java 1.3 and Java 1.4 ports are deprecated and will expire soon,linimon2011-07-212-2/+2 * - kick MD5miwi2011-07-021-1/+0 * - Update to 1.8.1pav2011-06-234-15/+16 * Remove unmaintain expired ports from palmbapt2011-05-0222-1047/+0 * Remove most expired ports:rene2011-04-196-60/+0 * - Mark BROKEN: does not compilepav2011-03-271-0/+2 * - Get Rid MD5 supportmiwi2011-03-1938-42/+0 * - Mark ports that have been broken for six month or more, or never compiled onpav2011-03-171-11/+5 * Deprecate unmaintained ports from palm where upstream disapear and/orbapt2011-03-144-0/+12 * Add -I${LOCALBASE}/include to CFLAGS. [1] Sort pkg-plist.gerald2011-01-263-12/+11 * Reset ijliao@FreeBSD.org due to maintainer-timeouts and long absence.linimon2010-12-285-7/+4 * Use the $SRC_BASE Makevar instead of hard-coding.linimon2010-12-171-2/+2 * Sync to new bsd.autotools.mkade2010-12-044-4/+4 * Convert LDCONFIG_DIRS to USE_LDCONFIG.makc2010-06-091-3/+1 * Bounce PORTREVISION for gettext-related ports. Have fun, ya'll.ade2010-05-316-6/+6 * Presenting GNOME 2.30.1 for FreeBSD. The offical release notes for thiskwm2010-05-111-2/+2 * - fix option WITH_PNGdinoex2010-03-301-0/+6 * - update to 1.4.1dinoex2010-03-2812-11/+12 * - Chase x11-toolkits/fltk updategahr2010-03-241-1/+1 * Plugin for JPilot (jpilot.org) to download pictures, photos and videos fromamdmi32010-03-194-0/+50 * - Add backup mirror (looks like project site is down)miwi2010-03-101-1/+1 * - Update to 0.12.5miwi2010-03-102-4/+4 * - update to jpeg-8dinoex2010-02-0510-7/+10 * - Convert to DOCSDIRmiwi2010-02-032-4/+4 * - Remove unneeded dependencies which is in perl-5.8.9 distkuriyama2010-01-261-2/+1 * - Fix sorting and minor cleanups in category Makefilesamdmi32010-01-201-1/+1 * - remove broken/expired ports@ portspgollucci2010-01-1818-919/+0 * - Convert NOMANCOMPRESS to NO_MANCOMPRESS to sync with srcmiwi2009-12-291-1/+1 * For ports maintained by ports@FreeBSD.org, remove names and/ordougb2009-12-215-9/+1 * This port has been broken for 3+ months, thuspav2009-12-081-0/+2 * Presenting GNOME 2.28.1 for FreeBSD. The official release notes for thismarcus2009-11-293-4/+7 * - Fix build on 6.xavl2009-10-171-2/+2 * - Remove the patch which is required for upcoming GNOME 2.28 onlyavl2009-10-121-76/+0 * - Update to 0.14avl2009-10-122-6/+6 * - Update to 0.3avl2009-10-123-6/+93 * - Update to 0.14avl2009-10-122-5/+6 * - Forgot to include bsd.port.pre.mk and bsd.port.post.mk.avl2009-10-121-1/+3 * - Fix .if conditionavl2009-10-121-1/+1 * - Update to 0.14avl2009-10-124-13/+41 * - Update to 0.14avl2009-10-122-4/+4 * - Update to 0.14avl2009-10-127-34/+40 * - Update to 0.14avl2009-10-122-4/+4 * - Fix build with custom PREFIXavl2009-10-121-1/+1 * - Fix build with custom PREFIXavl2009-10-121-1/+1 * - Update to 0.12.4amdmi32009-09-094-15/+20 * - Update to 0.44.1fluffy2009-09-032-6/+6 * - Switch SourceForge ports to the new File Release System: categories startin...amdmi32009-08-2214-24/+14 * Mark BROKEN: does not build.erwin2009-08-031-0/+1 * -Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.mezz2009-08-034-4/+4 * - bump all port that indirectly depends on libjpeg and have not yet been bump...dinoex2009-07-319-2/+9 * - Update boost to 1.39pav2009-07-281-1/+1 * - Disable optimizations, they cause segfaults on runtimepav2009-07-281-2/+2 * - Mark BROKEN on amd64/8pav2009-07-261-0/+1 * - Update to 1.6.2amdmi32009-07-102-4/+4 * - Unbreak on -current.wxs2009-07-091-6/+27 * Change MAINTAINER on my ports to my FreeBSD email addressavl2009-05-295-5/+5 * Mark BROKEN on 8.x: does not build.erwin2009-05-271-0/+4 * - Reset maintainermiwi2009-05-053-3/+3 * - Add patch to fix functionality on FreeBSD 7.xamdmi32009-04-222-1/+16 * - Fix build on CURRENT with new USB stackamdmi32009-04-021-0/+15 * - Fix indexmiwi2009-04-011-0/+1 * - Allow to build with MAKE_JOBS_SAFEmiwi2009-04-013-3/+8 * - Fix build with new USB2miwi2009-03-261-0/+2 * - Update to 0.13miwi2009-03-212-5/+4 * - Update to 0.13miwi2009-03-212-4/+4 * - Update to 0.13.1miwi2009-03-213-16/+4 * - Update to 0.13miwi2009-03-212-5/+4 * - Update to 0.13.1miwi2009-03-212-5/+9 * - Chase libusb20 rename in r189585.stas2009-03-102-2/+7 * Update to 2.0.17.marcus2009-03-015-9/+8 * - Update to 5.1.0r3tabthorpe2009-03-012-5/+20 * - Old MASTER_SITES are dead, switch to newer oneswxs2009-02-253-18/+7 * - Update to 0.2.2miwi2009-02-203-24/+4 * - Pass maintainership to submittertabthorpe2009-02-133-3/+3 * 2009-01-19 games/emacs-chess: has been broken for more than 6 monthsmiwi2009-02-047-128/+0 * - Use GNOME macro instead of ${MASTER_SITE_GNOME}, removearaujo2009-02-021-2/+1 * - Update to 0.2.1amdmi32009-01-154-5/+30 * - Update to 0.13.amdmi32009-01-158-236/+18 * - Remove conditional checks for FreeBSD 5.x and olderpav2009-01-071-3/+0 * - Update to 1.6.1amdmi32009-01-033-13/+7 * - Set for expiration in one month: has been broken for more than 6 monthspav2008-12-201-0/+2 * 2008-10-19 x11-wm/flwm: Project is dead, and uses obsolete version of fltkmiwi2008-12-0814-236/+0 * - Update to 0.12.3pav2008-12-044-24/+27 * - Remove py-wbxml from run-time dependencies listmiwi2008-11-231-1/+1 * - Update to 1.6.0miwi2008-11-095-25/+18 * - Speedup build phase.miwi2008-10-152-3/+7 * - Speedup build phase.miwi2008-10-152-3/+7 * Fix CATEGORIES in slave palm/py-synce-librapi2 and palm/py-synce-librra.miwi2008-10-122-2/+2 * SynCE is a project for connecting to devices running Windows CE or Pocket PC.miwi2008-10-056-0/+240 * - Fix manpage installmiwi2008-09-111-2/+2 * Fix an obvious typo.linimon2008-09-081-1/+1 * SynCE is a project for connecting to devices running Windows CE or Pocket PC.miwi2008-09-085-0/+41 * SynCE is a project for connecting to devices running Windows CE or Pocket PC.miwi2008-09-085-0/+40 * - Fixes issues with incorrectly handledmiwi2008-09-081-3/+4 * - Remove empty filespav2008-08-261-0/+0 * Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.rafan2008-08-213-3/+0 * Conversion from (now defunct) autoconf-2.61 to autoconf-2.62ade2008-08-20