aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoranray <anray@FreeBSD.org>2005-12-19 17:35:13 +0800
committeranray <anray@FreeBSD.org>2005-12-19 17:35:13 +0800
commite787f4856379b58962d85072eb1e638031c3684e (patch)
tree4c0ea49ea82a8c26eba2d039b7274e8ccefe0c1a /security
parent24a6429c91fad40dd33bc31eadc3b63bd82c3a9f (diff)
downloadfreebsd-ports-gnome-e787f4856379b58962d85072eb1e638031c3684e.tar.gz
freebsd-ports-gnome-e787f4856379b58962d85072eb1e638031c3684e.tar.zst
freebsd-ports-gnome-e787f4856379b58962d85072eb1e638031c3684e.zip
Added p5-Crypt-HCE_MD5, perl extension implementing one way hash chaining encryption using MD5.
PR: ports/90589 Submitted by: Gabor Kovesdan <gkovesdan@t-hosting.hu> Approved by: sem(mentor)
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-HCE_MD5/Makefile24
-rw-r--r--security/p5-Crypt-HCE_MD5/distinfo3
-rw-r--r--security/p5-Crypt-HCE_MD5/pkg-descr15
-rw-r--r--security/p5-Crypt-HCE_MD5/pkg-plist8
5 files changed, 51 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 48b992f2b55f..7961d040bab1 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -301,6 +301,7 @@
SUBDIR += p5-Crypt-ECB
SUBDIR += p5-Crypt-GPG
SUBDIR += p5-Crypt-GeneratePassword
+ SUBDIR += p5-Crypt-HCE_MD5
SUBDIR += p5-Crypt-HCE_SHA
SUBDIR += p5-Crypt-IDEA
SUBDIR += p5-Crypt-Lite
diff --git a/security/p5-Crypt-HCE_MD5/Makefile b/security/p5-Crypt-HCE_MD5/Makefile
new file mode 100644
index 000000000000..b0252f102159
--- /dev/null
+++ b/security/p5-Crypt-HCE_MD5/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: p5-Crypt-HCE_MD5
+# Date created: 17 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-HCE_MD5
+PORTVERSION= 0.70
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension implementing one way hash chaining encryption using MD5
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::HCE_MD5.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-HCE_MD5/distinfo b/security/p5-Crypt-HCE_MD5/distinfo
new file mode 100644
index 000000000000..9805bb74647d
--- /dev/null
+++ b/security/p5-Crypt-HCE_MD5/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-HCE_MD5-0.70.tar.gz) = 2fca1b79ee1a83854938f5c7711a19be
+SHA256 (Crypt-HCE_MD5-0.70.tar.gz) = a0f7c3baca1637c796dc7e65bdefd487ec1633fc17add3aebf32eec5c290449d
+SIZE (Crypt-HCE_MD5-0.70.tar.gz) = 5874
diff --git a/security/p5-Crypt-HCE_MD5/pkg-descr b/security/p5-Crypt-HCE_MD5/pkg-descr
new file mode 100644
index 000000000000..6d60d983bfbd
--- /dev/null
+++ b/security/p5-Crypt-HCE_MD5/pkg-descr
@@ -0,0 +1,15 @@
+This module implements a chaining block cipher using a one
+way hash. This method of encryption is the same that is
+used by radius (RFC2138) and is also described in Applied
+Cryptography.
+Two interfaces are provided in the module. The first is
+straight block encryption/decryption the second does base64
+mime encoding/decoding of the encrypted/decrypted blocks.
+The idea is the the two sides have a shared secret that
+supplies one of the keys and a randomly generated block of
+bytes provides the second key. The random key is passed in
+cleartext between the two sides.
+An example client and server are packaged as modules with
+this module. They are used in the tests.
+
+WWW: http://search.cpan.org/dist/Crypt-HECE_MD5
diff --git a/security/p5-Crypt-HCE_MD5/pkg-plist b/security/p5-Crypt-HCE_MD5/pkg-plist
new file mode 100644
index 000000000000..5b28579e3573
--- /dev/null
+++ b/security/p5-Crypt-HCE_MD5/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Crypt/HCE_MD5.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/HCE_MD5/.packlist
+%%SITE_PERL%%/auto/Crypt/HCE_MD5/autosplit.ix
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/HCE_MD5/
+@dirrm %%SITE_PERL%%/auto/Crypt/HCE_MD5/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Crypt 2>/dev/null || true