aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormarius <marius@FreeBSD.org>2004-10-21 02:22:23 +0800
committermarius <marius@FreeBSD.org>2004-10-21 02:22:23 +0800
commite7e9273ae0056b64b73580dc82a80072b0015500 (patch)
treed7b5a26b51069277968db52c243ebb74be73bce4 /security
parent3576892003a292f65b4cfdc41717e88210c20d21 (diff)
downloadfreebsd-ports-gnome-e7e9273ae0056b64b73580dc82a80072b0015500.tar.gz
freebsd-ports-gnome-e7e9273ae0056b64b73580dc82a80072b0015500.tar.zst
freebsd-ports-gnome-e7e9273ae0056b64b73580dc82a80072b0015500.zip
- Update to 1.1 (final). For changes since 1.1-beta see the ChangeLog
in the DOCSDIR. - Rename the start script from antivir-milter.sh to avmilter.sh to be consistent with naming of the rest of the installed AntiVir Milter files and directories. - Now that AntiVir Milter supports using a different location from /etc for the ignore, scan and warn config files no longer install them in the EXAMPLESDIR but in PREFIX/etc/avmilter (i.e. install as sample files, copy over when not already existent, etc.). - Change the location of the AntiVir Milter config file (avmilter.conf) but not that of the scan engine (antivir.conf; shared between different AntiVir products) from PREFIX/etc to PREFIX/etc/avmilter in order to have all AntiVir Milter config files in one place but don't directly populate PREFIX/etc with them. If you had previously changed PREFIX/etc/avmilter.conf you have to bring over your changes to PREFIX/etc/avmilter/avmilter.conf but note that some variables have been renamed. If you used ignore, scan and/or warn files in /etc you can now move them to PREFIX/etc/avmilter. Approved by: netchild
Diffstat (limited to 'security')
-rw-r--r--security/antivir-milter/Makefile41
-rw-r--r--security/antivir-milter/distinfo4
-rw-r--r--security/antivir-milter/files/patch-doc::MANUAL144
-rw-r--r--security/antivir-milter/files/patch-etc::avmilter.conf22
-rw-r--r--security/antivir-milter/files/patch-init::rc.avmilter17
-rw-r--r--security/antivir-milter/files/patch-pgp::README16
-rw-r--r--security/antivir-milter/files/patch-script::avq2
-rw-r--r--security/antivir-milter/pkg-descr2
-rw-r--r--security/antivir-milter/pkg-plist30
9 files changed, 159 insertions, 119 deletions
diff --git a/security/antivir-milter/Makefile b/security/antivir-milter/Makefile
index c2d0b1689dc5..08e8d6e8c82a 100644
--- a/security/antivir-milter/Makefile
+++ b/security/antivir-milter/Makefile
@@ -5,14 +5,11 @@
# $FreeBSD$
PORTNAME= antivir-milter
-PORTVERSION= 1.1.b
-PORTREVISION= 2
+PORTVERSION= 1.1
CATEGORIES= security mail
-#MASTER_SITES= ftp://ftp.antivir.de/freebsd/ \
-# http://www.antivir.de/dateien/antivir/release/
-MASTER_SITES= http://www.antivir.de/dateien/antivir/beta/freebsd/
-#DISTNAME= avfbmlt
-DISTNAME= avfbmlt_beta
+MASTER_SITES= ftp://ftp.antivir.de/freebsd/ \
+ http://dl.antivir.de/dateien/antivir/release/
+DISTNAME= avfbmlt
EXTRACT_SUFX= .tgz
MAINTAINER= marius@FreeBSD.org
@@ -27,7 +24,9 @@ NO_BUILD= yes
USE_REINPLACE= yes
# Auto re-fetch sucks!
FETCH_CMD= /usr/bin/fetch -A
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.b/-beta/}
+# When the avmilter binary is stripped its self-check fails.
+STRIP=
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
@@ -42,7 +41,7 @@ LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
post-patch:
.for i in doc/MANUAL etc/antivir.conf etc/avmilter.conf init/rc.avmilter \
- script/avq
+ pgp/README script/avq
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g; \
s|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/${i}
.endfor
@@ -56,38 +55,41 @@ post-patch:
do-install:
@${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755 ${PREFIX}/AntiVir
@${INSTALL} -o ${BINOWN} -g ${BINGRP} -m 755 ${WRKSRC}/bin/antivir \
- ${PREFIX}/AntiVir/antivir-dist_avfbmlt
+ ${PREFIX}/AntiVir/antivir-dist_avmilter
.if !exists(${PREFIX}/AntiVir/antivir)
@${INSTALL} -o ${BINOWN} -g ${BINGRP} -m 755 ${WRKSRC}/bin/antivir \
${PREFIX}/AntiVir
.endif
@${INSTALL} -o ${BINOWN} -g ${BINGRP} -m 644 ${WRKSRC}/vdf/antivir.vdf \
- ${PREFIX}/AntiVir/antivir.vdf-dist_avfbmlt
+ ${PREFIX}/AntiVir/antivir.vdf-dist_avmilter
.if !exists(${PREFIX}/AntiVir/antivir.vdf)
@${INSTALL} -o ${BINOWN} -g ${BINGRP} -m 644 ${WRKSRC}/vdf/antivir.vdf \
${PREFIX}/AntiVir
.endif
@${INSTALL_SCRIPT} ${WRKSRC}/script/avq ${PREFIX}/bin
-.for i in antivir.conf avmilter.conf
- @${INSTALL_DATA} ${WRKSRC}/etc/${i} ${PREFIX}/etc/${i}.sample
-.if !exists(${PREFIX}/etc/${i})
- @${INSTALL_DATA} ${WRKSRC}/etc/${i} ${PREFIX}/etc
+ @${INSTALL} -d ${PREFIX}/etc/avmilter
+.for i in avmilter.conf avmilter.ignore avmilter.scan avmilter.warn
+ @${INSTALL_DATA} ${WRKSRC}/etc/${i} ${PREFIX}/etc/avmilter/${i}.sample
+.if !exists(${PREFIX}/etc/avmilter/${i})
+ @${INSTALL_DATA} ${WRKSRC}/etc/${i} ${PREFIX}/etc/avmilter
.endif
.endfor
+ @${INSTALL_DATA} ${WRKSRC}/etc/antivir.conf \
+ ${PREFIX}/etc/antivir.conf.sample
+.if !exists(${PREFIX}/etc/antivir.conf)
+ @${INSTALL_DATA} ${WRKSRC}/etc/antivir.conf ${PREFIX}/etc
+.endif
@${INSTALL_PROGRAM} ${WRKSRC}/bin/avmilter ${PREFIX}/sbin
@${INSTALL_SCRIPT} ${WRKDIR}/antivirupdater.sh \
${PREFIX}/sbin/antivirupdater
@${INSTALL_SCRIPT} ${WRKDIR}/avqrm.sh ${PREFIX}/bin/avqrm
@${INSTALL_SCRIPT} ${WRKSRC}/init/rc.avmilter \
- ${PREFIX}/etc/rc.d/antivir-milter.sh
+ ${PREFIX}/etc/rc.d/avmilter.sh
@${INSTALL} -d -o smmsp -g smmsp -m 700 /var/spool/avmilter
.for i in incoming outgoing rejected
@${INSTALL} -d -o smmsp -g smmsp -m 700 /var/spool/avmilter/${i}
.endfor
@${INSTALL} -d ${EXAMPLESDIR}
-.for i in avmilter.ignore avmilter.scan avmilter.warn
- @${INSTALL_DATA} ${WRKSRC}/etc/${i} ${EXAMPLESDIR}
-.endfor
.for i in de en es hu it nl
@${INSTALL} -d ${EXAMPLESDIR}/templates/${i}
.for j in patho-administrator patho-recipient patho-sender virus-administrator \
@@ -105,6 +107,7 @@ do-install:
.for i in avmilter_de.pdf avmilter_en.pdf
@${INSTALL_DATA} ${WRKSRC}/doc/${i} ${DOCSDIR}
.endfor
+ @${INSTALL_DATA} ${WRKSRC}/pgp/README ${DOCSDIR}/README.gpg
@${INSTALL_DATA} ${WRKSRC}/pgp/antivir.gpg ${DOCSDIR}
.endif
diff --git a/security/antivir-milter/distinfo b/security/antivir-milter/distinfo
index f5491ef4eb28..6148b7b656b1 100644
--- a/security/antivir-milter/distinfo
+++ b/security/antivir-milter/distinfo
@@ -1,2 +1,2 @@
-MD5 (avfbmlt_beta.tgz) = 0005a0cb1f2757c357e85400a0936316
-SIZE (avfbmlt_beta.tgz) = 2597582
+MD5 (avfbmlt.tgz) = 86af07e84e3522a11c66dcb49cbc3306
+SIZE (avfbmlt.tgz) = 2869629
diff --git a/security/antivir-milter/files/patch-doc::MANUAL b/security/antivir-milter/files/patch-doc::MANUAL
index b1493cebb363..0ea99b938644 100644
--- a/security/antivir-milter/files/patch-doc::MANUAL
+++ b/security/antivir-milter/files/patch-doc::MANUAL
@@ -1,11 +1,11 @@
--- doc/MANUAL.orig Wed Jan 28 11:48:04 2004
+++ doc/MANUAL Mon Mar 1 01:08:06 2004
-@@ -3,39 +3,39 @@
+@@ -24,37 +24,38 @@
To start, stop, restart AntiVir Milter:
- # /usr/sbin/rcavmilter [start|stop|status|restart]
-+ # %%PREFIX%%/etc/rc.d/antivir-milter.sh [start|stop|status|restart]
++ # %%PREFIX%%/etc/rc.d/avmilter.sh [start|stop|status|restart]
When executed successfully, a message from AntiVir Milter with
the scan engine version and VDF version is present in the log file
@@ -16,60 +16,51 @@
2. Copying the license file
---------------------------
- If you have a license file for commercial or privat user,
--copy the license file *.key to the folder /usr/lib/AntiVir and
+-Copy the license file *.key to the folder /usr/lib/AntiVir and
-set the access rights of user and group to default uucp:
--
++Copy the license file *.key to the folder %%PREFIX%%/AntiVir and
++set the access rights of user root and group to smmsp:
+
- # cp hbedv.key /usr/lib/AntiVir/
- # chown uucp:uucp /usr/lib/AntiVir/avmgate.key
-+copy the license file *.key to the folder %%PREFIX%%/AntiVir and
-+set the access rights of user root and group smmsp:
-
+ # cp hbedv.key %%PREFIX%%/AntiVir/
+ # chown root:smmsp %%PREFIX%%/AntiVir/hbedv.key
+ # chmod 440 %%PREFIX%%/AntiVir/hbedv.key
+
3. Configuring AntiVir Milter
-----------------------------
-AntiVir Milter provides the configuration file /etc/avmilter.conf:
-+AntiVir Milter provides the configuration file %%PREFIX%%/etc/avmilter.conf:
- The following directives are available:
-
--# User uucp
--# Group uucp
-+# User smmsp
-+# Group smmsp
- # Postmaster postmaster
- # MyHostName localhost
- # SpoolDir /var/spool/avmilter
--# AntiVirDir /usr/lib/AntiVir
-+# AntiVirDir %%PREFIX%%/AntiVir
- # TemporaryDir /var/tmp
- # MinFreeBlocks 100
--# ForwardTo /usr/lib/sendmail -oem -oi
-+# ForwardTo /usr/sbin/sendmail -oem -oi
- # MaxNestingLevel 20
- # MaxAttachments 100
- # BlockSuspiciousMime NO
-@@ -43,7 +43,7 @@
- # VirusAlertToRcpt NO
- # VirusAlertToSender NO
- # VirusAlertToPostmaster YES
--# VirusAlertsUser AntiVir
-+# VirusAlertsUser MAILER-DAEMON
- # RejectVirusMail NO
- # ScanInArchive YES
- # ArchiveMaxSize 0
-@@ -64,21 +64,21 @@
- # LogFile NO
- # MaxRecipientsPerMessage 100
-
--For a detailed description see /etc/avmilter.conf.
-+For a detailed description see %%PREFIX%%/etc/avmilter.conf.
-
-
- 4. Configuring automatic update
+-The following directives are available:
++AntiVir Milter provides the following directives in the configuration file
++%%PREFIX%%/etc/avmilter/avmilter.conf:
+
+-# User uucp
+-# Group uucp
++# User smmsp
++# Group smmsp
+ # Postmaster postmaster
+ # MyHostName localhost
+ # SpoolDir /var/spool/avmilter
+-# AntiVirDir /usr/lib/AntiVir
++# AntiVirDir %%PREFIX%%/AntiVir
+ # TemporaryDir /var/tmp
+-# ForwardTo /usr/lib/sendmail -oem -oi
++# ForwardTo /usr/sbin/sendmail -oem -oi
+ # MaxNestingLevel same as ArchiveMaxRecursion
+ # MaxAttachments 100
+ # BlockSuspiciousMime NO
+@@ -62,7 +63,7 @@
+ # ExposeRecipientAlerts NO
+ # ExposeSenderAlerts NO
+ # ExposePostmasterAlerts YES
+-# AlertsUser AntiVir
++# AlertsUser MAILER-DAEMON
+ # RejectAlertMail NO
+ # QuarantineAlert YES
+ # ScanInArchive YES
+@@ -93,13 +94,13 @@
-------------------------------
Add the following line for a daily update at e.g. 0:25 a.m.:
@@ -80,29 +71,23 @@
in the file antivir.conf.
-The file /etc/antivir.conf contains settable parameters effecting
--the automatic virus protection updates. The following directives
--are provided:
+-the automatic protection updates. The following directives
+The file %%PREFIX%%/etc/antivir.conf contains settable parameters
-+effecting the automatic virus protection updates. The following
-+directives are provided:
-
- # EmailTo root@localhost
- # LogTo /var/log/antivir.log
-@@ -88,10 +88,10 @@
- # HTTPProxyPassword password
- # SyslogFacility user
- # SyslogPriority notice
++effecting the automatic protection updates. The following directives
+ are provided:
+
+ # EmailTo root@localhost
+@@ -113,7 +114,7 @@
+ # HTTPProxyPassword password
+ # SyslogFacility user
+ # SyslogPriority notice
-# GnuPGBinary
-+# GnuPGBinary %%PREFIX%%/bin/gpg
++# GnuPGBinary %%LOCALBASE%%/bin/gpg
# GnuPGOptions
-
--For a detailled description see /etc/avmilter.conf.
-+For a detailled description see %%PREFIX%%/etc/avmilter.conf.
-
-
- 5. Notification Templates
-@@ -101,7 +101,7 @@
- have the possibility to define your own text in virus and
+ # DetectDialer
+ # DetectJoke
+@@ -133,7 +134,7 @@
+ you have the possibility to define your own text in alert and
pathological notification mails.
-The directory /usr/lib/AntiVir/templates contains the
@@ -110,3 +95,32 @@
following files:
patho-administrator
+@@ -190,14 +191,15 @@
+ will be printed to syslog:
+ (avmilter[1234]: Mail from foo@bar.tld to john@doe.tld will be scanned!)
+
+-The tables are: /etc/avmilter.scan and /etc/avmilter.ignore.
++The tables are: %%PREFIX%%/etc/avmilter/avmilter.scan and
++%%PREFIX%%/etc/avmilter/avmilter.ignore.
+ Example files are included in this package.
+ Each table consists of an address that contains regular expressions
+ and one and/or two flags:
+
+ Examples:
+ ----------------------
+-/etc/avmilter.scan:
++avmilter.scan:
+ The i is an option for the regexp and it means ignore case.
+
+ #The following matches exactly the *recipient* address "foo@bar.tld"
+@@ -298,8 +300,8 @@
+ 11. Notice Mail Restrictions
+ ------------------------
+
+-In the /etc/avmilter.warn file one can specify who receives a
+-mail in case of an alert.
++In the %%PREFIX%%/etc/avmilter/avmilter.warn file one can specify
++who receives a mail in case of an alert.
+ The definition there is used instead of the definition in the
+ avmilter.conf (Expose*Alerts).
+
diff --git a/security/antivir-milter/files/patch-etc::avmilter.conf b/security/antivir-milter/files/patch-etc::avmilter.conf
index 71a0e52da1c4..7b22e1987b96 100644
--- a/security/antivir-milter/files/patch-etc::avmilter.conf
+++ b/security/antivir-milter/files/patch-etc::avmilter.conf
@@ -20,7 +20,7 @@
# ------------------------------------------------------------------------
-@@ -66,7 +66,7 @@
+@@ -65,7 +65,7 @@
# Select the directory and binary of sendmail and the arguments how to
# call sendmail.
@@ -29,7 +29,7 @@
# ------------------------------------------------------------------------
-@@ -93,7 +93,7 @@
+@@ -85,7 +85,7 @@
# Block mails which are coded as a fragmented message.
# "Message Fragmentation and Reassembly" (RFC2046, section 5.2.2.1).
@@ -38,15 +38,15 @@
# ------------------------------------------------------------------------
-@@ -121,6 +121,7 @@
- # VirusAlertsUser AvMilter
+@@ -113,6 +113,7 @@
+ # AlertsUser AvMilter
# or
- # VirusAlertsUser someone@anywhere.tld
-+VirusAlertsUser MAILER-DAEMON
+ # AlertsUser someone@anywhere.tld
++AlertsUser MAILER-DAEMON
# ------------------------------------------------------------------------
-@@ -171,7 +172,7 @@
+@@ -183,7 +184,7 @@
# If BlockSuspiciousArchive is YES, stop delivery of mails
# containing archives if ArchiveMaxRecursion has been reached.
@@ -55,7 +55,7 @@
# ------------------------------------------------------------------------
-@@ -181,7 +182,7 @@
+@@ -193,7 +194,7 @@
# If BlockEncryptedArchive is YES, stop delivery of mails
# containing encrypted files in an archive.
@@ -64,7 +64,7 @@
# ------------------------------------------------------------------------
-@@ -189,7 +190,7 @@
+@@ -201,7 +202,7 @@
# to the header of checked mail. E.g.: "X-AntiVirus: Checked by ..."
# This option is only available in commercial mode.
@@ -73,7 +73,7 @@
# ------------------------------------------------------------------------
-@@ -204,7 +205,7 @@
+@@ -216,7 +217,7 @@
# ScanTimeout specifies the scan time of mail, in seconds, when to stop
# scanning of mails.
@@ -82,7 +82,7 @@
# ------------------------------------------------------------------------
-@@ -213,6 +214,11 @@
+@@ -224,6 +225,11 @@
# rejected message.
# ExternalProgram /dir/my_own_script
diff --git a/security/antivir-milter/files/patch-init::rc.avmilter b/security/antivir-milter/files/patch-init::rc.avmilter
index 485e62a926a8..9498783d9e16 100644
--- a/security/antivir-milter/files/patch-init::rc.avmilter
+++ b/security/antivir-milter/files/patch-init::rc.avmilter
@@ -1,31 +1,30 @@
--- init/rc.avmilter.orig Sun Sep 21 19:51:22 2003
+++ init/rc.avmilter Sun Sep 21 20:22:38 2003
-@@ -14,20 +14,27 @@
+@@ -15,13 +15,19 @@
case "$1" in
start)
- echo "Starting AntiVir Milter."
-- /usr/sbin/avmilter -p inet:3333@localhost
+- /usr/sbin/avmilter
+ if [ -x %%PREFIX%%/sbin/avmilter ]; then
+ umask 0077
+ /bin/rm -f /var/spool/avmilter/avmilter.sock
+ /usr/sbin/daemon -f %%PREFIX%%/sbin/avmilter \
-+ -C %%PREFIX%%/etc/avmilter.conf \
++ -P %%PREFIX%%/etc/avmilter \
+ -p local:/var/spool/avmilter/avmilter.sock &
+ umask 0022
-+ echo -n " antivir-milter"
++ echo -n " avmilter"
+ fi
;;
stop)
- echo -n "Shutting down AntiVir Milter."
-- killall -TERM /usr/sbin/avmilter
+ killall -TERM avmilter
- echo
-+ /usr/bin/killall -TERM avmilter
-+ /bin/rm -f /var/spool/avmilter/avmilter.sock
-+ echo -n " antivir-milter"
++ echo -n " avmilter"
;;
restart)
"$0" stop
+@@ -29,7 +35,7 @@
"$0" start
;;
status)
@@ -34,7 +33,7 @@
then
echo "FAILED avmilter is not running!"
else
-@@ -35,7 +42,7 @@
+@@ -37,7 +43,7 @@
fi
;;
*)
diff --git a/security/antivir-milter/files/patch-pgp::README b/security/antivir-milter/files/patch-pgp::README
new file mode 100644
index 000000000000..8922c938286d
--- /dev/null
+++ b/security/antivir-milter/files/patch-pgp::README
@@ -0,0 +1,16 @@
+--- pgp/README.orig Fri Oct 1 11:25:22 2004
++++ pgp/README Tue Oct 12 17:50:07 2004
+@@ -58,10 +58,10 @@
+
+
+ 7. Activate GnuPG in AntiVir by adding the GnuPGBinary directive to the
+- /etc/antivir.conf file. This directive takes as argument the full path
+- to your GnuPG binary. Typically it would look like this:
++ %%PREFIX%%/etc/antivir.conf file. This directive takes as argument the
++ full path to your GnuPG binary. Typically it would look like this:
+
+- GnuPGBinary /usr/local/bin/gpg
++ GnuPGBinary %%LOCALBASE%%/bin/gpg
+
+
+ Note: Currently only engine or program updates utilize GnuPG. VDF file
diff --git a/security/antivir-milter/files/patch-script::avq b/security/antivir-milter/files/patch-script::avq
index e8bf04137efa..dcde2cf423e6 100644
--- a/security/antivir-milter/files/patch-script::avq
+++ b/security/antivir-milter/files/patch-script::avq
@@ -5,7 +5,7 @@
#******************************************************************************
-configuration=/etc/avmilter.conf
-+configuration=%%PREFIX%%/etc/avmilter.conf
++configuration=%%PREFIX%%/etc/avmilter/avmilter.conf
queue="`egrep -i '^[Ss][Pp][Oo][Oo][Ll][Dd][Ii][Rr]' ${configuration} | awk '{print $2;}'`"
queue_set=0
pname="`basename $0`"
diff --git a/security/antivir-milter/pkg-descr b/security/antivir-milter/pkg-descr
index d57e810e1057..d1457ff289f1 100644
--- a/security/antivir-milter/pkg-descr
+++ b/security/antivir-milter/pkg-descr
@@ -18,7 +18,7 @@ Functions:
- Immediate activation, if new virus definition file (.VDF) is available
- Heuristic macro-virus detection
- Modifiable templates to create own alert messages
-- Scanning in archives (19 formats are supported)
+- Scanning in archives (24 formats are supported)
AntiVir Milter is free of charge for private (individual, non-commercial) use.
diff --git a/security/antivir-milter/pkg-plist b/security/antivir-milter/pkg-plist
index 2ac8b81a59c3..8055da190f48 100644
--- a/security/antivir-milter/pkg-plist
+++ b/security/antivir-milter/pkg-plist
@@ -1,19 +1,29 @@
-@unexec if cmp -s %D/AntiVir/antivir-dist_avfbmlt %D/AntiVir/antivir; then rm -f %D/AntiVir/antivir; fi
-AntiVir/antivir-dist_avfbmlt
+@unexec if cmp -s %D/AntiVir/antivir-dist_avmilter %D/AntiVir/antivir; then rm -f %D/AntiVir/antivir; fi
+AntiVir/antivir-dist_avmilter
@exec [ -f %B/antivir ] || cp -p %B/%f %B/antivir
-@unexec if cmp -s %D/AntiVir/antivir.vdf-dist_avfbmlt %D/AntiVir/antivir.vdf; then rm -f %D/AntiVir/antivir.vdf; fi
-AntiVir/antivir.vdf-dist_avfbmlt
+@unexec if cmp -s %D/AntiVir/antivir.vdf-dist_avmilter %D/AntiVir/antivir.vdf; then rm -f %D/AntiVir/antivir.vdf; fi
+AntiVir/antivir.vdf-dist_avmilter
@exec [ -f %B/antivir.vdf ] || cp -p %B/%f %B/antivir.vdf
@unexec rmdir %D/AntiVir 2> /dev/null || echo "If permanently deleting this package, %D/AntiVir and its contents must be removed manually."
bin/avq
bin/avqrm
+@unexec if cmp -s %D/etc/avmilter/avmilter.conf.sample %D/etc/avmilter/avmilter.conf; then rm -f %D/etc/avmilter/avmilter.conf; else echo "If permanently deleting this package, %D/etc/avmilter/avmilter.conf must be removed manually."; fi
+etc/avmilter/avmilter.conf.sample
+@exec [ -f %B/avmilter.conf ] || cp %B/%f %B/avmilter.conf
+@unexec if cmp -s %D/etc/avmilter/avmilter.ignore.sample %D/etc/avmilter/avmilter.ignore; then rm -f %D/etc/avmilter/avmilter.ignore; else echo "If permanently deleting this package, %D/etc/avmilter/avmilter.ignore must be removed manually."; fi
+etc/avmilter/avmilter.ignore.sample
+@exec [ -f %B/avmilter.ignore ] || cp %B/%f %B/avmilter.ignore
+@unexec if cmp -s %D/etc/avmilter/avmilter.scan.sample %D/etc/avmilter/avmilter.scan; then rm -f %D/etc/avmilter/avmilter.scan; else echo "If permanently deleting this package, %D/etc/avmilter/avmilter.scan must be removed manually."; fi
+etc/avmilter/avmilter.scan.sample
+@exec [ -f %B/avmilter.scan ] || cp %B/%f %B/avmilter.scan
+@unexec if cmp -s %D/etc/avmilter/avmilter.warn.sample %D/etc/avmilter/avmilter.warn; then rm -f %D/etc/avmilter/avmilter.warn; else echo "If permanently deleting this package, %D/etc/avmilter/avmilter.warn must be removed manually."; fi
+etc/avmilter/avmilter.warn.sample
+@exec [ -f %B/avmilter.warn ] || cp %B/%f %B/avmilter.warn
+@unexec rmdir %D/etc/avmilter 2> /dev/null || echo "If permanently deleting this package, %D/etc/avmilter and its contents must be removed manually."
@unexec if cmp -s %D/etc/antivir.conf.sample %D/etc/antivir.conf; then rm -f %D/etc/antivir.conf; else echo "If permanently deleting this package, %D/etc/antivir.conf must be removed manually."; fi
etc/antivir.conf.sample
@exec [ -f %B/antivir.conf ] || cp %B/%f %B/antivir.conf
-@unexec if cmp -s %D/etc/avmilter.conf.sample %D/etc/avmilter.conf; then rm -f %D/etc/avmilter.conf; else echo "If permanently deleting this package, %D/etc/avmilter.conf must be removed manually."; fi
-etc/avmilter.conf.sample
-@exec [ -f %B/avmilter.conf ] || cp %B/%f %B/avmilter.conf
-etc/rc.d/antivir-milter.sh
+etc/rc.d/avmilter.sh
sbin/antivirupdater
sbin/avmilter
@exec install -d -o smmsp -g smmsp -m 700 /var/spool/avmilter
@@ -24,9 +34,6 @@ sbin/avmilter
@unexec rmdir /var/spool/avmilter/outgoing 2> /dev/null || true
@unexec rmdir /var/spool/avmilter/rejected 2> /dev/null || true
@unexec rmdir /var/spool/avmilter 2> /dev/null || echo "If permanently deleting this package, /var/spool/avmilter and its contents must be removed manually."
-%%EXAMPLESDIR%%/avmilter.ignore
-%%EXAMPLESDIR%%/avmilter.scan
-%%EXAMPLESDIR%%/avmilter.warn
%%EXAMPLESDIR%%/templates/de/patho-administrator
%%EXAMPLESDIR%%/templates/de/patho-recipient
%%EXAMPLESDIR%%/templates/de/patho-sender
@@ -75,6 +82,7 @@ sbin/avmilter
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/LICENSE.DE
%%PORTDOCS%%%%DOCSDIR%%/MANUAL
+%%PORTDOCS%%%%DOCSDIR%%/README.gpg
%%PORTDOCS%%%%DOCSDIR%%/avmilter_de.pdf
%%PORTDOCS%%%%DOCSDIR%%/avmilter_en.pdf
%%PORTDOCS%%%%DOCSDIR%%/antivir.gpg