aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-03-28 21:16:01 +0800
committerpav <pav@FreeBSD.org>2004-03-28 21:16:01 +0800
commitec9ed65aa310db947dff0ed6c275e11fb89c59bb (patch)
treea27048ed4dd49310803690c5e90fa4f4ed18941a /security
parentd6ac2a1b0631ebc67cdd7df2044e79a2193094a3 (diff)
downloadfreebsd-ports-gnome-ec9ed65aa310db947dff0ed6c275e11fb89c59bb.tar.gz
freebsd-ports-gnome-ec9ed65aa310db947dff0ed6c275e11fb89c59bb.tar.zst
freebsd-ports-gnome-ec9ed65aa310db947dff0ed6c275e11fb89c59bb.zip
- fix dependencies for modules already included in perl 5.8 (PR 64374)
- remove dependency on Carp::Heavy module which is not available with stock FreeBSD 4.9 perl - add official post -p8 buglet fixes which will be included in -p9 - add size information to distinfo - bump portrevision PR: ports/64589 Submitted by: Blaz Zupan <blaz.zupan@amis.net> (maintainer)
Diffstat (limited to 'security')
-rw-r--r--security/amavisd-new/Makefile14
-rw-r--r--security/amavisd-new/distinfo1
-rw-r--r--security/amavisd-new/files/patch-amavisd38
3 files changed, 43 insertions, 10 deletions
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index 6a5a29385354..5351c143c3ce 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -8,8 +8,9 @@
PORTNAME= amavisd-new
PORTVERSION= 20030616.p8
+PORTREVISION= 1
CATEGORIES= security
-MASTER_SITES= http://www.ijs.si/software/amavisd/ \
+MASTER_SITES= http://www.ijs.si/software/amavisd/ \
http://mirrors.catpipe.net/amavisd-new/ \
http://ftp.cfu.net/pub/amavisd-new/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/-p/}
@@ -17,15 +18,13 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/-p/}
MAINTAINER= blaz@si.FreeBSD.org
COMMENT= Performance-enhanced daemonized version of amavis-perl
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
- ${SITE_PERL}/${PERL_ARCH}/Unix/Syslog.pm:${PORTSDIR}/sysutils/p5-Unix-Syslog \
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Unix/Syslog.pm:${PORTSDIR}/sysutils/p5-Unix-Syslog \
${SITE_PERL}/MIME/Words.pm:${PORTSDIR}/mail/p5-MIME-Tools \
${SITE_PERL}/Convert/TNEF.pm:${PORTSDIR}/converters/p5-Convert-TNEF \
${SITE_PERL}/${PERL_ARCH}/Convert/UUlib.pm:${PORTSDIR}/converters/p5-Convert-UUlib \
${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/Net/Server.pm:${PORTSDIR}/net/p5-Net-Server \
${SITE_PERL}/Mail/SpamAssassin.pm:${PORTSDIR}/mail/p5-Mail-SpamAssassin \
${LOCALBASE}/bin/arc:${PORTSDIR}/archivers/arc \
@@ -106,7 +105,12 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500601
+.if ${PERL_LEVEL} < 500800
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+.endif
+
+.if ${PERL_LEVEL} < 500600
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/IO/Socket/UNIX.pm:${PORTSDIR}/devel/p5-IO
.endif
diff --git a/security/amavisd-new/distinfo b/security/amavisd-new/distinfo
index d467666ab3d1..a25a802a4661 100644
--- a/security/amavisd-new/distinfo
+++ b/security/amavisd-new/distinfo
@@ -1 +1,2 @@
MD5 (amavisd-new-20030616-p8.tar.gz) = 5b55cef4ef4cc717b9ee1ed204a1ed96
+SIZE (amavisd-new-20030616-p8.tar.gz) = 328420
diff --git a/security/amavisd-new/files/patch-amavisd b/security/amavisd-new/files/patch-amavisd
index ed4a1d619d04..8cba9aecfa18 100644
--- a/security/amavisd-new/files/patch-amavisd
+++ b/security/amavisd-new/files/patch-amavisd
@@ -1,11 +1,39 @@
---- amavisd.orig Mon Nov 10 01:22:13 2003
-+++ amavisd Tue Nov 11 22:42:47 2003
-@@ -6279,7 +6279,7 @@
- my($amavisd_path) = find_program_path($0, [split(/:/, $path, -1)], 0);
+--- amavisd.orig Tue Mar 9 03:21:43 2004
++++ amavisd Mon Mar 22 20:26:59 2004
+@@ -109,7 +109,7 @@
+
+ BEGIN {
+ fetch_modules('REQUIRED BASIC MODULES', 1, qw(
+- Exporter POSIX Fcntl Socket Errno Carp Carp::Heavy Time::HiRes
++ Exporter POSIX Fcntl Socket Errno Carp Time::HiRes
+ IO::File IO::Socket IO::Socket::UNIX IO::Socket::INET
+ IO::Handle IO::Wrap IO::Stringy
+ Digest::MD5 Unix::Syslog File::Basename File::Copy
+@@ -5358,7 +5358,8 @@
+ }
+ section_time('parts'); prolong_timer('decoding');
+ }
+- if ($any_undecipherable) { # test if undecipherables are banned
++ if ($any_undecipherable && $banned_filename_re) {
++ # test if undecipherables are banned
+ my($rn) = 'UNDECIPHERABLE';
+ my($result,$patt) = $banned_filename_re->lookup_re($rn);
+ if ($result) {
+@@ -5920,7 +5921,7 @@
+ $s = $undecipherable_subject_tag;
+ do_log(3,"adding $undecipherable_subject_tag, $any_undecipherable, $hold");
+ }
+- $s .= $sa_spam_subject_tag;
++ $s .= $sa_spam_subject_tag if $do_subj;
+ my($entity) = $msginfo->mime_entity;
+ if (defined $entity && defined $entity->head->get('Subject',0)) {
+ $hdr_edits->edit_header('Subject',
+@@ -6420,7 +6421,7 @@
+ local($1);
$amavisd_path = $1 if $amavisd_path=~m{^([A-Za-z0-9/._=+-]+)$(?!\n)}; # untaint
-my($config_file) = '/etc/amavisd.conf'; # default location of config file
+my($config_file) = '%%PREFIX%%/etc/amavisd.conf'; # default location of config file
if (@ARGV >= 2 && $ARGV[0] eq '-c') { # override by command line option -c
shift @ARGV; $config_file = shift @ARGV;
- $config_file = $1 if $config_file=~m{^([A-Za-z0-9/._=+-]+)$(?!\n)};# untaint
+ local($1);