aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-01-09 21:16:49 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-01-09 21:16:49 +0800
commitf3daf2261fb178366adda1ccfd67d90513f16f2a (patch)
tree263754af5ddd95f1ad55b06c101378a0cf71009b /security
parentcc1bd708b05005e884e1cb06113168318d3dbe5a (diff)
downloadfreebsd-ports-gnome-f3daf2261fb178366adda1ccfd67d90513f16f2a.tar.gz
freebsd-ports-gnome-f3daf2261fb178366adda1ccfd67d90513f16f2a.tar.zst
freebsd-ports-gnome-f3daf2261fb178366adda1ccfd67d90513f16f2a.zip
- Remove always-true/false conditions after FreeBSD 9, 10.1, 10.2 EOL
Approved by: portmgr blanket
Diffstat (limited to 'security')
-rw-r--r--security/acme-client/Makefile9
-rw-r--r--security/fastd/Makefile9
-rw-r--r--security/hpenc/Makefile6
-rw-r--r--security/pidgin-otr/Makefile6
-rw-r--r--security/s2n/Makefile7
-rw-r--r--security/tor-devel/Makefile4
-rw-r--r--security/tor/Makefile4
7 files changed, 2 insertions, 43 deletions
diff --git a/security/acme-client/Makefile b/security/acme-client/Makefile
index 9004b071123c..35eb3a7233e1 100644
--- a/security/acme-client/Makefile
+++ b/security/acme-client/Makefile
@@ -53,14 +53,7 @@ LDFLAGS+= -L${WRKDIR}/libressl/lib
. ifnmake describe
STAGEDIR_libressl!= ${MAKE} -V STAGEDIR -C ${PORTSDIR}/security/libressl
. endif
-# security/libressl ignores implicit SSP_UNSAFE, see Mk/bsd.ssp.mk
-. if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000036 && ${ARCH} == i386
-SSP_CFLAGS?= -fstack-protector
-CFLAGS+= ${SSP_CFLAGS}
-LDFLAGS+= -fstack-protector
-LIBS+= -lssp_nonshared
-. endif
-
+
pre-configure:
@(cd ${STAGEDIR_libressl}${LOCALBASE} && ${COPYTREE_SHARE} \
. ${WRKDIR}/libressl "! -name *.so*")
diff --git a/security/fastd/Makefile b/security/fastd/Makefile
index a9e8af2efdfa..f9a09de529fc 100644
--- a/security/fastd/Makefile
+++ b/security/fastd/Makefile
@@ -23,14 +23,7 @@ USE_RC_SUBR= fastd
PLIST_FILES= bin/fastd \
man/man1/fastd.1.gz
-.include <bsd.port.pre.mk>
-
-# GCC from base does not support -mpclmul.
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000024
-CMAKE_ARGS+= -DWITH_MAC_GHASH_PCLMULQDQ=FALSE
-.endif
-
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/fastd.1 ${STAGEDIR}${PREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/hpenc/Makefile b/security/hpenc/Makefile
index 548e58031bd2..e89c0e4027ce 100644
--- a/security/hpenc/Makefile
+++ b/security/hpenc/Makefile
@@ -27,12 +27,6 @@ CXXFLAGS+= -std=c++11 \
-I${OPENSSLINC}
LDFLAGS+= -pthread -lcrypto -L${OPENSSLLIB}
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000036
-WITH_OPENSSL_PORT= yes
-.endif
-
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/hpenc.1 ${STAGEDIR}${MANPREFIX}/man/man1
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/hpenc
diff --git a/security/pidgin-otr/Makefile b/security/pidgin-otr/Makefile
index 6326d7552482..a0b8a9f0a749 100644
--- a/security/pidgin-otr/Makefile
+++ b/security/pidgin-otr/Makefile
@@ -37,10 +37,4 @@ OPTIONS_SUB= yes
NLS_USES= gettext
NLS_USES_OFF= gettext-tools
-.include <bsd.port.options.mk>
-
-.if ${OSVERSION} < 1000036 && ${ARCH} == i386
-LDFLAGS+= -lssp_nonshared
-.endif
-
.include <bsd.port.mk>
diff --git a/security/s2n/Makefile b/security/s2n/Makefile
index 999e1977cf14..b99a8647724c 100644
--- a/security/s2n/Makefile
+++ b/security/s2n/Makefile
@@ -23,13 +23,6 @@ NO_CONFIGURE= yes
SUB_FILES= pkg-message Makefile
ALL_TARGET= bin
-.include <bsd.port.options.mk>
-
-.if ${OSVERSION} < 1000015
-WITH_OPENSSL_PORT= yes
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|CFLAGS |&+|' ${WRKSRC}/s2n.mk
@${REINPLACE_CMD} -e 's|CRYPTO_LDFLAGS |&+|' \
diff --git a/security/tor-devel/Makefile b/security/tor-devel/Makefile
index 857c7683b102..d1619003bad7 100644
--- a/security/tor-devel/Makefile
+++ b/security/tor-devel/Makefile
@@ -49,10 +49,6 @@ STATIC_TOR_USES_OFF= ssl
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 1000000
-WITH_OPENSSL_PORT= yes
-.endif
-
.if !defined(USE_GCC) && empty(CC:T:M*gcc4*) && \
empty(PORT_OPTIONS:MSTATIC_TOR) && empty(ARCH:Mia64)
CONFIGURE_ARGS+= --enable-gcc-hardening
diff --git a/security/tor/Makefile b/security/tor/Makefile
index 3c04bc632669..c5b4fee6eb98 100644
--- a/security/tor/Makefile
+++ b/security/tor/Makefile
@@ -48,10 +48,6 @@ STATIC_TOR_USES_OFF= ssl
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 1000000
-WITH_OPENSSL_PORT= yes
-.endif
-
.if !defined(USE_GCC) && empty(CC:T:M*gcc4*) && \
empty(PORT_OPTIONS:MSTATIC_TOR) && empty(ARCH:Mia64)
CONFIGURE_ARGS+= --enable-gcc-hardening