aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-01-25 01:09:46 +0800
committergarga <garga@FreeBSD.org>2006-01-25 01:09:46 +0800
commitf85146b751ddedc815fc9c12c343addd112a7b68 (patch)
treecd10c9585f4d09630523f9933699a13e0e64ed3d /security
parentea123fc89d8ee3dde78945cd2b5773192036e087 (diff)
downloadfreebsd-ports-gnome-f85146b751ddedc815fc9c12c343addd112a7b68.tar.gz
freebsd-ports-gnome-f85146b751ddedc815fc9c12c343addd112a7b68.tar.zst
freebsd-ports-gnome-f85146b751ddedc815fc9c12c343addd112a7b68.zip
We all know that you should always check input variables, but PHP does not
offer really good functionality for doing this in a safe way. The Input Filter extension is meant to address this issue by implementing a set of filters and mechanisms that users can use to safely access their input data. WWW: http://pecl.php.net/package/filter PR: ports/92198 Submitted by: Alexander Zhuravlev <zaa@zaa.pp.ru>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/pecl-filter/Makefile31
-rw-r--r--security/pecl-filter/distinfo3
-rw-r--r--security/pecl-filter/pkg-descr7
4 files changed, 42 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 4f54592f5c0c..6fda48cfff9c 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -449,6 +449,7 @@
SUBDIR += pear-LiveUser
SUBDIR += pear-LiveUser_Admin
SUBDIR += pear-Text_Password
+ SUBDIR += pecl-filter
SUBDIR += pecl-hash
SUBDIR += pecl-ssh2
SUBDIR += pft
diff --git a/security/pecl-filter/Makefile b/security/pecl-filter/Makefile
new file mode 100644
index 000000000000..274f237b1a3e
--- /dev/null
+++ b/security/pecl-filter/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: pecl-filter
+# Date created: 2006-01-23
+# Whom: Alexander Zhuravlev <zaa@zaa.pp.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= filter
+DISTVERSION= 0.9.4
+CATEGORIES= security
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= zaa@zaa.pp.ru
+COMMENT= PHP extension for safely dealing with input parameters
+
+LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHPEXT= yes
+PHP_MODNAME= filter
+
+DEFAULT_PHP_VER= 5
+BROKEN_WITH_VER= 4
+
+CONFIGURE_ARGS+= --with-pcre-dir=${LOCALBASE}
+
+.include <bsd.port.mk>
diff --git a/security/pecl-filter/distinfo b/security/pecl-filter/distinfo
new file mode 100644
index 000000000000..8c8137e384da
--- /dev/null
+++ b/security/pecl-filter/distinfo
@@ -0,0 +1,3 @@
+MD5 (PECL/filter-0.9.4.tgz) = bd1e15d31d89776f80e192f0828a46a8
+SHA256 (PECL/filter-0.9.4.tgz) = 8fa653b5aec6560ca93be29c70fd4956c88ff4e6c542895e9fdca9b838641793
+SIZE (PECL/filter-0.9.4.tgz) = 13586
diff --git a/security/pecl-filter/pkg-descr b/security/pecl-filter/pkg-descr
new file mode 100644
index 000000000000..1ec2750850ba
--- /dev/null
+++ b/security/pecl-filter/pkg-descr
@@ -0,0 +1,7 @@
+We all know that you should always check input variables, but PHP does not
+offer really good functionality for doing this in a safe way.
+The Input Filter extension is meant to address this issue by implementing
+a set of filters and mechanisms that users can use to safely access their
+input data.
+
+WWW: http://pecl.php.net/package/filter