aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-08-17 02:44:59 +0800
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-08-17 02:44:59 +0800
commitfefa95929a49e4d55211b4c1312a03cce3078791 (patch)
tree27083488bf99998d50d1f131ff287588483442da /security
parent613f32fa9f2f6eedb9733192c4c475f6ffa52953 (diff)
downloadfreebsd-ports-gnome-fefa95929a49e4d55211b4c1312a03cce3078791.tar.gz
freebsd-ports-gnome-fefa95929a49e4d55211b4c1312a03cce3078791.tar.zst
freebsd-ports-gnome-fefa95929a49e4d55211b4c1312a03cce3078791.zip
security/libfido2: fix build on GCC architectures
Use newer compiler: /wrkdirs/usr/ports/security/libfido2/work/libfido2-1.4.0/src/fido.h:115: error: wrong number of arguments specified for '__deprecated__' attribute MFH: 2020Q3 (fix build blanket)
Diffstat (limited to 'security')
-rw-r--r--security/libfido2/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/security/libfido2/Makefile b/security/libfido2/Makefile
index def46599aae9..4bd73268dcfd 100644
--- a/security/libfido2/Makefile
+++ b/security/libfido2/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libcbor.so:devel/libcbor \
libhidapi.so.0:comms/hidapi
-USES= cmake compiler pkgconfig ssl
+USES= cmake compiler:c11 pkgconfig ssl
CFLAGS+= -D_WITH_GETLINE
CMAKE_ON= USE_HIDAPI
@@ -29,8 +29,5 @@ OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e '/libcrypto/d' ${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} -e 's|endian.h|sys/&|' ${WRKSRC}/CMakeLists.txt ${WRKSRC}/openbsd-compat/openbsd-compat.h
-.if ${CHOSEN_COMPILER_TYPE} == gcc
- @${REINPLACE_CMD} -e '/-Wno-unused-result/d; /-Wno-discarded-qualifiers/d' ${WRKSRC}/CMakeLists.txt
-.endif
.include <bsd.port.post.mk>