aboutsummaryrefslogtreecommitdiffstats
path: root/shells/bash
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2006-03-07 05:58:25 +0800
committerkris <kris@FreeBSD.org>2006-03-07 05:58:25 +0800
commit3a2e5df2fa9dda000b307066d2bf5fff9725d0ed (patch)
treeb194164a4ad23c080d6a41c667b52b4603de654c /shells/bash
parenta616f0537b53af610c5ee0fcc846ba8031b73c75 (diff)
downloadfreebsd-ports-gnome-3a2e5df2fa9dda000b307066d2bf5fff9725d0ed.tar.gz
freebsd-ports-gnome-3a2e5df2fa9dda000b307066d2bf5fff9725d0ed.tar.zst
freebsd-ports-gnome-3a2e5df2fa9dda000b307066d2bf5fff9725d0ed.zip
When bash is built with the bison 1.75 port present it breaks the ability
of bash to parse certain legal shell scripts (used by e.g. GNU configure). Fix this by explicitly directing bash to use yacc. Bump PORTREVISION since this is likely to be a common enough occurrence that many users will benefit from the rebuild. Submitted by: Nicolas Rachinsky <nicolas-0@ml.turing-complete.org> PR: ports/94086 Approved by: portmgr (implicit)
Diffstat (limited to 'shells/bash')
-rw-r--r--shells/bash/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 18081863ac07..101d7460f3b9 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bash
PORTVERSION= 3.1.${PATCHLEVEL:S/^0//g}
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_GNU:S/$/:bash/} \
ftp://ftp.cwru.edu/pub/%SUBDIR%/:faq
@@ -89,7 +90,8 @@ CPPFLAGS+= ${PTHREAD_CFLAGS} \
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
+ LDFLAGS="${LDFLAGS}" \
+ YACC="${YACC}"
.include <bsd.port.pre.mk>