aboutsummaryrefslogtreecommitdiffstats
path: root/shells/es
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1995-08-14 12:08:02 +0800
committerasami <asami@FreeBSD.org>1995-08-14 12:08:02 +0800
commit492951fad01bca530b12060a8fdb5ca3447569ac (patch)
treec756985edb4d7bd1e350d605dbc1f2aabb495734 /shells/es
parent388294ef462d6a7de135800a9be3c1bac3a2834f (diff)
downloadfreebsd-ports-gnome-492951fad01bca530b12060a8fdb5ca3447569ac.tar.gz
freebsd-ports-gnome-492951fad01bca530b12060a8fdb5ca3447569ac.tar.zst
freebsd-ports-gnome-492951fad01bca530b12060a8fdb5ca3447569ac.zip
Various plan9 utilities. It's such a complete collection, I'm going
to import it all at once! Submitted by: Eric L. Hernes <erich@lodgenet.com>
Diffstat (limited to 'shells/es')
-rw-r--r--shells/es/Makefile14
-rw-r--r--shells/es/distinfo1
-rw-r--r--shells/es/files/patch-aa88
-rw-r--r--shells/es/pkg-comment1
-rw-r--r--shells/es/pkg-descr13
-rw-r--r--shells/es/pkg-plist3
6 files changed, 120 insertions, 0 deletions
diff --git a/shells/es/Makefile b/shells/es/Makefile
new file mode 100644
index 000000000000..3dceedad1109
--- /dev/null
+++ b/shells/es/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: es
+# Version required: 0.9a1
+# Date created: Sun Aug 13 12:36:14 CDT 1995
+# Whom: erich@rrnet.com
+#
+# $Id$
+#
+
+DISTNAME= es-0.9-alpha1
+PKGNAME= es-0.9a1
+CATEGORIES+= plan9
+MASTER_SITES= ftp://ftp.sys.toronto.edu/pub/es/
+
+.include <bsd.port.mk>
diff --git a/shells/es/distinfo b/shells/es/distinfo
new file mode 100644
index 000000000000..cef218f706f8
--- /dev/null
+++ b/shells/es/distinfo
@@ -0,0 +1 @@
+MD5 (es-0.9-alpha1.tar.gz) = 2e7372fc4c8eaeb00571e721730b6108
diff --git a/shells/es/files/patch-aa b/shells/es/files/patch-aa
new file mode 100644
index 000000000000..f491e82fb15f
--- /dev/null
+++ b/shells/es/files/patch-aa
@@ -0,0 +1,88 @@
+*** Makefile.orig Tue May 30 06:14:14 1995
+--- Makefile Fri Aug 11 16:02:11 1995
+***************
+*** 33,40 ****
+ SHELL = /bin/sh
+ CC = cc
+ #CC = gcc
+! CFLAGS = -g
+! #CFLAGS = -g -O -Wall
+ LDFLAGS =
+ LIBS =
+
+--- 33,40 ----
+ SHELL = /bin/sh
+ CC = cc
+ #CC = gcc
+! #CFLAGS = -g
+! CFLAGS = -O2
+ LDFLAGS =
+ LIBS =
+
+***************
+*** 52,57 ****
+--- 52,66 ----
+ tree.o util.o var.o vec.o version.o y.tab.o
+ OTHER = Makefile parse.y mksignal
+ GEN = esdump y.tab.c y.tab.h y.output token.h sigmsgs.c initial.c
++
++ all: es
++
++ install:
++ $(INSTALL) -c es $(PREFIX)/bin
++ $(INSTALL) -c esdebug $(PREFIX)/bin/esdebug
++ $(INSTALL) -c es.1 $(PREFIX)/man/man1
++ strip $(PREFIX)/bin/es
++ gzip -9nf $(PREFIX)/man/man1/es.1
+
+ es : ${OFILES} initial.o
+ ${CC} -o es ${LDFLAGS} ${OFILES} initial.o ${LIBS}
+*** esdebug~ Mon Jul 31 13:54:29 1995
+--- esdebug Mon Jul 31 13:54:45 1995
+***************
+*** 1,4 ****
+! #! /bin/es -p
+ # esdebug: a debugger for es scripts ($Revision: 1.4 $)
+
+ # TODO
+--- 1,4 ----
+! #!/usr/local/bin/es -p
+ # esdebug: a debugger for es scripts ($Revision: 1.4 $)
+
+ # TODO
+*** prim-sys.c~ Mon Jul 31 16:20:31 1995
+--- prim-sys.c Mon Jul 31 16:21:25 1995
+***************
+*** 194,200 ****
+
+ static void printlimit(const Limit *limit, Boolean hard) {
+ struct rlimit rlim;
+! long lim;
+ getrlimit(limit->flag, &rlim);
+ if (hard)
+ lim = rlim.rlim_max;
+--- 194,200 ----
+
+ static void printlimit(const Limit *limit, Boolean hard) {
+ struct rlimit rlim;
+! u_quad_t lim;
+ getrlimit(limit->flag, &rlim);
+ if (hard)
+ lim = rlim.rlim_max;
+***************
+*** 213,219 ****
+ }
+ }
+
+! static long parselimit(const Limit *limit, char *s) {
+ long lim;
+ char *t;
+ const Suffix *suf = limit->suffix;
+--- 213,219 ----
+ }
+ }
+
+! static u_quad_t parselimit(const Limit *limit, char *s) {
+ long lim;
+ char *t;
+ const Suffix *suf = limit->suffix;
diff --git a/shells/es/pkg-comment b/shells/es/pkg-comment
new file mode 100644
index 000000000000..2ecdaa9b7e00
--- /dev/null
+++ b/shells/es/pkg-comment
@@ -0,0 +1 @@
+Es -- an extensible shell, derrived from plan9's rc
diff --git a/shells/es/pkg-descr b/shells/es/pkg-descr
new file mode 100644
index 000000000000..6b6cdba3348f
--- /dev/null
+++ b/shells/es/pkg-descr
@@ -0,0 +1,13 @@
+Es is an extensible shell. The language was derived from the Plan 9
+shell, rc, and was influenced by functional programming languages,
+such as Scheme, and the Tcl embeddable programming language. This
+implementation is derived from Byron Rakitzis's public domain
+implementation of rc.
+
+Es is in the public domain. We hold no copyrights or patents on
+the source code, and do not place any restrictions on its distribution.
+We would appreciate it if any distributions do credit the authors.
+
+Enjoy!
+
+-- Paul Haahr & Byron Rakitzis
diff --git a/shells/es/pkg-plist b/shells/es/pkg-plist
new file mode 100644
index 000000000000..03aafe9fe6b3
--- /dev/null
+++ b/shells/es/pkg-plist
@@ -0,0 +1,3 @@
+bin/es
+bin/esdebug
+man/man1/es.1.gz