aboutsummaryrefslogtreecommitdiffstats
path: root/shells/flash/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-04-01 21:13:03 +0800
committeredwin <edwin@FreeBSD.org>2006-04-01 21:13:03 +0800
commit40324e18a58d4c2aa380cf5157909d76fbd4ae55 (patch)
tree680adfdb170839a117325292a393db2ed7e09da5 /shells/flash/Makefile
parent12251bb688f44f94b67df756dc404b0fe012ed5d (diff)
downloadfreebsd-ports-gnome-40324e18a58d4c2aa380cf5157909d76fbd4ae55.tar.gz
freebsd-ports-gnome-40324e18a58d4c2aa380cf5157909d76fbd4ae55.tar.zst
freebsd-ports-gnome-40324e18a58d4c2aa380cf5157909d76fbd4ae55.zip
Use SUB_FILES for pkg-message
Diffstat (limited to 'shells/flash/Makefile')
-rw-r--r--shells/flash/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/shells/flash/Makefile b/shells/flash/Makefile
index 6f12de9dd81d..39e0b78722a7 100644
--- a/shells/flash/Makefile
+++ b/shells/flash/Makefile
@@ -26,6 +26,8 @@ GNU_CONFIGURE= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -rdynamic" \
LDFLAGS="${LDFLAGS} -rdynamic"
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
MAN1= flash.1
@@ -69,6 +71,6 @@ post-install:
@(${GREP} -v ${PREFIX}/bin/flash /etc/shells.bak; \
${ECHO_CMD} ${PREFIX}/bin/flash) > /etc/shells
@${RM} /etc/shells.bak
- @${SED} -e "s:/usr/local:${PREFIX}:g" ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>