aboutsummaryrefslogtreecommitdiffstats
path: root/shells/git-prompt.zsh
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2019-05-16 05:00:39 +0800
committerJoseph Mingrone <jrm@FreeBSD.org>2019-05-16 05:00:39 +0800
commitd85981f52b69e2cb1576483a9aa3cbbf8da89feb (patch)
tree0d6e0f71d81f5031ef94327a2948470eb2a7b22a /shells/git-prompt.zsh
parent0801fd92a1ec7dff037a5857b2fadb3f1b6ca2cf (diff)
downloadfreebsd-ports-gnome-d85981f52b69e2cb1576483a9aa3cbbf8da89feb.tar.gz
freebsd-ports-gnome-d85981f52b69e2cb1576483a9aa3cbbf8da89feb.tar.zst
freebsd-ports-gnome-d85981f52b69e2cb1576483a9aa3cbbf8da89feb.zip
New port, git-prompt.zsh: asynchronous Git prompt for Zsh
WWW: https://github.com/woefe/git-prompt.zsh
Diffstat (limited to 'shells/git-prompt.zsh')
-rw-r--r--shells/git-prompt.zsh/Makefile29
-rw-r--r--shells/git-prompt.zsh/distinfo3
-rw-r--r--shells/git-prompt.zsh/pkg-descr6
3 files changed, 38 insertions, 0 deletions
diff --git a/shells/git-prompt.zsh/Makefile b/shells/git-prompt.zsh/Makefile
new file mode 100644
index 000000000000..60773e837710
--- /dev/null
+++ b/shells/git-prompt.zsh/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= git-prompt.zsh
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.0-17
+DISTVERSIONSUFFIX= -gb238e9c
+CATEGORIES= shells
+
+MAINTAINER= jrm@FreeBSD.org
+COMMENT= Fast, customizable, pure-shell, asynchronous Git prompt for Zsh
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= zsh>=4.3:shells/zsh \
+ git>=2.11.0:devel/git
+
+USE_GITHUB= yes
+GH_ACCOUNT= woefe
+
+NO_ARCH= yes
+NO_BUILD= yes
+PLIST_FILES= ${DATADIR}/${PORTNAME}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME} ${STAGEDIR}/${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/shells/git-prompt.zsh/distinfo b/shells/git-prompt.zsh/distinfo
new file mode 100644
index 000000000000..27cb4b1e8ed0
--- /dev/null
+++ b/shells/git-prompt.zsh/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1557941532
+SHA256 (woefe-git-prompt.zsh-v1.0.0-17-gb238e9c_GH0.tar.gz) = c84edd1dace8f8f70bedd4b04479473df3a1c158a068dc87dbab5a40769698f7
+SIZE (woefe-git-prompt.zsh-v1.0.0-17-gb238e9c_GH0.tar.gz) = 7262
diff --git a/shells/git-prompt.zsh/pkg-descr b/shells/git-prompt.zsh/pkg-descr
new file mode 100644
index 000000000000..ef11e5defaae
--- /dev/null
+++ b/shells/git-prompt.zsh/pkg-descr
@@ -0,0 +1,6 @@
+git-prompt.zsh is a fast, customizable, pure-shell, asynchronous Git
+prompt for Zsh. It is heavily inspired by Olivier Verdier's
+zsh-git-prompt and very similar to the "Informative VCS" prompt of fish
+shell.
+
+WWW: https://github.com/woefe/git-prompt.zsh