aboutsummaryrefslogtreecommitdiffstats
path: root/shells/perlsh/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2001-02-26 12:04:33 +0800
committersteve <steve@FreeBSD.org>2001-02-26 12:04:33 +0800
commit026c53a781667fdd0ede669b49075ff01eb70320 (patch)
tree10ecb285598a5a8a84f57afd2904e21297f2a2bf /shells/perlsh/Makefile
parente8b142348e64e263c4329e877a0c8f6b6a307056 (diff)
downloadfreebsd-ports-gnome-026c53a781667fdd0ede669b49075ff01eb70320.tar.gz
freebsd-ports-gnome-026c53a781667fdd0ede669b49075ff01eb70320.tar.zst
freebsd-ports-gnome-026c53a781667fdd0ede669b49075ff01eb70320.zip
Update to version 0.009.
PR: 24119 Submitted by: Joseph Scott <joseph@randomnetworks.com>
Diffstat (limited to 'shells/perlsh/Makefile')
-rw-r--r--shells/perlsh/Makefile34
1 files changed, 26 insertions, 8 deletions
diff --git a/shells/perlsh/Makefile b/shells/perlsh/Makefile
index 9e20076d89b2..84ebf9d16cb1 100644
--- a/shells/perlsh/Makefile
+++ b/shells/perlsh/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= perlsh
-PORTVERSION= 0.007
+PORTVERSION= 0.009
CATEGORIES= shells perl5
MASTER_SITES= http://www.focusresearch.com/gregor/psh/
DISTNAME= psh-${PORTVERSION}
@@ -14,15 +14,33 @@ DISTNAME= psh-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
USE_PERL5= yes
-FETCH_BEFORE_ARGS+= -t
-MAKE_ENV+= PPREFIX="${PREFIX}"
-MAN1= psh.1
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+PERL_CONFIGURE= yes
-.include "${.CURDIR}/files/man3"
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Psh::Builtins.3 \
+ Psh::Completion.3 \
+ Psh::Job.3 \
+ Psh::Joblist.3 \
+ Psh::Locale::Base.3 \
+ Psh::Locale::Default.3 \
+ Psh::Locale::French.3 \
+ Psh::Locale::German.3 \
+ Psh::Locale::Italian.3 \
+ Psh::Locale::Portuguese.3 \
+ Psh::Locale::Spanish.3 \
+ Psh::OS.3 \
+ Psh::OS::Mac.3 \
+ Psh::OS::Unix.3 \
+ Psh::OS::Win.3 \
+ Psh::PCompletion.3 \
+ Psh::Parser.3 \
+ Psh::PerlEval.3 \
+ Psh::Util.3
-do-build:
- @(cd ${WRKSRC} && ${PERL} Makefile.PL && ${MAKE})
+pre-install:
+ ${PERL} -pi -e "s:/usr/local:${PREFIX}:g" ${WRKSRC}/Makefile;
+ ${PERL} -pi -e "s:/usr/local/man/man1:${MAN3PREFIX}/man/man1:g" ${WRKSRC}/Makefile;
+ ${PERL} -pi -e "s:/usr/local/lib/perl5/5.00503/man/man3:${MAN3PREFIX}/man/man3:g" ${WRKSRC}/Makefile;
post-install:
@${ECHO} "Updating /etc/shells"