aboutsummaryrefslogtreecommitdiffstats
path: root/shells/tcshrc
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-12-26 21:29:25 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-12-26 21:29:25 +0800
commiteb9ac8a8cd1a277b43d612b6b24ff0ca1f94e305 (patch)
tree5ca3703a9378b2b802d2347603a5d569556de52a /shells/tcshrc
parent768326eb784dc1543850b928a752755b7face3d1 (diff)
downloadfreebsd-ports-gnome-eb9ac8a8cd1a277b43d612b6b24ff0ca1f94e305.tar.gz
freebsd-ports-gnome-eb9ac8a8cd1a277b43d612b6b24ff0ca1f94e305.tar.zst
freebsd-ports-gnome-eb9ac8a8cd1a277b43d612b6b24ff0ca1f94e305.zip
Apply FreeBSD specific changes:
* 'ls --color' -> 'ls -G' * adjusted manpath NOTE: Submitter is encouraged to submit the changes to the author. PR: 105154 (based on) Submitted by: ingo.petersen.webfreenet.de
Diffstat (limited to 'shells/tcshrc')
-rw-r--r--shells/tcshrc/Makefile12
-rw-r--r--shells/tcshrc/files/patch-src__tcshrc.alias31
-rw-r--r--shells/tcshrc/files/patch-src__tcshrc.complete22
-rw-r--r--shells/tcshrc/files/patch-tcshrc_config31
4 files changed, 92 insertions, 4 deletions
diff --git a/shells/tcshrc/Makefile b/shells/tcshrc/Makefile
index fb3008e17bf7..1cac8e19b16e 100644
--- a/shells/tcshrc/Makefile
+++ b/shells/tcshrc/Makefile
@@ -1,12 +1,13 @@
# New ports collection makefile for: tcshrc
-# Date created: 2003-09-09
-# Whom: Sean Chittenden <seanc@FreeBSD.org>
+# Date created: 2003-09-09
+# Whom: Sean Chittenden <seanc@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= tcshrc
PORTVERSION= 1.6.0
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tcshrc
@@ -14,12 +15,15 @@ MASTER_SITE_SUBDIR= tcshrc
MAINTAINER= ports@FreeBSD.org
COMMENT= A set of configuration scripts for the TCSH shell
+NO_BUILD= yes
+
INSTALL_TARGET= systeminstall
MAKE_ARGS= BIN=${LOCALBASE}/bin SHARETCSHRC=${DATADIR}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-do-build:
- ${REINPLACE_CMD} -e 's#/usr/share#${PREFIX}/share#g' ${WRKSRC}/tcshrc_config
+post-patch:
+ @${REINPLACE_CMD} -e 's#/usr/share#${PREFIX}/share#g' \
+ ${WRKSRC}/tcshrc_config
.include <bsd.port.mk>
diff --git a/shells/tcshrc/files/patch-src__tcshrc.alias b/shells/tcshrc/files/patch-src__tcshrc.alias
new file mode 100644
index 000000000000..ed2416cc1542
--- /dev/null
+++ b/shells/tcshrc/files/patch-src__tcshrc.alias
@@ -0,0 +1,31 @@
+--- ./src/tcshrc.alias.orig Fri Aug 13 19:04:01 2004
++++ ./src/tcshrc.alias Tue Dec 26 14:12:03 2006
+@@ -21,7 +21,7 @@
+
+ ## Standard aliases - convenience
+ # Color syntax
+-alias ls 'ls --color'
++alias ls 'ls -G'
+ # Typicaly "more" does not allow you to use the arrow keys/etc for navigation.
+ # Thus, we try to use "less", if it exists. Some distros do not put the
+ # fileutils package and it is annoying if the alias exists without the app.
+@@ -73,7 +73,7 @@
+ alias maek 'make'
+ alias alais 'alias'
+ alias csl 'clear'
+-alias sl 'ls --color'
++alias sl 'ls -G'
+
+ ## Aliases specific to TCSH
+ # What is the help command? Type "ls" and hit F1. Will show a help line.
+@@ -127,3 +127,9 @@
+ #alias clean 'rm -f *~'
+ # This is useful to translators checking .po files.
+ alias msgcheck 'msgfmt -o /dev/null --statistics --strict --verbose'
++
++#Install `most` from he ports or package for coloured manpages
++
++if ( -e `where most`) then
++ alias man 'man -P most'
++endif
+\ No newline at end of file
diff --git a/shells/tcshrc/files/patch-src__tcshrc.complete b/shells/tcshrc/files/patch-src__tcshrc.complete
new file mode 100644
index 000000000000..31783cd6762b
--- /dev/null
+++ b/shells/tcshrc/files/patch-src__tcshrc.complete
@@ -0,0 +1,22 @@
+--- ./src/tcshrc.complete.orig Fri Aug 13 19:04:01 2004
++++ ./src/tcshrc.complete Tue Dec 26 14:12:31 2006
+@@ -714,13 +714,12 @@
+ endif
+ unset _maildir
+
+- if (! $?MANPATH) then
+- if (-r /usr/share/man) then
+- setenv MANPATH /usr/share/man:
+- else
+- setenv MANPATH /usr/man:
+- endif
+- endif
++
++# changed from original file to allow to use all manpathes found
++# by the manpath utility, not only one path
++
++unsetenv MANPATH
++setenv MANPATH `manpath`
+
+ if ($?traditional_complete) then
+ # use of $MANPATH from Dan Nicolaescu <dann@ics.uci.edu>
diff --git a/shells/tcshrc/files/patch-tcshrc_config b/shells/tcshrc/files/patch-tcshrc_config
new file mode 100644
index 000000000000..03d6afa6af18
--- /dev/null
+++ b/shells/tcshrc/files/patch-tcshrc_config
@@ -0,0 +1,31 @@
+--- ./tcshrc_config.orig Fri Aug 13 19:21:42 2004
++++ ./tcshrc_config Tue Dec 26 14:13:16 2006
+@@ -36,7 +36,7 @@
+ SYSTEM=y
+ ;;
+ -v|--verbose)
+- VERBOSE=--verbose
++ VERBOSE=-v
+ ;;
+ -*)
+ usage
+@@ -62,7 +62,18 @@
+ /bin/cp -f ${VERBOSE} ${SOURCE}/tcshrc.set ${HOME}/.tcshrc.set
+ /bin/cp -f ${VERBOSE} ${SOURCE}/tcshrc.alias ${HOME}/.tcshrc.alias
+ /bin/cp -f ${VERBOSE} ${SOURCE}/tcshrc.hosts ${HOME}/.tcshrc.hosts
+- /bin/cp -u ${VERBOSE} ${SOURCE}/tcshrc.local ${HOME}/.tcshrc.local
++
++ if [ "`uname`" != "Linux" ] ; then
++ if [ -e "${HOME}/.tcshrc.local" ] ; then
++ /bin/cp -f ${VERBOSE} ${HOME}/.tcshrc.local ${HOME}/.tcshrc.local.old
++ /bin/cp -f ${VERBOSE} ${SOURCE}/tcshrc.local ${HOME}/.tcshrc.local
++
++ else /bin/cp -f ${VERBOSE} ${SOURCE}/tcshrc.local ${HOME}/.tcshrc.local
++ fi
++ else /bin/cp -u ${VERBOSE} ${SOURCE}/tcshrc.local ${HOME}/.tcshrc.local
++
++ fi
++
+ echo " done." >&2
+ exit 0
+ fi