aboutsummaryrefslogtreecommitdiffstats
path: root/shells/zsh
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-05-26 18:54:36 +0800
committermarino <marino@FreeBSD.org>2015-05-26 18:54:36 +0800
commit777cc8c0c97f5b594b463ccb81bdf71b32eabe80 (patch)
tree0112d0f7a49ad6048abbfb51efa5ad3e485ddbda /shells/zsh
parent7db452fc543fc8c6212bbe2509f0c3b5cdff729a (diff)
downloadfreebsd-ports-gnome-777cc8c0c97f5b594b463ccb81bdf71b32eabe80.tar.gz
freebsd-ports-gnome-777cc8c0c97f5b594b463ccb81bdf71b32eabe80.tar.zst
freebsd-ports-gnome-777cc8c0c97f5b594b463ccb81bdf71b32eabe80.zip
shells/zsh: Fix runtime error when built by gcc-5 with upstream patch
The previous approved fix for building with gcc5 still didn't work right. Sure enough, upstream updated their patch. When we take that update, zshell finally behaves. Piggybacking on previous approval.
Diffstat (limited to 'shells/zsh')
-rw-r--r--shells/zsh/Makefile2
-rw-r--r--shells/zsh/files/patch-Src_zsh.mdd4
2 files changed, 3 insertions, 3 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index b454df7ddb68..00b70c51c991 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zsh
PORTVERSION= 5.0.7
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= shells
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION} \
SF/${PORTNAME}/${PORTNAME}-doc/${PORTVERSION}:doc
diff --git a/shells/zsh/files/patch-Src_zsh.mdd b/shells/zsh/files/patch-Src_zsh.mdd
index e8de489eb6ea..9cf32f03afb4 100644
--- a/shells/zsh/files/patch-Src_zsh.mdd
+++ b/shells/zsh/files/patch-Src_zsh.mdd
@@ -11,8 +11,8 @@
signames.c: signames1.awk signames2.awk ../config.h @SIGNAL_H@
$(AWK) -f $(sdir)/signames1.awk @SIGNAL_H@ >sigtmp.c
- $(CPP) sigtmp.c >sigtmp.out
-+ case "$(CPP)" in \
-+ gcc*) \
++ case "`$(CPP) --version </dev/null 2>&1`" in \
++ *"Free Software Foundation"*) \
+ $(CPP) -P sigtmp.c >sigtmp.out;; \
+ *) \
+ $(CPP) sigtmp.c >sigtmp.out;; \