aboutsummaryrefslogtreecommitdiffstats
path: root/shells/zsh
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2009-12-18 21:05:28 +0800
committerolgeni <olgeni@FreeBSD.org>2009-12-18 21:05:28 +0800
commit9847f900c03ca85226ae15b23f106d344f4ec7fa (patch)
treef78e17822297c50b9329e8d7ebe5484a54e5c6e1 /shells/zsh
parentafecf5f1be907afd9bd2a33d06659c930025fdf8 (diff)
downloadfreebsd-ports-gnome-9847f900c03ca85226ae15b23f106d344f4ec7fa.tar.gz
freebsd-ports-gnome-9847f900c03ca85226ae15b23f106d344f4ec7fa.tar.zst
freebsd-ports-gnome-9847f900c03ca85226ae15b23f106d344f4ec7fa.zip
* Fetch documentation from the zsh-doc-dev sourceforge project.
* Make portlint happy by using ${ECHO}, and TABs in assignments. PORTREVISION bump not required. PR: ports/141728 Submitted by: olgeni Approved by: des (by mail)
Diffstat (limited to 'shells/zsh')
-rw-r--r--shells/zsh/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index fc4c5d6d512f..c2c32cc6e4e2 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -9,9 +9,10 @@ PORTNAME= zsh
PORTVERSION= 4.3.10
PORTREVISION= 2
CATEGORIES= shells
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-dev/${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-dev/${PORTVERSION}:src \
+ SF/${PORTNAME}/${PORTNAME}-doc-dev/${PORTVERSION}:doc
.if !defined(NOPORTDOCS)
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}-doc${EXTRACT_SUFX}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:src ${DISTNAME}-doc${EXTRACT_SUFX}:doc
.endif
MAINTAINER= des@FreeBSD.org
@@ -33,8 +34,8 @@ CONFIGURE_ARGS= --with-term-lib="ncursesw ncurses" --with-tcsetpgrp \
--enable-function-subdirs
EXTRA_PATCHES= ${FILESDIR}/extra-patch-bsdtar
-EXTRA_COMPLETION_FILES= _fstat _procstat _sockstat
-EXTRA_COMPLETION_DIR= Completion/BSD/Command
+EXTRA_COMPLETION_FILES= _fstat _procstat _sockstat
+EXTRA_COMPLETION_DIR= Completion/BSD/Command
OPTIONS= ZSH_GDBM "Enable GDBM support (GPL)" off \
ZSH_MEM "Enable zsh-mem and zsh-secure-free options" on \
@@ -103,13 +104,13 @@ post-patch:
@${SED} -i "" -e "s,/etc/,${LOCALBASE}/etc/," \
${WRKSRC}/Functions/MIME/zsh-mime-setup
.ifdef EXTRA_COMPLETION_FILES
- @echo "===> Installing extra completion files"
+ @${ECHO} "===> Installing extra completion files"
.for COMPFILE in ${EXTRA_COMPLETION_FILES}
@(if [ -f ${WRKSRC}/${EXTRA_COMPLETION_DIR}/${COMPFILE} ] ; then \
- echo "${EXTRA_COMPLETION_DIR}/${COMPFILE} already exists" ; \
+ ${ECHO} "${EXTRA_COMPLETION_DIR}/${COMPFILE} already exists" ; \
exit 1 ; \
else \
- echo ${EXTRA_COMPLETION_DIR}/${COMPFILE} ; \
+ ${ECHO} ${EXTRA_COMPLETION_DIR}/${COMPFILE} ; \
${CP} ${FILESDIR}/${COMPFILE} \
${WRKSRC}/${EXTRA_COMPLETION_DIR}/${COMPFILE} ; \
fi)