aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2018-10-06 21:06:42 +0800
committerdes <des@FreeBSD.org>2018-10-06 21:06:42 +0800
commit091caf4661b26a5f70d9b8e0409821418f5afdbb (patch)
tree0721b637b4bcfc0a8ff2a945bdcb7e68f8993680 /shells
parenteb79e9b6a267227492e837fea536cf5c224c7a2d (diff)
downloadfreebsd-ports-gnome-091caf4661b26a5f70d9b8e0409821418f5afdbb.tar.gz
freebsd-ports-gnome-091caf4661b26a5f70d9b8e0409821418f5afdbb.tar.zst
freebsd-ports-gnome-091caf4661b26a5f70d9b8e0409821418f5afdbb.zip
Fix every instance of RUN_DEPENDS:=${BUILD_DEPENDS} in p5 ports, except
for where it resulted in a change in output from build-depends-list or run-depends-list. Approved by: portmgr (adamw)
Diffstat (limited to 'shells')
-rw-r--r--shells/p5-Bash-Completion/Makefile4
-rw-r--r--shells/p5-Term-Bash-Completion-Generator/Makefile4
-rw-r--r--shells/p5-Term-ShellUI/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/shells/p5-Bash-Completion/Makefile b/shells/p5-Bash-Completion/Makefile
index bf4b237911d4..066701b4f1f1 100644
--- a/shells/p5-Bash-Completion/Makefile
+++ b/shells/p5-Bash-Completion/Makefile
@@ -15,9 +15,9 @@ COMMENT= Extensible system to provide bash completion
LICENSE= ART20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-List-MoreUtils>=0:lang/p5-List-MoreUtils \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-List-MoreUtils>=0:lang/p5-List-MoreUtils \
p5-Module-Load>=0.22:devel/p5-Module-Load
-RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Deep>=0:devel/p5-Test-Deep
NO_ARCH= yes
diff --git a/shells/p5-Term-Bash-Completion-Generator/Makefile b/shells/p5-Term-Bash-Completion-Generator/Makefile
index f8e30619be59..6bf07e9c7cc0 100644
--- a/shells/p5-Term-Bash-Completion-Generator/Makefile
+++ b/shells/p5-Term-Bash-Completion-Generator/Makefile
@@ -14,10 +14,10 @@ COMMENT= Generate bash completion scripts
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Readonly>=0:devel/p5-Readonly \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Readonly>=0:devel/p5-Readonly \
p5-Sub-Exporter>=0:devel/p5-Sub-Exporter \
p5-Tree-Trie>=0:devel/p5-Tree-Trie
-RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-NoWarnings>=0:devel/p5-Test-NoWarnings \
p5-Test-Warn>=0:devel/p5-Test-Warn \
diff --git a/shells/p5-Term-ShellUI/Makefile b/shells/p5-Term-ShellUI/Makefile
index 8988f3007a99..0ecaecccf079 100644
--- a/shells/p5-Term-ShellUI/Makefile
+++ b/shells/p5-Term-ShellUI/Makefile
@@ -11,8 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Fully-featured shell-like command line environment
-BUILD_DEPENDS= p5-Term-ReadLine-Gnu>=0:devel/p5-Term-ReadLine-Gnu
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Term-ReadLine-Gnu>=0:devel/p5-Term-ReadLine-Gnu
USES= perl5 shebangfix
SHEBANG_FILES= examples/*