aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2001-06-14 21:11:03 +0800
committerdwcjr <dwcjr@FreeBSD.org>2001-06-14 21:11:03 +0800
commit344a17fee25cd209aea6822544838e0e7b24fe96 (patch)
tree84d38c58de3e88105783d94a928b7731dedb23b4 /shells
parent0fd445ca7a5755fac718ebe884ea6b23ef8448ae (diff)
downloadfreebsd-ports-gnome-344a17fee25cd209aea6822544838e0e7b24fe96.tar.gz
freebsd-ports-gnome-344a17fee25cd209aea6822544838e0e7b24fe96.tar.zst
freebsd-ports-gnome-344a17fee25cd209aea6822544838e0e7b24fe96.zip
Add hmmah, The Deep Prompt, a set of shell prompts
Submitted by: David Yeske <dyeske@yahoo.com> Reviewed by: will
Diffstat (limited to 'shells')
-rw-r--r--shells/Makefile1
-rw-r--r--shells/hmmah/Makefile32
-rw-r--r--shells/hmmah/distinfo1
-rw-r--r--shells/hmmah/pkg-comment1
-rw-r--r--shells/hmmah/pkg-descr3
-rw-r--r--shells/hmmah/pkg-plist5
6 files changed, 43 insertions, 0 deletions
diff --git a/shells/Makefile b/shells/Makefile
index a9eeb1f2fd97..0d906202c474 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -7,6 +7,7 @@
SUBDIR += es
SUBDIR += esh
SUBDIR += flash
+ SUBDIR += hmmah
SUBDIR += ksh93
SUBDIR += mudsh
SUBDIR += osh
diff --git a/shells/hmmah/Makefile b/shells/hmmah/Makefile
new file mode 100644
index 000000000000..88f4e744aa56
--- /dev/null
+++ b/shells/hmmah/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: hmmah
+# Date created: Jun 6, 2001
+# Whom: dwcjr@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= hmmah
+PORTVERSION= 1.0
+CATEGORIES= shells
+MASTER_SITES= http://dyeske.netrush.net/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dyeske@yahoo.com
+
+NO_BUILD=
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+do-install:
+ @${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/dot.bash_prompt ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/dot.ksh_prompt ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/dot.tcsh_prompt ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/dot.zsh_prompt ${PREFIX}/share/doc/${PORTNAME}
+
+post-install:
+ @${ECHO_MSG} "-------------------------------------------------------------------------------"
+ @${ECHO_MSG} "Copy the dot.(shell)_prompt file to ~/.(shell)_prompt and then "
+ @${ECHO_MSG} "run it via your shell start up file such as .bashrc, .tcshrc, .zshrc, or .kshrc"
+ @${ECHO_MSG} "-------------------------------------------------------------------------------"
+
+.include <bsd.port.mk>
diff --git a/shells/hmmah/distinfo b/shells/hmmah/distinfo
new file mode 100644
index 000000000000..c42d74516094
--- /dev/null
+++ b/shells/hmmah/distinfo
@@ -0,0 +1 @@
+MD5 (hmmah-1.0.tgz) = 1685d97b122c676fdd3249acd1c32b76
diff --git a/shells/hmmah/pkg-comment b/shells/hmmah/pkg-comment
new file mode 100644
index 000000000000..70a04b88f036
--- /dev/null
+++ b/shells/hmmah/pkg-comment
@@ -0,0 +1 @@
+The Deep Prompt
diff --git a/shells/hmmah/pkg-descr b/shells/hmmah/pkg-descr
new file mode 100644
index 000000000000..e9345b72dafb
--- /dev/null
+++ b/shells/hmmah/pkg-descr
@@ -0,0 +1,3 @@
+The Deep Prompt
+These are some example prompts for various shells.
+The bash prompt is currently more developed than the other prompt's.
diff --git a/shells/hmmah/pkg-plist b/shells/hmmah/pkg-plist
new file mode 100644
index 000000000000..019ae99e35cc
--- /dev/null
+++ b/shells/hmmah/pkg-plist
@@ -0,0 +1,5 @@
+share/doc/hmmah/dot.ksh_prompt
+share/doc/hmmah/dot.bash_prompt
+share/doc/hmmah/dot.zsh_prompt
+share/doc/hmmah/dot.tcsh_prompt
+@dirrm share/doc/hmmah