aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2021-04-15 19:23:03 +0800
committerMateusz Piotrowski <0mp@FreeBSD.org>2021-04-15 19:23:03 +0800
commit43ebfaa30d8d8744bf0e345ab29cd133640740e4 (patch)
tree21b3487118bcfd69d68b24aecf9657dd7cc0b896 /shells
parent5fafc75c0ff5e3ad71947b9edbb0d0720e7ec41f (diff)
downloadfreebsd-ports-gnome-43ebfaa30d8d8744bf0e345ab29cd133640740e4.tar.gz
freebsd-ports-gnome-43ebfaa30d8d8744bf0e345ab29cd133640740e4.tar.zst
freebsd-ports-gnome-43ebfaa30d8d8744bf0e345ab29cd133640740e4.zip
shells/modernish: Make the build more verbose
Our official poudriere instances fail to build this port for unknown reasons. Let's get some additional logs in order to fix the issue. Reported by: pkg-fallout
Diffstat (limited to 'shells')
-rw-r--r--shells/modernish/Makefile2
-rw-r--r--shells/modernish/files/patch-install.sh11
2 files changed, 12 insertions, 1 deletions
diff --git a/shells/modernish/Makefile b/shells/modernish/Makefile
index c5e9666474ec..9c9a1e4958b7 100644
--- a/shells/modernish/Makefile
+++ b/shells/modernish/Makefile
@@ -18,7 +18,7 @@ OPTIONS_DEFINE= DOCS EXAMPLES
do-install:
cd ${WRKSRC} && \
- ${SETENV} ${MAKE_ENV} ./install.sh -d ${PREFIX} -D ${STAGEDIR} -n -s ${SH}
+ ${SETENV} ${MAKE_ENV} ${SH} -x ./install.sh -d ${PREFIX} -D ${STAGEDIR} -n -s ${SH}
${RM} ${STAGEDIR}${DOCSDIR}/LICENSE
${MKDIR} ${STAGEDIR}${EXAMPLESDIR:H}
diff --git a/shells/modernish/files/patch-install.sh b/shells/modernish/files/patch-install.sh
new file mode 100644
index 000000000000..9f59425be61e
--- /dev/null
+++ b/shells/modernish/files/patch-install.sh
@@ -0,0 +1,11 @@
+--- install.sh.orig 2021-04-15 11:21:11 UTC
++++ install.sh
+@@ -119,7 +119,7 @@ case ${opt_s+s} in
+ ( * ) MSH_SHELL=$opt_s
+ export MSH_SHELL
+ echo "Relaunching ${0##*/} with $MSH_SHELL..." >&2
+- exec "$MSH_SHELL" "$MSH_PREFIX/${0##*/}" --relaunch "$@" ;;
++ exec "$MSH_SHELL" -x "$MSH_PREFIX/${0##*/}" --relaunch "$@" ;;
+ esac ;;
+ esac
+