aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2002-09-29 09:42:08 +0800
committerkris <kris@FreeBSD.org>2002-09-29 09:42:08 +0800
commit80c927ed3b05aa80f8725a03c24716feb204b469 (patch)
tree8399171f505cb2a7241e8b75ab8f403768bdd015 /shells
parente64669d3b72d9f3a7869d2517e88236132b4fbe3 (diff)
downloadfreebsd-ports-gnome-80c927ed3b05aa80f8725a03c24716feb204b469.tar.gz
freebsd-ports-gnome-80c927ed3b05aa80f8725a03c24716feb204b469.tar.zst
freebsd-ports-gnome-80c927ed3b05aa80f8725a03c24716feb204b469.zip
Move files from illegal subdirectory src/ to files/ and fix
extract procedure.
Diffstat (limited to 'shells')
-rw-r--r--shells/nologinmsg/Makefile4
-rw-r--r--shells/nologinmsg/files/Makefile (renamed from shells/nologinmsg/src/Makefile)0
-rw-r--r--shells/nologinmsg/files/nologinmsg.8 (renamed from shells/nologinmsg/src/nologinmsg.8)0
-rw-r--r--shells/nologinmsg/files/nologinmsg.c (renamed from shells/nologinmsg/src/nologinmsg.c)0
-rw-r--r--shells/nologinmsg/files/pathnames.h (renamed from shells/nologinmsg/src/pathnames.h)0
5 files changed, 3 insertions, 1 deletions
diff --git a/shells/nologinmsg/Makefile b/shells/nologinmsg/Makefile
index 411a39847f57..bc76b3b49ee1 100644
--- a/shells/nologinmsg/Makefile
+++ b/shells/nologinmsg/Makefile
@@ -21,7 +21,9 @@ MANCOMPRESSED= yes
do-extract:
@${MKDIR} ${WRKSRC}
- @${CP} ${.CURDIR}/src/* ${WRKSRC}
+.for i in Makefile nologinmsg.c nologinmsg.8 pathnames.h
+ @${CP} ${FILESDIR}/${i} ${WRKSRC}
+.endfor
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/nologinmsg.8 \
diff --git a/shells/nologinmsg/src/Makefile b/shells/nologinmsg/files/Makefile
index 814a190d719d..814a190d719d 100644
--- a/shells/nologinmsg/src/Makefile
+++ b/shells/nologinmsg/files/Makefile
diff --git a/shells/nologinmsg/src/nologinmsg.8 b/shells/nologinmsg/files/nologinmsg.8
index 1d89489b455c..1d89489b455c 100644
--- a/shells/nologinmsg/src/nologinmsg.8
+++ b/shells/nologinmsg/files/nologinmsg.8
diff --git a/shells/nologinmsg/src/nologinmsg.c b/shells/nologinmsg/files/nologinmsg.c
index 91da8693a5ef..91da8693a5ef 100644
--- a/shells/nologinmsg/src/nologinmsg.c
+++ b/shells/nologinmsg/files/nologinmsg.c
diff --git a/shells/nologinmsg/src/pathnames.h b/shells/nologinmsg/files/pathnames.h
index 1bcdbefebaa8..1bcdbefebaa8 100644
--- a/shells/nologinmsg/src/pathnames.h
+++ b/shells/nologinmsg/files/pathnames.h