aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-08-11 21:28:31 +0800
committerknu <knu@FreeBSD.org>2002-08-11 21:28:31 +0800
commit8741b18dd824d3ddbbf1872541fa118da78d8d1b (patch)
treea9f741025fd528d2103976791fc15460f7973de7 /shells
parenta47e0f0f96a747e69cc041f4de2730ac77572856 (diff)
downloadfreebsd-ports-gnome-8741b18dd824d3ddbbf1872541fa118da78d8d1b.tar.gz
freebsd-ports-gnome-8741b18dd824d3ddbbf1872541fa118da78d8d1b.tar.zst
freebsd-ports-gnome-8741b18dd824d3ddbbf1872541fa118da78d8d1b.zip
- Recognize .tbz as a tar+bzip2 suffix.
- Expand the arch table size from 16 to 32. - Bump PORTREVISION accordingly.
Diffstat (limited to 'shells')
-rw-r--r--shells/fd/Makefile1
-rw-r--r--shells/fd/files/patch-_fdrc6
-rw-r--r--shells/fd/files/patch-fd.h7
3 files changed, 11 insertions, 3 deletions
diff --git a/shells/fd/Makefile b/shells/fd/Makefile
index ba089c7ce021..1c922c6cf06b 100644
--- a/shells/fd/Makefile
+++ b/shells/fd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fd
PORTVERSION= 2.01b
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= http://hp.vector.co.jp/authors/VA012337/soft/fd/ \
ftp://ftp.vector.co.jp/pack/unix/util/file/filer/fd/
diff --git a/shells/fd/files/patch-_fdrc b/shells/fd/files/patch-_fdrc
index 2842da0dd894..8ac4168b01e0 100644
--- a/shells/fd/files/patch-_fdrc
+++ b/shells/fd/files/patch-_fdrc
@@ -1,5 +1,5 @@
--- _fdrc.orig Mon Jun 10 00:00:00 2002
-+++ _fdrc Tue Jun 11 21:27:57 2002
++++ _fdrc Sun Aug 11 22:18:20 2002
@@ -13,2 +13,3 @@
#SORTTYPE=0
+FD_SORTTYPE=101
@@ -39,7 +39,7 @@
+ launch "$ext" "$tar ztvf %C" "$tar_format"
+done
+
-+for ext in .tar.bz2 .tbz2; do
++for ext in .tar.bz2 .tbz2 .tbz; do
+ launch "$ext" "$tar jtvf %C" "$tar_format"
+done
+
@@ -76,7 +76,7 @@
+ arch "$ext" "$tar cf - %T | gzip -9c > %C" "$tar zxf %C %TA"
+done
+
-+for ext in .tar.bz2 .tbz2; do
++for ext in .tar.bz2 .tbz2 .tbz; do
+ arch "$ext" "$tar cf - %T | bzip2 -9c > %C" "$tar jxf %C %TA"
+done
+
diff --git a/shells/fd/files/patch-fd.h b/shells/fd/files/patch-fd.h
new file mode 100644
index 000000000000..ac6a52d45fd8
--- /dev/null
+++ b/shells/fd/files/patch-fd.h
@@ -0,0 +1,7 @@
+--- fd.h.orig Wed Jul 10 00:00:00 2002
++++ fd.h Sun Aug 11 22:25:15 2002
+@@ -132,3 +132,3 @@
+ #define MAXLAUNCHTABLE 32
+-#define MAXARCHIVETABLE 16
++#define MAXARCHIVETABLE 32
+ #define MAXALIASTABLE 256