aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authordmgk <dmgk@FreeBSD.org>2019-09-30 06:31:57 +0800
committerdmgk <dmgk@FreeBSD.org>2019-09-30 06:31:57 +0800
commitb5fa25d93147965f8c5e5b9ca1d5fb93edf4e768 (patch)
tree16884a4188ae95c6d4b3c8e73cfaf24404fd28e8 /shells
parentf79699403b81858cdc3eebd9227fdae738250275 (diff)
downloadfreebsd-ports-gnome-b5fa25d93147965f8c5e5b9ca1d5fb93edf4e768.tar.gz
freebsd-ports-gnome-b5fa25d93147965f8c5e5b9ca1d5fb93edf4e768.tar.zst
freebsd-ports-gnome-b5fa25d93147965f8c5e5b9ca1d5fb93edf4e768.zip
Go ports: cleanup, finish transition to USES=go started with r505321 (cat. misc-shells)
- Remove custom build/install targets left in place after r505321 - Switch to the new GO_TARGET tuple syntax introduced in r512001 - Switch to go:modules when upstream already uses them Reviewed by: tobik Approved by: araujo (mentor), portmgr (adamw) Differential Revision: https://reviews.freebsd.org/D21743
Diffstat (limited to 'shells')
-rw-r--r--shells/antibody/Makefile28
1 files changed, 10 insertions, 18 deletions
diff --git a/shells/antibody/Makefile b/shells/antibody/Makefile
index ac552881fc57..edffbe404f5a 100644
--- a/shells/antibody/Makefile
+++ b/shells/antibody/Makefile
@@ -15,29 +15,21 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
RUN_DEPENDS= git:devel/git \
zsh:shells/zsh
-USES= go
+USES= go:modules
PLIST_FILES= bin/antibody
USE_GITHUB= yes
GH_ACCOUNT= getantibody
-GH_SUBDIR= src/github.com/${GH_ACCOUNT_DEFAULT}/${PORTNAME}
# Not needed: go-spew, go-difflib
-GH_TUPLE= alecthomas:kingpin:a39589:kingpin/src/github.com/alecthomas/kingpin \
- alecthomas:template:a0175e:tempalte/src/github.com/alecthomas/template \
- alecthomas:units:2efee8:units/src/github.com/alecthomas/units \
- caarlos0:gohome:75f08ebc:gohome/src/github.com/caarlos0/gohome \
- getantibody:folder:v1.0.0:folder/src/github.com/getantibody/folder \
- golang:crypto:1a580b:crypto/src/golang.org/x/crypto \
- golang:net:2491c5:net/src/golang.org/x/net \
- golang:sync:1d60e4:sync/src/golang.org/x/sync \
- golang:sys:7c87d1:sys/src/golang.org/x/sys
-
-do-build:
- ${RM} ${WRKSRC}/go.mod
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${BUILD_ENV} GOPATH=${WRKSRC} go build
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/antibody-${PORTVERSION} ${STAGEDIR}${PREFIX}/bin/antibody
+GH_TUPLE= alecthomas:kingpin:a39589:kingpin/vendor/github.com/alecthomas/kingpin \
+ alecthomas:template:a0175e:tempalte/vendor/github.com/alecthomas/template \
+ alecthomas:units:2efee8:units/vendor/github.com/alecthomas/units \
+ caarlos0:gohome:75f08ebc:gohome/vendor/github.com/caarlos0/gohome \
+ getantibody:folder:v1.0.0:folder/vendor/github.com/getantibody/folder \
+ golang:crypto:1a580b:crypto/vendor/golang.org/x/crypto \
+ golang:net:2491c5:net/vendor/golang.org/x/net \
+ golang:sync:1d60e4:sync/vendor/golang.org/x/sync \
+ golang:sys:7c87d1:sys/vendor/golang.org/x/sys
.include <bsd.port.mk>