aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorKoop Mast <koop@beyonit.nl>2019-09-25 01:10:20 +0800
committerKoop Mast <koop@beyonit.nl>2019-09-25 01:10:20 +0800
commitc5d4cd5d5cbcd9f16aa5bd8e5fcfdc96e17a81f6 (patch)
tree4b5a3cd1d243ff0c74465ea743ec310199c5edb5 /shells
parentfe87ebd172e9d689d85015844fb5a85fb32b3e50 (diff)
parent54294ad9726b349cbad4ebbbe9711550f8b1e53d (diff)
downloadfreebsd-ports-gnome-c5d4cd5d5cbcd9f16aa5bd8e5fcfdc96e17a81f6.tar.gz
freebsd-ports-gnome-c5d4cd5d5cbcd9f16aa5bd8e5fcfdc96e17a81f6.tar.zst
freebsd-ports-gnome-c5d4cd5d5cbcd9f16aa5bd8e5fcfdc96e17a81f6.zip
Merge remote-tracking branch 'upstream/master'
Diffstat (limited to 'shells')
-rw-r--r--shells/bashc/Makefile2
-rw-r--r--shells/flash/Makefile2
-rw-r--r--shells/ksh93-devel/Makefile7
-rw-r--r--shells/ksh93-devel/distinfo6
-rw-r--r--shells/ksh93-devel/files/extra-patch-install-as-ksh9313
-rw-r--r--shells/ksh93-devel/files/extra-patch-install-as-ksh93-doc10
-rw-r--r--shells/ksh93-devel/pkg-plist30
-rw-r--r--shells/v7sh/Makefile2
8 files changed, 56 insertions, 16 deletions
diff --git a/shells/bashc/Makefile b/shells/bashc/Makefile
index ade400ecbc15..b8de13f7a64d 100644
--- a/shells/bashc/Makefile
+++ b/shells/bashc/Makefile
@@ -13,6 +13,8 @@ COMMENT= GNU bash shell extended with visual two-panel file browser
MAKE_JOBS_UNSAFE= yes
BROKEN= unfetchable
+DEPRECATED= Unfetchable, unmaintained
+EXPIRATION_DATE= 2019-10-16
BROKEN_aarch64= Fails to link: missing sbrk
USES= tar:tgz
diff --git a/shells/flash/Makefile b/shells/flash/Makefile
index 52a1e2df7eb0..27c643307f67 100644
--- a/shells/flash/Makefile
+++ b/shells/flash/Makefile
@@ -10,6 +10,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Ncurses-based restriction shell
BROKEN= unfetchable
+DEPRECATED= Unfetchable, unmaintained
+EXPIRATION_DATE= 2019-10-16
USES= gmake ncurses
GNU_CONFIGURE= yes
diff --git a/shells/ksh93-devel/Makefile b/shells/ksh93-devel/Makefile
index 4492a80f9108..abef9546428c 100644
--- a/shells/ksh93-devel/Makefile
+++ b/shells/ksh93-devel/Makefile
@@ -12,8 +12,8 @@ LICENSE= EPL
USES= compiler:c11 meson ninja python:build
-HASH= 657c587
-AST_COMMIT_DATE= 2019.09.03
+HASH= 4c9c5964
+AST_COMMIT_DATE= 2019.09.20
USE_GITHUB= yes
GH_ACCOUNT= att
@@ -31,7 +31,8 @@ OPTIONS_SINGLE_BIN_KSH= KSH KSH93
KSH_DESC= Install to ${PREFIX}/bin/ksh
KSH93_DESC= Install to ${PREFIX}/bin/ksh93
-KSH93_EXTRA_PATCHES= ${FILESDIR}/extra-patch-install-as-ksh93
+KSH93_EXTRA_PATCHES= ${FILESDIR}/extra-patch-install-as-ksh93 \
+ ${FILESDIR}/extra-patch-install-as-ksh93-doc
KSH_PLIST_SUB= 93=""
KSH93_PLIST_SUB= 93="93"
diff --git a/shells/ksh93-devel/distinfo b/shells/ksh93-devel/distinfo
index 813a4dfab61c..0354e6cb10c4 100644
--- a/shells/ksh93-devel/distinfo
+++ b/shells/ksh93-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1567565030
-SHA256 (att-ast-2019.09.03-657c587_GH0.tar.gz) = 62494fb5d9dfa3d201091a7df19654806110db8b969546b9d64ec271be27baba
-SIZE (att-ast-2019.09.03-657c587_GH0.tar.gz) = 2023290
+TIMESTAMP = 1569007331
+SHA256 (att-ast-2019.09.20-4c9c5964_GH0.tar.gz) = f35f639f9de38887ed425ade1b3e1dfaced8e0fcd35b941deaa06b34f41f935a
+SIZE (att-ast-2019.09.20-4c9c5964_GH0.tar.gz) = 2113253
diff --git a/shells/ksh93-devel/files/extra-patch-install-as-ksh93 b/shells/ksh93-devel/files/extra-patch-install-as-ksh93
index 44f3603721b4..e6406f59b035 100644
--- a/shells/ksh93-devel/files/extra-patch-install-as-ksh93
+++ b/shells/ksh93-devel/files/extra-patch-install-as-ksh93
@@ -1,6 +1,6 @@
---- ./src/cmd/ksh93/meson.build.orig 2019-08-25 15:52:12.000000000 -0700
-+++ ./src/cmd/ksh93/meson.build 2019-08-28 12:34:47.804820000 -0700
-@@ -26,19 +26,19 @@
+--- ./src/cmd/ksh93/meson.build.orig 2019-09-16 17:08:04.000000000 -0700
++++ ./src/cmd/ksh93/meson.build 2019-09-17 11:55:21.799030000 -0700
+@@ -27,13 +27,13 @@
dependencies: [libm_dep, libexecinfo_dep, libdl_dep, libsocket_dep, libnsl_dep],
install: get_option('default_library') == 'shared')
@@ -16,10 +16,3 @@
include_directories: [configuration_incdir, ksh93_incdir],
link_with: [libksh, libast, libcmd, libdll],
dependencies: [libm_dep, libexecinfo_dep, libdl_dep, libsocket_dep, libnsl_dep],
- install: true)
-
--install_man('docs/ksh.1')
-+install_man('docs/ksh93.1')
-
- test_dir = join_paths(meson.current_source_dir(), 'tests')
- test_driver = join_paths(test_dir, 'util', 'run_test.sh')
diff --git a/shells/ksh93-devel/files/extra-patch-install-as-ksh93-doc b/shells/ksh93-devel/files/extra-patch-install-as-ksh93-doc
new file mode 100644
index 000000000000..35e8b7d6dd8e
--- /dev/null
+++ b/shells/ksh93-devel/files/extra-patch-install-as-ksh93-doc
@@ -0,0 +1,10 @@
+--- src/cmd/ksh93/docs/meson.build.orig 2019-09-16 17:08:04.000000000 -0700
++++ src/cmd/ksh93/docs/meson.build 2019-09-17 12:15:14.321848000 -0700
+@@ -3,6 +3,6 @@
+ # default man page directory: /usr/local/share/man/man1. The man pages for individual builtins will
+ # be installed in /usr/local/share/ksh/man.
+ #
+-install_man('ksh.1', install_mode: 'rw-r--r--')
++install_man('ksh93.1', install_mode: 'rw-r--r--')
+
+ # See also scripts/install_aux_files.sh which takes care of installing the private man pages.
diff --git a/shells/ksh93-devel/pkg-plist b/shells/ksh93-devel/pkg-plist
index 6dab70e96c94..8421d316fd99 100644
--- a/shells/ksh93-devel/pkg-plist
+++ b/shells/ksh93-devel/pkg-plist
@@ -1,3 +1,33 @@
@shell bin/ksh%%93%%
bin/shcomp%%93%%
man/man1/ksh%%93%%.1.gz
+share/ksh/config.ksh
+share/ksh/functions/_ksh_print_help
+share/ksh/functions/dirs
+share/ksh/functions/man
+share/ksh/functions/popd
+share/ksh/functions/pushd
+share/ksh/man/man1/alias.1
+share/ksh/man/man1/basename.1
+share/ksh/man/man1/bg.1
+share/ksh/man/man1/break.1
+share/ksh/man/man1/builtin.1
+share/ksh/man/man1/cat.1
+share/ksh/man/man1/cd.1
+share/ksh/man/man1/chmod.1
+share/ksh/man/man1/cmp.1
+share/ksh/man/man1/command.1
+share/ksh/man/man1/continue.1
+share/ksh/man/man1/cut.1
+share/ksh/man/man1/dirname.1
+share/ksh/man/man1/disown.1
+share/ksh/man/man1/echo.1
+share/ksh/man/man1/enum.1
+share/ksh/man/man1/eval.1
+share/ksh/man/man1/exec.1
+share/ksh/man/man1/exit.1
+share/ksh/man/man1/export.1
+share/ksh/man/man1/fg.1
+share/ksh/man/man1/head.1
+share/ksh/man/man1/hist.1
+share/ksh/man/man1/source.1
diff --git a/shells/v7sh/Makefile b/shells/v7sh/Makefile
index fb78b5957078..4a40e4838848 100644
--- a/shells/v7sh/Makefile
+++ b/shells/v7sh/Makefile
@@ -21,6 +21,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Implementation of the UNIX 7th Edition shell
BROKEN= unfetchable
+DEPRECATED= Unfetchable, unmaintained
+EXPIRATION_DATE= 2019-10-16
BROKEN_aarch64= Fails to link: missing sbrk
USES= uidfix