aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-10-16 09:31:58 +0800
committerkris <kris@FreeBSD.org>2003-10-16 09:31:58 +0800
commitda8461ff2ec762292299f15fc11acb1c8964991e (patch)
treef89e331d5f2e08ecfea6d61ae8acc9965049b439 /shells
parentaacf2ddd5568a006dd10f1707dbfc411828817ce (diff)
downloadfreebsd-ports-gnome-da8461ff2ec762292299f15fc11acb1c8964991e.tar.gz
freebsd-ports-gnome-da8461ff2ec762292299f15fc11acb1c8964991e.tar.zst
freebsd-ports-gnome-da8461ff2ec762292299f15fc11acb1c8964991e.zip
BROKEN on 5.x: does not compile
Diffstat (limited to 'shells')
-rw-r--r--shells/bash1/Makefile8
-rw-r--r--shells/wapsh/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/shells/bash1/Makefile b/shells/bash1/Makefile
index 649b5b911f4d..e44b06377eaa 100644
--- a/shells/bash1/Makefile
+++ b/shells/bash1/Makefile
@@ -22,7 +22,13 @@ NOMANCOMPRESS= yes
MAN1= bash.1 bash_builtins.1
INFO= bash
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
post-install:
@install-info ${PREFIX}/info/bash.info ${PREFIX}/info/dir
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/shells/wapsh/Makefile b/shells/wapsh/Makefile
index 3da577109096..c3c1d656e5bb 100644
--- a/shells/wapsh/Makefile
+++ b/shells/wapsh/Makefile
@@ -42,6 +42,12 @@ HTDOCS= command.php command_html.inc command_wml.inc \
login_html.php login_wml.php scroll_wml.php \
shortcuts_wml.php
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
post-patch:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/htshd/htshd.c > ${WRKDIR}/foo && \
${MV} ${WRKDIR}/foo ${WRKSRC}/htshd/htshd.c
@@ -96,4 +102,4 @@ post-install:
fi
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>