aboutsummaryrefslogtreecommitdiffstats
path: root/shells
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2001-02-28 02:33:39 +0800
committersteve <steve@FreeBSD.org>2001-02-28 02:33:39 +0800
commitfad960ae83f792c755c6a2d14bb77ad393db72e1 (patch)
tree433fd47bc6ab9a7819f4dcc0dc0a8bd0a341d6e3 /shells
parent37c8e0c6c9163c0252362743825046fe6a154ada (diff)
downloadfreebsd-ports-gnome-fad960ae83f792c755c6a2d14bb77ad393db72e1.tar.gz
freebsd-ports-gnome-fad960ae83f792c755c6a2d14bb77ad393db72e1.tar.zst
freebsd-ports-gnome-fad960ae83f792c755c6a2d14bb77ad393db72e1.zip
- Remove the custom do-extract target.
- Cleanup the do-build target. - Allow the ksh binary to be statically linked but default to dynamic to support dynamic loading of 'builtin' functions. Submitted by: Jacques A. Vidrine <n@nectar.com> Reviewed by: maintainer
Diffstat (limited to 'shells')
-rw-r--r--shells/ksh93/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/shells/ksh93/Makefile b/shells/ksh93/Makefile
index d25cf60261b1..3a923caef4a4 100644
--- a/shells/ksh93/Makefile
+++ b/shells/ksh93/Makefile
@@ -17,20 +17,17 @@ IS_INTERACTIVE= yes # must acknowledge license
DISTNAME= ${PORTNAME}-${VERSION}
DISTFILES= INIT.${VERSION}.tgz ast-ksh.${VERSION}.tgz
-EXTRACT_ONLY= INIT.${VERSION}.tgz
NO_WRKSUBDIR= yes
+MAKE_ARGS= CC='${CC}' CCFLAGS='${CFLAGS}' SHELL='${SH}'
+.if defined(WANT_STATIC)
+MAKE_ARGS+= LDFLAGS=-static
+.endif
MAN1= ksh93.1
-post-extract:
- @${MKDIR} ${WRKSRC}/lib/package/tgz
- @${LN} -s ${DISTDIR}/ast-ksh.${VERSION}.tgz ${WRKSRC}/lib/package/tgz/
- @cd ${WRKSRC}; bin/package read
-
do-build:
- @cd ${WRKSRC}; bin/package make \
- CC='${CC}' CCFLAGS='${CFLAGS}' LDFLAGS=-static
+ @cd ${WRKSRC}; bin/package make ${MAKE_ARGS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/arch/freebsd.${ARCH}/bin/ksh \