aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/ansible
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2016-02-26 07:05:59 +0800
committermatthew <matthew@FreeBSD.org>2016-02-26 07:05:59 +0800
commitce90f17b168d16978b713c940b6e9f58129049b1 (patch)
tree9187afde4dbfdd3ff7a59fbe99a08e76aae0ed1a /sysutils/ansible
parent5dd9f4f89e993b55d4ad301b4a3273a737b95d4c (diff)
downloadfreebsd-ports-gnome-ce90f17b168d16978b713c940b6e9f58129049b1.tar.gz
freebsd-ports-gnome-ce90f17b168d16978b713c940b6e9f58129049b1.tar.zst
freebsd-ports-gnome-ce90f17b168d16978b713c940b6e9f58129049b1.zip
Update to 2.0.1.0
This is primarily a bugfix release. This also includes a merge of the two local bugfix patches. ChangeLog: https://raw.githubusercontent.com/ansible/ansible/v2.0.1.0-1/CHANGELOG.md PR: 207490 Submitted by: lifanov@mail.lifanov.com (maintainer)
Diffstat (limited to 'sysutils/ansible')
-rw-r--r--sysutils/ansible/Makefile6
-rw-r--r--sysutils/ansible/distinfo4
-rw-r--r--sysutils/ansible/files/extra-patch-6bf2f4531
-rw-r--r--sysutils/ansible/files/extra-patch-8647fdc21
4 files changed, 3 insertions, 59 deletions
diff --git a/sysutils/ansible/Makefile b/sysutils/ansible/Makefile
index aa7755955e57..1954435ea8f8 100644
--- a/sysutils/ansible/Makefile
+++ b/sysutils/ansible/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ansible
-PORTVERSION?= 2.0.0.2
-PORTREVISION?= 3
+PORTVERSION?= 2.0.1.0
CATEGORIES= sysutils python
MASTER_SITES= http://releases.ansible.com/ansible/
@@ -18,9 +17,6 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
${PYTHON_PKGNAMEPREFIX}paramiko>0:${PORTSDIR}/security/py-paramiko \
${PYTHON_PKGNAMEPREFIX}Jinja2>0:${PORTSDIR}/devel/py-Jinja2
-EXTRA_PATCHES?= ${FILESDIR}/extra-patch-8647fdc \
- ${FILESDIR}/extra-patch-6bf2f45
-
NO_ARCH= yes
USES= cpe python:2 shebangfix
USE_PYTHON= autoplist distutils
diff --git a/sysutils/ansible/distinfo b/sysutils/ansible/distinfo
index af13a2178c4f..cacb809a0ef4 100644
--- a/sysutils/ansible/distinfo
+++ b/sysutils/ansible/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ansible-2.0.0.2.tar.gz) = 27db0b99113fab85b1430c361c7790a0aa7f5c614c9af13362e2adbba07e5828
-SIZE (ansible-2.0.0.2.tar.gz) = 1497944
+SHA256 (ansible-2.0.1.0.tar.gz) = cddc4fa6af4c1be6cd1d6634de1bd0397abad921c76b32cab6722c042744ee5d
+SIZE (ansible-2.0.1.0.tar.gz) = 1510155
diff --git a/sysutils/ansible/files/extra-patch-6bf2f45 b/sysutils/ansible/files/extra-patch-6bf2f45
deleted file mode 100644
index 3e4d2da1f4e9..000000000000
--- a/sysutils/ansible/files/extra-patch-6bf2f45
+++ /dev/null
@@ -1,31 +0,0 @@
---- lib/ansible/playbook/play_context.py.orig 2016-01-14 22:33:27 UTC
-+++ lib/ansible/playbook/play_context.py
-@@ -446,8 +446,10 @@ class PlayContext(Base):
-
- if self.become_method == 'sudo':
- # If we have a password, we run sudo with a randomly-generated
-- # prompt set using -p. Otherwise we run it with -n, which makes
-+ # prompt set using -p. Otherwise we run it with default -n, which makes
- # it fail if it would have prompted for a password.
-+ # Cannot rely on -n as it can be removed from defaults, which should be
-+ # done for older versions of sudo that do not support the option.
- #
- # Passing a quoted compound command to sudo (or sudo -s)
- # directly doesn't work, so we shellquote it with pipes.quote()
-@@ -463,12 +465,14 @@ class PlayContext(Base):
-
- elif self.become_method == 'su':
-
-+ # passing code ref to examine prompt as simple string comparisson isn't good enough with su
- def detect_su_prompt(data):
- SU_PROMPT_LOCALIZATIONS_RE = re.compile("|".join(['(\w+\'s )?' + x + ' ?: ?' for x in SU_PROMPT_LOCALIZATIONS]), flags=re.IGNORECASE)
- return bool(SU_PROMPT_LOCALIZATIONS_RE.match(data))
--
- prompt = detect_su_prompt
-- becomecmd = '%s %s %s -c "%s -c %s"' % (exe, flags, self.become_user, executable, success_cmd)
-+
-+ su_success_cmd = '%s -c %s' % (executable, success_cmd) # this is here cause su too succeptible to overquoting
-+ becomecmd = '%s %s %s -c %s' % (exe, flags, self.become_user, su_success_cmd) #works with sh
-
- elif self.become_method == 'pbrun':
-
diff --git a/sysutils/ansible/files/extra-patch-8647fdc b/sysutils/ansible/files/extra-patch-8647fdc
deleted file mode 100644
index 5f1290caa43c..000000000000
--- a/sysutils/ansible/files/extra-patch-8647fdc
+++ /dev/null
@@ -1,21 +0,0 @@
---- lib/ansible/plugins/action/__init__.py.orig 2016-01-14 22:33:27 UTC
-+++ lib/ansible/plugins/action/__init__.py
-@@ -475,8 +475,7 @@ class ActionBase(with_metaclass(ABCMeta,
- display.debug("done with _execute_module (%s, %s)" % (module_name, module_args))
- return data
-
-- def _low_level_execute_command(self, cmd, sudoable=True, in_data=None,
-- executable=None, encoding_errors='replace'):
-+ def _low_level_execute_command(self, cmd, sudoable=True, in_data=None, executable=C.DEFAULT_EXECUTABLE, encoding_errors='replace'):
- '''
- This is the function which executes the low level shell command, which
- may be commands to create/remove directories for temporary files, or to
-@@ -492,7 +491,7 @@ class ActionBase(with_metaclass(ABCMeta,
- '''
-
- if executable is not None:
-- cmd = executable + ' -c ' + cmd
-+ cmd = executable + ' -c ' + pipes.quote(cmd)
-
- display.debug("_low_level_execute_command(): starting")
- if not cmd: