aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/byobu
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2011-07-19 10:02:03 +0800
committerstephen <stephen@FreeBSD.org>2011-07-19 10:02:03 +0800
commitbb7d1171da417fc16eed6253c688ce4a6e99303c (patch)
treef3d977eddb24930dc05bf96cd7127695877a0566 /sysutils/byobu
parent549c1bc01cc6af625d7869923f6103cb440a624d (diff)
downloadfreebsd-ports-gnome-bb7d1171da417fc16eed6253c688ce4a6e99303c.tar.gz
freebsd-ports-gnome-bb7d1171da417fc16eed6253c688ce4a6e99303c.tar.zst
freebsd-ports-gnome-bb7d1171da417fc16eed6253c688ce4a6e99303c.zip
- Make PREFIX compliant, and add dependency to bash.
- Make PORTDOCS compliant. - Bump portrevision. PR: ports/158732 Submitted by: Thomas Schweikle <tps@vr-web.de> and Gea-Suan Lin <gslin@gslin.org> Approved by: maho (mentor) and gslin@gslin.org (maintainer)
Diffstat (limited to 'sysutils/byobu')
-rw-r--r--sysutils/byobu/Makefile19
-rw-r--r--sysutils/byobu/pkg-plist20
2 files changed, 27 insertions, 12 deletions
diff --git a/sysutils/byobu/Makefile b/sysutils/byobu/Makefile
index ca4c7ff219a1..1f3f9cb66d41 100644
--- a/sysutils/byobu/Makefile
+++ b/sysutils/byobu/Makefile
@@ -7,16 +7,20 @@
PORTNAME= byobu
PORTVERSION= 3.29
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://launchpadlibrarian.net/65243016/
-DISTFILES= ${PORTNAME}_${PORTVERSION}.orig${EXTRACT_SUFX}
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
MAINTAINER= gslin@gslin.org
COMMENT= Profile and configuration utilities for GNU Screen
-RUN_DEPENDS= ${LOCALBASE}/bin/screen:${PORTSDIR}/sysutils/screen
+RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash \
+ ${LOCALBASE}/bin/screen:${PORTSDIR}/sysutils/screen
GNU_CONFIGURE= yes
+USE_PYTHON= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAN1= byobu-config.1 \
byobu-disable.1 \
@@ -35,4 +39,15 @@ MAN1= byobu-config.1 \
byobu.1 \
shell.1
+post-patch:
+ ${REINPLACE_CMD} \
+ -e "s@/bin/bash@${LOCALBASE}/bin/bash@" \
+ -e "s@/usr/bin/python@${PYTHON_CMD}@" \
+ ${WRKSRC}/usr/bin/*
+.if defined(NOPORTDOCS)
+ ${REINPLACE_CMD} \
+ -e "s@^install:.*@install:@" \
+ ${WRKSRC}/usr/share/doc/byobu/Makefile.in
+.endif
+
.include <bsd.port.mk>
diff --git a/sysutils/byobu/pkg-plist b/sysutils/byobu/pkg-plist
index 95033b740220..ec45b2c19bdd 100644
--- a/sysutils/byobu/pkg-plist
+++ b/sysutils/byobu/pkg-plist
@@ -14,7 +14,7 @@
%%DATADIR%%/profiles/statusrc
%%DATADIR%%/tests/byobu-time-notifications
%%DATADIR%%/windows/common
-%%DOCSDIR%%/help.txt
+%%PORTDOCS%%%%DOCSDIR%%/help.txt
bin/byobu
bin/byobu-config
bin/byobu-disable
@@ -72,12 +72,12 @@ lib/byobu/whoami
lib/byobu/wifi_quality
share/applications/byobu.desktop
@dirrmtry share/applications
-@dirrmtry lib/byobu
-@dirrm %%DOCSDIR%%
-@dirrmtry %%DATADIR%%/windows
-@dirrmtry %%DATADIR%%/tests
-@dirrmtry %%DATADIR%%/profiles
-@dirrmtry %%DATADIR%%/pixmaps
-@dirrmtry %%DATADIR%%/keybindings
-@dirrmtry %%DATADIR%%/ec2
-@dirrmtry %%DATADIR%%
+@dirrm lib/byobu
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/windows
+@dirrm %%DATADIR%%/tests
+@dirrm %%DATADIR%%/profiles
+@dirrm %%DATADIR%%/pixmaps
+@dirrm %%DATADIR%%/keybindings
+@dirrm %%DATADIR%%/ec2
+@dirrm %%DATADIR%%