aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/cfengine33/Makefile
diff options
context:
space:
mode:
authorgjb <gjb@FreeBSD.org>2012-10-25 10:38:27 +0800
committergjb <gjb@FreeBSD.org>2012-10-25 10:38:27 +0800
commit36b6173a99b102904aba1d89267ab5a76751defe (patch)
treefada5e48a5cc3554067efc910ce76b8ca2609ff8 /sysutils/cfengine33/Makefile
parentc9633d5dfc9edc0f966602b1a5a72dbe78b23671 (diff)
downloadfreebsd-ports-gnome-36b6173a99b102904aba1d89267ab5a76751defe.tar.gz
freebsd-ports-gnome-36b6173a99b102904aba1d89267ab5a76751defe.tar.zst
freebsd-ports-gnome-36b6173a99b102904aba1d89267ab5a76751defe.zip
- Update to 3.3.8
- Convert to OptionsNG - Trim headers Approved by: cy (maintainer, via small keyboard), crees (mentor, implicit) Feature safe: yes
Diffstat (limited to 'sysutils/cfengine33/Makefile')
-rw-r--r--sysutils/cfengine33/Makefile40
1 files changed, 16 insertions, 24 deletions
diff --git a/sysutils/cfengine33/Makefile b/sysutils/cfengine33/Makefile
index c75675797eda..2c09c7b57bc1 100644
--- a/sysutils/cfengine33/Makefile
+++ b/sysutils/cfengine33/Makefile
@@ -1,13 +1,9 @@
-
-# Date created: February 2, 2009
-# Whom: jrhett@netconsonance.com
-#
+# Created by: jrhett@netconsonance.com
# $FreeBSD$
#
PORTNAME= cfengine
-PORTVERSION= 3.3.5
-PORTREVISION= 1
+PORTVERSION= 3.3.8
CATEGORIES= sysutils
MASTER_SITES= http://cfengine.com/source-code/download?file=
@@ -35,46 +31,42 @@ CONFIGURE_ARGS= --docdir=${DOCSDIR} \
LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
-OPTIONS= TOKYOCABINET "Enable TokyoCabinet support" on \
- QDBM "Enable QDBM support" off \
- PGSQL "Enable PostgreSQL connector" off \
- MYSQL "Enable MySQL connector" off \
- LIBVIRT "Enable libvirt compatibility" off
+OPTIONS_DEFINE= PGSQL MYSQL LIBVIRT
+OPTIONS_SINGLE= DB
+OPTIONS_SINGLE_DB= TOKYOCABINET QDBM
+TOKYOCABINET_DESC= Enable TokyoCabinet database backend
+QDBM_DESC= Enable QDBM database backend
+PGSQL_DESC= Enable PostgreSQL integration
+MYSQL_DESC= Enable MySQL integration
+LIBVIRT_DESC= Enable libvirt integration
+OPTIONS_DEFAULT=TOKYOCABINET
.include <bsd.port.pre.mk>
-.if defined(WITH_TOKYOCABINET) && defined(WITH_QDBM)
-BROKEN= TOKYOCABINET and QDBM are mutuallly exclusive
-.endif
-
-.if !defined(WITH_TOKYOCABINET) && !defined(WITH_QDBM)
-BROKEN= TOKYOCABINET or QDBM must be defined
-.endif
-
-.if defined(WITH_TOKYOCABINET)
+.if ${PORT_OPTIONS:MTOKYOCABINET}
CONFIGURE_ARGS+= --with-tokyocabinet=${LOCALBASE}
LIB_DEPENDS+= tokyocabinet.9:${PORTSDIR}/databases/tokyocabinet
.endif
-.if defined(WITH_QDBM)
+.if ${PORT_OPTIONS:MQDBM}
CONFIGURE_ARGS+= --with-qdbm=${LOCALBASE}
LIB_DEPENDS+= qdbm.14:${PORTSDIR}/databases/qdbm
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
CONFIGURE_ARGS+= --with-postgresql=${LOCALBASE}
LIB_DEPENDS+= pq:${PORTSDIR}/databases/postgresql${PGSQL_VER}-client
.endif
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
LIB_DEPENDS+= mysqlclient:${PORTSDIR}/${_MYSQL_CLIENT}
LDFLAGS+= -L${LOCALBASE}/lib/mysql
.endif
-.if defined(WITH_LIBVIRT)
+.if ${PORT_OPTIONS:MLIBVIRT}
CONFIGURE_ARGS+= --with-libvirt=${LOCALBASE}
LIB_DEPENDS+= virt:${PORTSDIR}/devel/libvirt
.endif