aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/conky
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2016-09-29 23:57:40 +0800
committermadpilot <madpilot@FreeBSD.org>2016-09-29 23:57:40 +0800
commite04b8960b851dc9bad539e5b417cc297cec1fd30 (patch)
tree3675462bc4c6b1a0fc3794156bff89e802107496 /sysutils/conky
parente623563f2c9c426ae8ebf0e4ab6402c3c9574c58 (diff)
downloadfreebsd-ports-gnome-e04b8960b851dc9bad539e5b417cc297cec1fd30.tar.gz
freebsd-ports-gnome-e04b8960b851dc9bad539e5b417cc297cec1fd30.tar.zst
freebsd-ports-gnome-e04b8960b851dc9bad539e5b417cc297cec1fd30.zip
Fix ${top name} configuration variable output.
Reported by: Szabolcs Grof <grof.szabolcs at gmail.com> (via email, with patch)
Diffstat (limited to 'sysutils/conky')
-rw-r--r--sysutils/conky/Makefile2
-rw-r--r--sysutils/conky/files/patch-src_freebsd.cc10
2 files changed, 10 insertions, 2 deletions
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index ab41e6b64732..671f70dfc649 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -4,7 +4,7 @@
PORTNAME= conky
PORTVERSION= 1.10.4
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MAINTAINER= madpilot@FreeBSD.org
diff --git a/sysutils/conky/files/patch-src_freebsd.cc b/sysutils/conky/files/patch-src_freebsd.cc
index 0e89b18f9fe1..6aa9be65eb56 100644
--- a/sysutils/conky/files/patch-src_freebsd.cc
+++ b/sysutils/conky/files/patch-src_freebsd.cc
@@ -51,7 +51,15 @@
}
double get_battery_perct_bar(struct text_object *obj)
-@@ -745,11 +725,14 @@ void get_battery_short_status(char *buff
+@@ -729,6 +709,7 @@ void get_top_info(void)
+
+ proc->time_stamp = g_time;
+ proc->name = strndup(p[i].ki_comm, text_buffer_size.get(*state));
++ proc->basename = strndup(p[i].ki_comm, text_buffer_size.get(*state));
+ proc->amount = 100.0 * p[i].ki_pctcpu / FSCALE;
+ proc->vsize = p[i].ki_size;
+ proc->rss = (p[i].ki_rssize * getpagesize());
+@@ -745,11 +726,14 @@ void get_battery_short_status(char *buff
if (0 == strncmp("charging", buffer, 8)) {
buffer[0] = 'C';
memmove(buffer + 1, buffer + 8, n - 8);