aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/consul-alerts
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2019-09-30 06:34:31 +0800
committerDmitri Goutnik <dmgk@FreeBSD.org>2019-09-30 06:34:31 +0800
commitfc95b3f0cf943e760e906eac92aac51eff4d0c1c (patch)
tree8b41993e1df35d7245f4013a2d3adcb758a276a1 /sysutils/consul-alerts
parent67c4b925b7fd606361a2152563b80da493232dfb (diff)
downloadfreebsd-ports-gnome-fc95b3f0cf943e760e906eac92aac51eff4d0c1c.tar.gz
freebsd-ports-gnome-fc95b3f0cf943e760e906eac92aac51eff4d0c1c.tar.zst
freebsd-ports-gnome-fc95b3f0cf943e760e906eac92aac51eff4d0c1c.zip
Go ports: cleanup, finish transition to USES=go started with r505321 (cat. sysutils-x11)
- Remove custom build/install targets left in place after r505321 - Switch to the new GO_TARGET tuple syntax introduced in r512001 Reviewed by: tobik Approved by: araujo (mentor), portmgr (adamw) Differential Revision: https://reviews.freebsd.org/D21744
Diffstat (limited to 'sysutils/consul-alerts')
-rw-r--r--sysutils/consul-alerts/Makefile27
1 files changed, 7 insertions, 20 deletions
diff --git a/sysutils/consul-alerts/Makefile b/sysutils/consul-alerts/Makefile
index 7d82e534f8bd..247085c93c5d 100644
--- a/sysutils/consul-alerts/Makefile
+++ b/sysutils/consul-alerts/Makefile
@@ -10,32 +10,19 @@ COMMENT= Simple daemon to send notifications based on Consul health checks
LICENSE= GPLv2+
-USES= compiler go
+USES= go
USE_GITHUB= yes
GH_ACCOUNT= AcalephStorage
GH_SUBDIR= src/github.com/AcalephStorage/consul-alerts
-GH_TUPLE= aws:aws-sdk-go:v1.8.30:aws_sdk_go/src/github.com/aws/aws-sdk-go \
- imdario:mergo:0.2.2:mergo/src/github.com/imdario/mergo \
- mitchellh:hashstructure:9204ce5:hashstructure/src/github.com/mitchellh/hashstructure
+GH_TUPLE= aws:aws-sdk-go:v1.8.30:aws_sdk_go/vendor/github.com/aws/aws-sdk-go \
+ imdario:mergo:0.2.2:mergo/vendor/github.com/imdario/mergo \
+ mitchellh:hashstructure:9204ce5:hashstructure/vendor/github.com/mitchellh/hashstructure
+
+GO_BUILDFLAGS= -ldflags "-X main.GitDescribe=${DISTVERSIONFULL}"
PLIST_FILES= ${PREFIX}/bin/${PORTNAME}
USE_RC_SUBR= ${PORTNAME}
-do-build:
- cd ${GO_WRKSRC} && \
- ${SETENV} ${MAKE_ENV} ${BUILD_ENV} GOPATH=${WRKSRC} go build -v -x \
- -ldflags "-X main.GitDescribe=${DISTVERSIONFULL}" -o bin/${PORTNAME}
-
-do-install:
- ${INSTALL_PROGRAM} ${GO_WRKSRC}/bin/${PORTNAME} \
- ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-
-.include <bsd.port.pre.mk>
-
-.if ${COMPILER_TYPE} == clang
-BUILD_ENV= CC=clang
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>