aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/coreutils
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2004-10-13 01:34:12 +0800
committerleeym <leeym@FreeBSD.org>2004-10-13 01:34:12 +0800
commitf57cff3ba82c8a8f89f217230f5e2d67eb57ac10 (patch)
treecab7ea087fe15c6ce2bb77cadcc61cbcda090cbc /sysutils/coreutils
parent309363b090c2ffb7777db3e9b0fea4167d272519 (diff)
downloadfreebsd-ports-gnome-f57cff3ba82c8a8f89f217230f5e2d67eb57ac10.tar.gz
freebsd-ports-gnome-f57cff3ba82c8a8f89f217230f5e2d67eb57ac10.tar.zst
freebsd-ports-gnome-f57cff3ba82c8a8f89f217230f5e2d67eb57ac10.zip
- fix CONFLICTS
- add WITHOUT_NLS for USE_GETTEXT - don't make install in WRKSRC/lib, which will install useless charset.alias PR: ports/71579 Submitted by: leeym Approved by: maintainer
Diffstat (limited to 'sysutils/coreutils')
-rw-r--r--sysutils/coreutils/Makefile14
-rw-r--r--sysutils/coreutils/pkg-plist168
2 files changed, 116 insertions, 66 deletions
diff --git a/sysutils/coreutils/Makefile b/sysutils/coreutils/Makefile
index f6aee1006d84..d1ac6285e5f0 100644
--- a/sysutils/coreutils/Makefile
+++ b/sysutils/coreutils/Makefile
@@ -16,12 +16,11 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= jharris@widomaker.com
COMMENT= The Free Software Foundation's core utilities
-CONFLICTS= sh-utils-* fileutils-* textutils-* id-utils-*
+CONFLICTS= sh-utils-[0-9]* fileutils-[0-9]* textutils-[0-9]* id-utils-[0-9]*
USE_GPG?= yes
SIG_FILES= ${DISTNAME}${EXTRACT_SUFX}.sig
USE_BZIP2= yes
-USE_GETTEXT= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
CONFIGURE_ARGS= --program-prefix=g
@@ -29,6 +28,14 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
INFO= coreutils
MAN1= gbasename.1 gcat.1 gchgrp.1 gchmod.1 gchown.1 gchroot.1 gcksum.1 \
@@ -52,6 +59,9 @@ post-patch:
@${REINPLACE_CMD} -e "s/u\+s/u\+w/g" ${WRKSRC}/src/Makefile.in
.endif
+post-build:
+ @${REINPLACE_CMD} -e "s/ lib / /g" ${WRKSRC}/Makefile
+
post-install: install-info
install-info:
diff --git a/sysutils/coreutils/pkg-plist b/sysutils/coreutils/pkg-plist
index 857f2f1ac8bf..b734cb5a7ebb 100644
--- a/sysutils/coreutils/pkg-plist
+++ b/sysutils/coreutils/pkg-plist
@@ -88,67 +88,107 @@ bin/gwc
bin/gwho
bin/gwhoami
bin/gyes
-share/locale/af/LC_MESSAGES/coreutils.mo
-share/locale/af/LC_TIME/coreutils.mo
-share/locale/be/LC_MESSAGES/coreutils.mo
-share/locale/be/LC_TIME/coreutils.mo
-share/locale/ca/LC_MESSAGES/coreutils.mo
-share/locale/ca/LC_TIME/coreutils.mo
-share/locale/cs/LC_MESSAGES/coreutils.mo
-share/locale/cs/LC_TIME/coreutils.mo
-share/locale/da/LC_MESSAGES/coreutils.mo
-share/locale/da/LC_TIME/coreutils.mo
-share/locale/de/LC_MESSAGES/coreutils.mo
-share/locale/de/LC_TIME/coreutils.mo
-share/locale/el/LC_MESSAGES/coreutils.mo
-share/locale/el/LC_TIME/coreutils.mo
-share/locale/es/LC_MESSAGES/coreutils.mo
-share/locale/es/LC_TIME/coreutils.mo
-share/locale/et/LC_MESSAGES/coreutils.mo
-share/locale/et/LC_TIME/coreutils.mo
-share/locale/fi/LC_MESSAGES/coreutils.mo
-share/locale/fi/LC_TIME/coreutils.mo
-share/locale/fr/LC_MESSAGES/coreutils.mo
-share/locale/fr/LC_TIME/coreutils.mo
-share/locale/ga/LC_MESSAGES/coreutils.mo
-share/locale/ga/LC_TIME/coreutils.mo
-share/locale/gl/LC_MESSAGES/coreutils.mo
-share/locale/gl/LC_TIME/coreutils.mo
-share/locale/hu/LC_MESSAGES/coreutils.mo
-share/locale/hu/LC_TIME/coreutils.mo
-share/locale/it/LC_MESSAGES/coreutils.mo
-share/locale/it/LC_TIME/coreutils.mo
-share/locale/ja/LC_MESSAGES/coreutils.mo
-share/locale/ja/LC_TIME/coreutils.mo
-share/locale/ko/LC_MESSAGES/coreutils.mo
-share/locale/ko/LC_TIME/coreutils.mo
-share/locale/lg/LC_MESSAGES/coreutils.mo
-share/locale/lg/LC_TIME/coreutils.mo
-share/locale/ms/LC_MESSAGES/coreutils.mo
-share/locale/ms/LC_TIME/coreutils.mo
-share/locale/nb/LC_MESSAGES/coreutils.mo
-share/locale/nb/LC_TIME/coreutils.mo
-share/locale/nl/LC_MESSAGES/coreutils.mo
-share/locale/nl/LC_TIME/coreutils.mo
-share/locale/no/LC_MESSAGES/coreutils.mo
-share/locale/no/LC_TIME/coreutils.mo
-share/locale/pl/LC_MESSAGES/coreutils.mo
-share/locale/pl/LC_TIME/coreutils.mo
-share/locale/pt/LC_MESSAGES/coreutils.mo
-share/locale/pt/LC_TIME/coreutils.mo
-share/locale/pt_BR/LC_MESSAGES/coreutils.mo
-share/locale/pt_BR/LC_TIME/coreutils.mo
-share/locale/ru/LC_MESSAGES/coreutils.mo
-share/locale/ru/LC_TIME/coreutils.mo
-share/locale/sk/LC_MESSAGES/coreutils.mo
-share/locale/sk/LC_TIME/coreutils.mo
-share/locale/sl/LC_MESSAGES/coreutils.mo
-share/locale/sl/LC_TIME/coreutils.mo
-share/locale/sv/LC_MESSAGES/coreutils.mo
-share/locale/sv/LC_TIME/coreutils.mo
-share/locale/tr/LC_MESSAGES/coreutils.mo
-share/locale/tr/LC_TIME/coreutils.mo
-share/locale/zh_CN/LC_MESSAGES/coreutils.mo
-share/locale/zh_CN/LC_TIME/coreutils.mo
-share/locale/zh_TW/LC_MESSAGES/coreutils.mo
-share/locale/zh_TW/LC_TIME/coreutils.mo
+%%NLS%%share/locale/af/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/af/LC_TIME/coreutils.mo
+%%NLS%%share/locale/be/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/be/LC_TIME/coreutils.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/ca/LC_TIME/coreutils.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/cs/LC_TIME/coreutils.mo
+%%NLS%%share/locale/da/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/da/LC_TIME/coreutils.mo
+%%NLS%%share/locale/de/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/de/LC_TIME/coreutils.mo
+%%NLS%%share/locale/el/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/el/LC_TIME/coreutils.mo
+%%NLS%%share/locale/es/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/es/LC_TIME/coreutils.mo
+%%NLS%%share/locale/et/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/et/LC_TIME/coreutils.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/fi/LC_TIME/coreutils.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/fr/LC_TIME/coreutils.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/ga/LC_TIME/coreutils.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/gl/LC_TIME/coreutils.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/hu/LC_TIME/coreutils.mo
+%%NLS%%share/locale/it/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/it/LC_TIME/coreutils.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/ja/LC_TIME/coreutils.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/ko/LC_TIME/coreutils.mo
+%%NLS%%share/locale/lg/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/lg/LC_TIME/coreutils.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/ms/LC_TIME/coreutils.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/nb/LC_TIME/coreutils.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/nl/LC_TIME/coreutils.mo
+%%NLS%%share/locale/no/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/no/LC_TIME/coreutils.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/pl/LC_TIME/coreutils.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/pt/LC_TIME/coreutils.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/pt_BR/LC_TIME/coreutils.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/ru/LC_TIME/coreutils.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/sk/LC_TIME/coreutils.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/sl/LC_TIME/coreutils.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/sv/LC_TIME/coreutils.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/tr/LC_TIME/coreutils.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/zh_CN/LC_TIME/coreutils.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/coreutils.mo
+%%NLS%%share/locale/zh_TW/LC_TIME/coreutils.mo
+%%NLS%%@unexec rmdir %D/share/locale/zh_TW/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/zh_CN/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/tr/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/sv/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/sl/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/sk/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/ru/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/pt_BR/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/pt/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/pl/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/no/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/nl/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/nb/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/nb/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/ms/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/ms/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/lg/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/lg/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/lg 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/ko/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/ja/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/it/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/hu/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/gl/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/ga/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/ga/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/ga 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/fr/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/fi/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/et/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/es/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/el/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/de/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/da/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/cs/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/ca/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/be/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/af/LC_TIME 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/af/LC_MESSAGES 2>/dev/null || true
+%%NLS%%@unexec rmdir %D/share/locale/af 2>/dev/null || true