aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/dd_rescue
diff options
context:
space:
mode:
authorse <se@FreeBSD.org>2018-08-20 14:48:55 +0800
committerse <se@FreeBSD.org>2018-08-20 14:48:55 +0800
commit03a966c1e88119e844ccd8726ccf9edeb97ec38d (patch)
tree6cdbb342f16fc8546608e94f8cb64414b5f8632d /sysutils/dd_rescue
parente69b53e059f7e5f6a2abf79fbf1dd7c8a7836a0f (diff)
downloadfreebsd-ports-gnome-03a966c1e88119e844ccd8726ccf9edeb97ec38d.tar.gz
freebsd-ports-gnome-03a966c1e88119e844ccd8726ccf9edeb97ec38d.tar.zst
freebsd-ports-gnome-03a966c1e88119e844ccd8726ccf9edeb97ec38d.zip
Fix build by including sys/random.h.
Approved by: nobutaka (maintainer)
Diffstat (limited to 'sysutils/dd_rescue')
-rw-r--r--sysutils/dd_rescue/Makefile1
-rw-r--r--sysutils/dd_rescue/files/patch-random.c12
2 files changed, 13 insertions, 0 deletions
diff --git a/sysutils/dd_rescue/Makefile b/sysutils/dd_rescue/Makefile
index 45a8173852f2..7909f5facfaa 100644
--- a/sysutils/dd_rescue/Makefile
+++ b/sysutils/dd_rescue/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dd_rescue
PORTVERSION= 1.99.8
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.garloff.de/kurt/linux/ddrescue/ \
http://fossies.org/unix/privat/
diff --git a/sysutils/dd_rescue/files/patch-random.c b/sysutils/dd_rescue/files/patch-random.c
new file mode 100644
index 000000000000..e2a830f9b41c
--- /dev/null
+++ b/sysutils/dd_rescue/files/patch-random.c
@@ -0,0 +1,12 @@
+--- random.c.orig 2015-09-10 15:51:08 UTC
++++ random.c
+@@ -22,6 +22,9 @@ typedef unsigned int __u32;
+ #ifdef HAVE_LINUX_RANDOM_H
+ #include <linux/random.h>
+ #endif
++#ifdef __FreeBSD__
++#include <sys/random.h>
++#endif
+
+ static void msleep(unsigned int msecs)
+ {