aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/duplicity/Makefile
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-10-04 03:15:56 +0800
committerpawel <pawel@FreeBSD.org>2016-10-04 03:15:56 +0800
commit04e64fa52201ed82a0767656d199a532dfbf52b2 (patch)
treed1fd3d2891224361f3cb03110eb1476ec198e123 /sysutils/duplicity/Makefile
parent8e383086a9dc1896e3b5d8792d50cb65c1b9be63 (diff)
downloadfreebsd-ports-gnome-04e64fa52201ed82a0767656d199a532dfbf52b2.tar.gz
freebsd-ports-gnome-04e64fa52201ed82a0767656d199a532dfbf52b2.tar.zst
freebsd-ports-gnome-04e64fa52201ed82a0767656d199a532dfbf52b2.zip
- Update to version 0.7.10 [1]
- Modify options descriptions to match currents standards - Fix PEXPECT option, misc/py-pexpect does not install pexpect executable, convert check to path independent one - Convert to options helpers, break lines around 80 characters - Regenerate patch with make makepatch PR: 213145 [1] Submitted by: Arnaud de Prelle [1]
Diffstat (limited to 'sysutils/duplicity/Makefile')
-rw-r--r--sysutils/duplicity/Makefile85
1 files changed, 42 insertions, 43 deletions
diff --git a/sysutils/duplicity/Makefile b/sysutils/duplicity/Makefile
index 2a2708d4f2e0..c654f22b17a6 100644
--- a/sysutils/duplicity/Makefile
+++ b/sysutils/duplicity/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= duplicity
-PORTVERSION= 0.7.09
+PORTVERSION= 0.7.10
CATEGORIES= sysutils
MASTER_SITES= http://launchpad.net/duplicity/0.7-series/${PORTVERSION}/+download/
@@ -16,26 +16,26 @@ USES= python:2
USE_PYTHON= autoplist distutils
USE_LDCONFIG= yes
+PORTDOCS= CHANGELOG COPYING README README-REPO README-LOG
+
OPTIONS_DEFINE= CLOUDFILES DOCS FTP FTPS GDOCS GIO NLS S3
OPTIONS_GROUP= GPG SSH
OPTIONS_SINGLE= GPG
OPTIONS_SINGLE_GPG= GNUPG GNUPG2
OPTIONS_GROUP_SSH= PARAMIKO PEXPECT
OPTIONS_DEFAULT= FTP FTPS GNUPG PARAMIKO S3
-CLOUDFILES_DESC= Install CloudFiles backend
-FTP_DESC= Install FTP backend
-FTPS_DESC= Install FTPS backend
-GDOCS_DESC= Install Google Docs backend
-GIO_DESC= Install GIO backend
-GPG_DESC= Install GnuPG
-GNUPG_DESC= Install GnuPG 1
-GNUPG2_DESC= Install GnuPG 2
-S3_DESC= Install Amazon S3 backend
-SSH_DESC= Install SSH/SCP/SFTP backend
-PARAMIKO_DESC= Install python ssh implementation
-PEXPECT_DESC= Install pexpect and use ssh binaries
-
-PORTDOCS= CHANGELOG COPYING README README-REPO README-LOG
+CLOUDFILES_DESC= CloudFiles backend
+FTP_DESC= FTP backend
+FTPS_DESC= FTPS backend
+GDOCS_DESC= Google Docs backend
+GIO_DESC= GIO backend
+GPG_DESC= GnuPG support
+GNUPG_DESC= Use GnuPG 1
+GNUPG2_DESC= Use GnuPG 2
+S3_DESC= Amazon S3 backend
+SSH_DESC= SSH/SCP/SFTP backend
+PARAMIKO_DESC= python ssh implementation
+PEXPECT_DESC= pexpect and use ssh binaries
CLOUDFILES_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cloudfiles>0:net/py-cloudfiles
FTP_RUN_DEPENDS= ncftp>=3.2.2:ftp/ncftp3
@@ -47,54 +47,53 @@ GNUPG_RUN_DEPENDS= gnupg1>=1.4.7:security/gnupg1
GNUPG2_RUN_DEPENDS= gpg2:security/gnupg
NLS_USES= gettext
PARAMIKO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paramiko>=1.7.7.1:security/py-paramiko
-PEXPECT_RUN_DEPENDS= pexpect:misc/py-pexpect
+PEXPECT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pexpect>0:misc/py-pexpect
S3_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto>=1.6b:devel/py-boto
-.include <bsd.port.options.mk>
-
-post-patch:
-.if empty(PORT_OPTIONS:MNLS)
+post-patch-NLS-off:
@${REINPLACE_CMD} -e '56,67d' \
${WRKSRC}/setup.py
-.endif
-.if empty(PORT_OPTIONS:MPARAMIKO)
- @${FIND} ${WRKSRC}/${PORTNAME}/backends -type f -depth 1 -name '*ssh_paramiko*' -delete
-.endif
-.if empty(PORT_OPTIONS:MPEXPECT)
- @${FIND} ${WRKSRC}/${PORTNAME}/backends -type f -depth 1 -name '*ssh_pexpect*' -delete
-.endif
-.if empty(PORT_OPTIONS:MFTP)
+
+post-patch-PARAMIKO-off:
+ @${FIND} ${WRKSRC}/${PORTNAME}/backends -type f -depth 1 \
+ -name '*ssh_paramiko*' -delete
+
+post-patch-PEXPECT-off:
+ @${FIND} ${WRKSRC}/${PORTNAME}/backends -type f -depth 1 \
+ -name '*ssh_pexpect*' -delete
+
+post-patch-FTP-off:
@${RM} -f ${WRKSRC}/${PORTNAME}/backends/ftpbackend.py
-.endif
-.if empty(PORT_OPTIONS:MFTPS)
+
+post-patch-FTPS-off:
@${RM} -f ${WRKSRC}/${PORTNAME}/backends/ftpsbackend.py
-.endif
-.if empty(PORT_OPTIONS:MS3)
+
+post-patch-S3-off:
.for f in botobackend _boto_multi _boto_single
@${RM} -f ${WRKSRC}/${PORTNAME}/backends/${f}.py
.endfor
-.endif
-.if empty(PORT_OPTIONS:MGDOCS)
+
+post-patch-GDOCS-off:
@${RM} -f ${WRKSRC}/${PORTNAME}/backends/gdocsbackend.py
-.endif
-.if empty(PORT_OPTIONS:MCLOUDFILES)
+
+post-patch-CLOUDFILES-off:
.for f in cfbackend _cf_cloudfiles _cf_pyrax
@${RM} -f ${WRKSRC}/${PORTNAME}/backends/${f}.py
.endfor
-.else
+
+post-patch-CLOUDFILES-on:
# Make pycloudfiles the default backend for cloudfiles, as pyrax isn't in the Ports Collection yet
# Use --cf-backend=pyrax arg when running duplicity to manually select pyrax as the backend
@${REINPLACE_CMD} 's|"pyrax"|"cloudfiles"|' ${WRKSRC}/${PORTNAME}/globals.py
-.endif
-.if empty(PORT_OPTIONS:MGIO)
+
+post-patch-GIO-off:
@${RM} -f ${WRKSRC}/${PORTNAME}/backends/giobackend.py
-.endif
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/python2.7/site-packages/duplicity/_librsync.so
${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
-.endfor
+
+post-install-DOCS-on:
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|g} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>