aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/facter
diff options
context:
space:
mode:
authorromain <romain@FreeBSD.org>2018-09-27 14:47:03 +0800
committerromain <romain@FreeBSD.org>2018-09-27 14:47:03 +0800
commitdbb8acf85a4cea273e3dbd81d556617a0eb8c2d9 (patch)
tree805657a3e3d50f03da21c97e29bfbf06c2c1a38e /sysutils/facter
parenta4bcda24b39949a9ae895d0e59ccd46e378e0838 (diff)
downloadfreebsd-ports-gnome-dbb8acf85a4cea273e3dbd81d556617a0eb8c2d9.tar.gz
freebsd-ports-gnome-dbb8acf85a4cea273e3dbd81d556617a0eb8c2d9.tar.zst
freebsd-ports-gnome-dbb8acf85a4cea273e3dbd81d556617a0eb8c2d9.zip
Install the generated .gemspec file
Building the C implementation of facter also produce a .gemspec file. So far, it was not installed (probably by mistake: since nothing was using it, everything was fine). Now that we are about to add a consumer of this file as sysutils/rubygem-puppetserver-ca to the ports tree, this file must be installed. With hat: puppet
Diffstat (limited to 'sysutils/facter')
-rw-r--r--sysutils/facter/Makefile5
-rw-r--r--sysutils/facter/pkg-plist1
2 files changed, 6 insertions, 0 deletions
diff --git a/sysutils/facter/Makefile b/sysutils/facter/Makefile
index a276d4d26834..c1b8b123547a 100644
--- a/sysutils/facter/Makefile
+++ b/sysutils/facter/Makefile
@@ -2,6 +2,7 @@
PORTNAME= facter
PORTVERSION= 3.12.0
+PORTREVISION= 1
CATEGORIES?= sysutils
MASTER_SITES= https://downloads.puppetlabs.com/facter/
@@ -46,6 +47,10 @@ post-patch:
${WRKSRC}/lib/src/facts/posix/collection.cc \
${WRKSRC}/lib/src/util/config/posix/config.cc
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/ruby/gems/${RUBY_VER}/specifications
+ ${INSTALL_DATA} ${WRKSRC}/.gemspec ${STAGEDIR}${PREFIX}/lib/ruby/gems/${RUBY_VER}/specifications/${DISTNAME}.gemspec
+
test: build
cd ${WRKSRC}/lib && bundle install --path vendor
cd ${WRKSRC} && ${MAKE_CMD} test
diff --git a/sysutils/facter/pkg-plist b/sysutils/facter/pkg-plist
index 26620f30ed77..f63cbb03c9a4 100644
--- a/sysutils/facter/pkg-plist
+++ b/sysutils/facter/pkg-plist
@@ -19,6 +19,7 @@ include/facter/util/string.hpp
include/facter/version.h
lib/libfacter.so
lib/libfacter.so.%%PORTVERSION%%
+lib/ruby/gems/%%RUBY_VER%%/specifications/facter-%%PORTVERSION%%.gemspec
lib/ruby/vendor_ruby/facter.rb
man/man8/facter.8.gz
%%FACTER_JAVA%%lib/ruby/vendor_ruby/facter.jar