aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/filelight/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-08-30 07:43:48 +0800
committerkrion <krion@FreeBSD.org>2003-08-30 07:43:48 +0800
commit4fb3e3a13afea3b28f9dc470d59ce267acc9b66c (patch)
treebe2850c20f33804eed67d0d7c1333dde3b6f8be9 /sysutils/filelight/Makefile
parent22fc0450791f6adaa8794855f8a9095e21230740 (diff)
downloadfreebsd-ports-gnome-4fb3e3a13afea3b28f9dc470d59ce267acc9b66c.tar.gz
freebsd-ports-gnome-4fb3e3a13afea3b28f9dc470d59ce267acc9b66c.tar.zst
freebsd-ports-gnome-4fb3e3a13afea3b28f9dc470d59ce267acc9b66c.zip
- New port: sysutils/filelight
Filelight graphically represents a file system as a set of concentric segmented-rings, indicating where diskspace is being used. Segments expanding from the center represent files (including directories), with each segment's size being proportional to the file's size and directories having child segments. PR: 56152 Submitted by: Markus Brueffer <brueffer@phoenix-systems.de>
Diffstat (limited to 'sysutils/filelight/Makefile')
-rw-r--r--sysutils/filelight/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/sysutils/filelight/Makefile b/sysutils/filelight/Makefile
new file mode 100644
index 000000000000..668c54f17bdf
--- /dev/null
+++ b/sysutils/filelight/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: filelight
+# Date created: Fri Aug 29 21:16:39 CEST 2003
+# Whom: Markus Brueffer <brueffer@phoenix-systems.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= filelight
+PORTVERSION= 0.6.0
+CATEGORIES= sysutils kde
+MASTER_SITES= http://www.methylblue.com/filelight/
+
+MAINTAINER= brueffer@phoenix-systems.de
+COMMENT= Represent a file system as a set of concentric segmented-rings
+
+USE_KDELIBS_VER=3
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+post-patch:
+ @${CP} ${FILESDIR}/mntent* ${WRKSRC}/filelight
+ @${REINPLACE_CMD} -e 's/-O2//g; s/-pedantic //g' \
+ ${CONFIGURE_WRKSRC}/configure
+
+.include <bsd.port.mk>