aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/fvcool
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2004-10-17 11:32:08 +0800
committerlinimon <linimon@FreeBSD.org>2004-10-17 11:32:08 +0800
commit36c3a4847c2070f298951441337e0cc2b6e7a0ef (patch)
treef7332b7b1c08533cf7d1b163a6a339ece6ef38f6 /sysutils/fvcool
parent1b60d875a0a19d8922ae07869a65cb73ba60cf7b (diff)
downloadfreebsd-ports-gnome-36c3a4847c2070f298951441337e0cc2b6e7a0ef.tar.gz
freebsd-ports-gnome-36c3a4847c2070f298951441337e0cc2b6e7a0ef.tar.zst
freebsd-ports-gnome-36c3a4847c2070f298951441337e0cc2b6e7a0ef.zip
Update to 1.0.4; convert to rc.subr; assign maintainership to submitter.
PR: ports/72101 Submitted by: Matthew Seaman <m dot seaman at infracaninophile dot co dot uk>
Diffstat (limited to 'sysutils/fvcool')
-rw-r--r--sysutils/fvcool/Makefile21
-rw-r--r--sysutils/fvcool/distinfo4
-rw-r--r--sysutils/fvcool/pkg-message25
-rw-r--r--sysutils/fvcool/pkg-plist7
-rw-r--r--sysutils/fvcool/scripts/fvcool.sh48
5 files changed, 91 insertions, 14 deletions
diff --git a/sysutils/fvcool/Makefile b/sysutils/fvcool/Makefile
index bfed0ab27333..780ea2dc2ce3 100644
--- a/sysutils/fvcool/Makefile
+++ b/sysutils/fvcool/Makefile
@@ -6,30 +6,45 @@
#
PORTNAME= fvcool
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
CATEGORIES= sysutils
MASTER_SITES= http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/
DISTNAME= FVCool${PORTVERSION:S/.//g}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= m.seaman@infracaninophile.co.uk
COMMENT= VCool for FreeBSD - Cooling software for AMD Athlon/Duron CPUs
ONLY_FOR_ARCHS= i386
USE_REINPLACE= yes
GNU_CONFIGURE= yes
+USE_RC_SUBR= yes
ALL_TARGET= fvcool
PLIST_SUB+= DOCSDIR=${DOCSDIR:S,^${PREFIX}/,,}
+MSG_FILE= ${PKGDIR}/pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
-DOC_FILES= 00README.txt 00READMEj.txt 00READMEkt133.txt
+SED_SCRIPT= -e 's,%%RC_SUBR%%,${RC_SUBR},g' \
+ -e 's,%%PORTNAME%%,${PORTNAME},g' \
+ -e 's,%%PREFIX%%,${PREFIX},g'
+
+DOC_FILES= ReadMe ReadMe.jp ReadMe.tech_KT133
post-patch:
@${REINPLACE_CMD} -e 's|@CC@|& ${CFLAGS}|; \
s|-O3||g ; s| -s | |g' ${BUILD_WRKSRC}/Makefile.in
+post-build:
+ @${SED} ${SED_SCRIPT} ${SCRIPTDIR}/${PORTNAME}.sh \
+ > ${WRKDIR}/${PORTNAME}.sh
+ @${SED} ${SED_SCRIPT} ${MSG_FILE} \
+ > ${PKGMESSAGE}
+
do-install: install-doc
${INSTALL_PROGRAM} ${WRKSRC}/fvcool ${PREFIX}/sbin/fvcool
post-install:
+ @${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh \
+ ${PREFIX}/etc/rc.d/${PORTNAME}.sh
@${CAT} ${PKGMESSAGE}
install-doc:
diff --git a/sysutils/fvcool/distinfo b/sysutils/fvcool/distinfo
index 38b1b6cd6ca5..232eaeb8c67a 100644
--- a/sysutils/fvcool/distinfo
+++ b/sysutils/fvcool/distinfo
@@ -1,2 +1,2 @@
-MD5 (FVCool103.tar.gz) = d5e56d9d79ca7d642f54f94a7b8eb696
-SIZE (FVCool103.tar.gz) = 51712
+MD5 (FVCool104.tar.gz) = c42222059abd57a430d9828fe19ff6bf
+SIZE (FVCool104.tar.gz) = 54611
diff --git a/sysutils/fvcool/pkg-message b/sysutils/fvcool/pkg-message
index 1259efd0bf9e..b825562157ae 100644
--- a/sysutils/fvcool/pkg-message
+++ b/sysutils/fvcool/pkg-message
@@ -1,8 +1,21 @@
-WARNING: This software can have a negative impact on the system's
-stability, in particular while doing heavy duty work such as encoding
-music the system can freeze under certain conditions!
+===> How to enable the %%PORTNAME%% package
-Don't use this software in production or mission-critical environments!
+ If you want to invoke %%PORTNAME%% automatically on system startup,
+ add the following line to /etc/rc.conf:
+
+ fvcool_enable="YES"
+
+ See %%PREFIX%%/etc/rc.d/%%PORTNAME%%.sh for more details.
+
+===> WARNING
+
+ This software can have a negative impact on system stability. In
+ particular while doing heavy duty work such as encoding music,
+ under certain conditions the system can freeze.
+
+ Don't use this software in production or mission-critical
+ environments!
+
+ Also note that this software is supposed to be used with AMD
+ Athlon (XP) an AMD Duron processors only.
-Also note that this software is supposed to be used with AMD Athlon (XP) an
-AMD Duron processors only!
diff --git a/sysutils/fvcool/pkg-plist b/sysutils/fvcool/pkg-plist
index c9ffae33c61c..95a7a5ae299d 100644
--- a/sysutils/fvcool/pkg-plist
+++ b/sysutils/fvcool/pkg-plist
@@ -1,5 +1,6 @@
sbin/fvcool
-%%PORTDOCS%%%%DOCSDIR%%/00README.txt
-%%PORTDOCS%%%%DOCSDIR%%/00READMEj.txt
-%%PORTDOCS%%%%DOCSDIR%%/00READMEkt133.txt
+etc/rc.d/fvcool.sh
+%%PORTDOCS%%%%DOCSDIR%%/ReadMe
+%%PORTDOCS%%%%DOCSDIR%%/ReadMe.jp
+%%PORTDOCS%%%%DOCSDIR%%/ReadMe.tech_KT133
%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/sysutils/fvcool/scripts/fvcool.sh b/sysutils/fvcool/scripts/fvcool.sh
new file mode 100644
index 000000000000..2181a8187dde
--- /dev/null
+++ b/sysutils/fvcool/scripts/fvcool.sh
@@ -0,0 +1,48 @@
+#!/bin/sh
+#
+# @(#) $FreeBSD$
+
+# PROVIDE: %%PORTNAME%%
+# REQUIRE: LOGIN abi
+# BEFORE: securelevel
+# KEYWORD: FreeBSD shutdown
+
+# Add the following line to /etc/rc.conf to enable `%%PORTNAME%%':
+#
+#%%PORTNAME%%_enable="YES"
+#
+# Other rc.conf variables:
+#
+# %%PORTNAME%%_flags Set to "-v" for verbose mode.
+#
+
+. %%RC_SUBR%%
+
+name="%%PORTNAME%%"
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/sbin/%%PORTNAME%%"
+command_args="-e"
+
+# %%PORTNAME%% is a command to be run during startup and shutdown, not a
+# long running daemon process. There's no pidfile to check, and it's
+# hard to tell if %%PORTNAME%% is enabled or not -- just run '%%PORTNAME%% -e' to
+# force enable it, '%%PORTNAME%% -d' to disable.
+
+stop_cmd="stop_cmd"
+stop_cmd()
+{
+ $command -d
+}
+
+status_cmd="status_cmd"
+status_cmd()
+{
+ echo "Can't check %%PORTNAME%% status"
+}
+
+load_rc_config "$name"
+: ${%%PORTNAME%%_enable="NO"}
+: ${%%PORTNAME%%_flags=""}
+
+run_rc_command "$1"