aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/gfslicer/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-01-11 03:04:28 +0800
committerijliao <ijliao@FreeBSD.org>2002-01-11 03:04:28 +0800
commit5ddb5f9e03eb88c825d190709f7d8fc7a6f2dc39 (patch)
treee491c62f91b5b179f7b3b69729c0d53bb49cf710 /sysutils/gfslicer/Makefile
parentd51d7acfb38ffd279c246969199b4d43d7dbf1ba (diff)
downloadfreebsd-ports-gnome-5ddb5f9e03eb88c825d190709f7d8fc7a6f2dc39.tar.gz
freebsd-ports-gnome-5ddb5f9e03eb88c825d190709f7d8fc7a6f2dc39.tar.zst
freebsd-ports-gnome-5ddb5f9e03eb88c825d190709f7d8fc7a6f2dc39.zip
add gfslicer 1.5.4
gfslicer helps to slice and then deslice files which are of larger size
Diffstat (limited to 'sysutils/gfslicer/Makefile')
-rw-r--r--sysutils/gfslicer/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/sysutils/gfslicer/Makefile b/sysutils/gfslicer/Makefile
new file mode 100644
index 000000000000..a4298f9ba7a2
--- /dev/null
+++ b/sysutils/gfslicer/Makefile
@@ -0,0 +1,41 @@
+# ex:ts=8
+# Ports collection makefile for: gfslicer
+# Date created: Jan 11, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gfslicer
+PORTVERSION= 1.5.4
+CATEGORIES= sysutils
+MASTER_SITES= http://www.geocities.com/gfslicer/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext
+
+USE_X_PREFIX= yes
+USE_GTK= yes
+USE_GNOME= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_GMAKE= yes
+
+MANCOMPRESSED= yes
+MAN1= gfslicer.1
+
+post-extract:
+.for file in install-sh missing mkinstalldirs
+ @${LN} -sf ${LOCALBASE}/share/automake/${file} ${WRKSRC}
+.endfor
+ @${RM} -f ${WRKSRC}/config.cache
+
+post-patch:
+ @${PERL} -pi -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
+
+post-install:
+ @${CP} ${WRKSRC}/${MAN1}.gz ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>