aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/gnomecontrolcenter/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>1999-01-05 21:12:01 +0800
committervanilla <vanilla@FreeBSD.org>1999-01-05 21:12:01 +0800
commiteeb75e4501f46350afac7eb6c5ba5a887a880d4f (patch)
treede6ab5a98e33db2041331c6ba677a2b2981c6e38 /sysutils/gnomecontrolcenter/Makefile
parente5bc81b5ff8e909d0df98b14a7f1ab3a60397029 (diff)
downloadfreebsd-ports-gnome-eeb75e4501f46350afac7eb6c5ba5a887a880d4f.tar.gz
freebsd-ports-gnome-eeb75e4501f46350afac7eb6c5ba5a887a880d4f.tar.zst
freebsd-ports-gnome-eeb75e4501f46350afac7eb6c5ba5a887a880d4f.zip
It's gnome control center.
Diffstat (limited to 'sysutils/gnomecontrolcenter/Makefile')
-rw-r--r--sysutils/gnomecontrolcenter/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/sysutils/gnomecontrolcenter/Makefile b/sysutils/gnomecontrolcenter/Makefile
new file mode 100644
index 000000000000..c3c0d7ef38e7
--- /dev/null
+++ b/sysutils/gnomecontrolcenter/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: control-center
+# Version required: 0.99
+# Date created: 29 Dec 1998
+# Whom: Vanilla I. Shu <vanilla@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= control-center-0.99
+PKGNAME= gnomecontrolcenter-0.99
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.jimpick.com/pub/mirrors/gnome/sources/ \
+ ftp://ftp.gnome.org/pub/GNOME/sources/
+
+MAINTAINER= vanilla@FreeBSD.ORG
+
+LIB_DEPENDS= gnome.0:${PORTSDIR}/x11/gnomelibs
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --with-gnome=${X11BASE}
+CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include \
+ -I${X11BASE}/include" \
+ CXXFLAGS="${CFLAGS}" \
+ GTK_CONFIG="${X11BASE}/bin/gtk11d-config" \
+ GLIB_CONFIG="${X11BASE}/bin/glib11d-config" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
+
+post-install:
+ @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.mk>