aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/hal-info
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2008-03-24 11:52:36 +0800
committermarcus <marcus@FreeBSD.org>2008-03-24 11:52:36 +0800
commit7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3 (patch)
tree862f96db414616c771eb64412d27d795591004f0 /sysutils/hal-info
parent6c3349d5db64bb9ea320c30d23ba353e2f013754 (diff)
downloadfreebsd-ports-gnome-7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3.tar.gz
freebsd-ports-gnome-7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3.tar.zst
freebsd-ports-gnome-7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3.zip
The FreeBSD GNOME team is proud to annunce the release of GNOME 2.22.0 for
FreeBSD. The official GNOME 2.22 release notes can be found at http://library.gnome.org/misc/release-notes/2.22/ . On the FreeBSD front, this release features an updated hal port with support for video4linux devices, DRM (Direct Rendering), and better support of removable media. Work is also underway to tie webkit more closely into GNOME. As part of the GNOME 2.22 upgrade, GStreamer received a rather large upgrade as well. Be sure to consult UPDATING on the proper steps to upgrade all of your GNOME ports. This release would not have been possible without the contributions and testing efforts of the following people: Pawel Worach kan edwin Peter Ulrich Kruppa J. W. Ballantine Yasuda Keisuke Andriy Gapon
Diffstat (limited to 'sysutils/hal-info')
-rw-r--r--sysutils/hal-info/Makefile28
-rw-r--r--sysutils/hal-info/distinfo3
-rw-r--r--sysutils/hal-info/files/patch-configure83
-rw-r--r--sysutils/hal-info/pkg-descr3
-rw-r--r--sysutils/hal-info/pkg-plist44
5 files changed, 161 insertions, 0 deletions
diff --git a/sysutils/hal-info/Makefile b/sysutils/hal-info/Makefile
new file mode 100644
index 000000000000..7bcba489a709
--- /dev/null
+++ b/sysutils/hal-info/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: hal-info
+# Date Created: 25 January 2008
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/sysutils/hal-info/Makefile,v 1.3 2008/03/17 22:31:58 marcus Exp $
+#
+
+PORTNAME= hal-info
+PORTVERSION= 20080317
+CATEGORIES= sysutils
+MASTER_SITES= http://hal.freedesktop.org/releases/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Additional FDI files to further classify HAL devices
+
+LIB_PC_DEPENDS= hal.pc:${PORTSDIR}/sysutils/hal
+
+BUILD_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+RUN_DEPENDS+= ${LIB_PC_DEPENDS:C|^|${LOCALBASE}/libdata/pkgconfig/|g}
+
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnometarget
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/sysutils/hal-info/distinfo b/sysutils/hal-info/distinfo
new file mode 100644
index 000000000000..a058eaa17f47
--- /dev/null
+++ b/sysutils/hal-info/distinfo
@@ -0,0 +1,3 @@
+MD5 (hal-info-20080317.tar.gz) = 4cde7ff94f660879c44da17eb525edfd
+SHA256 (hal-info-20080317.tar.gz) = b6e3c45cb7929ed66eb154f28b7f89b6e36a9a6645a37f583f8b7c7e29322405
+SIZE (hal-info-20080317.tar.gz) = 184704
diff --git a/sysutils/hal-info/files/patch-configure b/sysutils/hal-info/files/patch-configure
new file mode 100644
index 000000000000..0a70073241be
--- /dev/null
+++ b/sysutils/hal-info/files/patch-configure
@@ -0,0 +1,83 @@
+--- configure.orig 2008-03-17 18:27:34.000000000 -0400
++++ configure 2008-03-17 18:28:11.000000000 -0400
+@@ -3436,7 +3436,7 @@ else
+ enable_recall=yes
+ fi
+
+- if test x$enable_recall == xyes; then
++ if test x$enable_recall = xyes; then
+ BUILD_RECALL_TRUE=
+ BUILD_RECALL_FALSE='#'
+ else
+@@ -3452,7 +3452,7 @@ else
+ enable_video=yes
+ fi
+
+- if test x$enable_video == xyes; then
++ if test x$enable_video = xyes; then
+ BUILD_VIDEO_TRUE=
+ BUILD_VIDEO_FALSE='#'
+ else
+@@ -3468,7 +3468,7 @@ else
+ enable_keymaps=yes
+ fi
+
+- if test x$enable_keymaps == xyes; then
++ if test x$enable_keymaps = xyes; then
+ BUILD_KEYMAPS_TRUE=
+ BUILD_KEYMAPS_FALSE='#'
+ else
+@@ -3484,7 +3484,7 @@ else
+ enable_killswitch_dell_wlan=yes
+ fi
+
+- if test x$enable_killswitch_dell_wlan == xyes; then
++ if test x$enable_killswitch_dell_wlan = xyes; then
+ BUILD_KILLSWITCH_DELL_WLAN_TRUE=
+ BUILD_KILLSWITCH_DELL_WLAN_FALSE='#'
+ else
+@@ -3500,7 +3500,7 @@ else
+ enable_killswitch_dell_bluetooth=yes
+ fi
+
+- if test x$enable_killswitch_dell_bluetooth == xyes; then
++ if test x$enable_killswitch_dell_bluetooth = xyes; then
+ BUILD_KILLSWITCH_DELL_BLUETOOTH_TRUE=
+ BUILD_KILLSWITCH_DELL_BLUETOOTH_FALSE='#'
+ else
+@@ -3516,7 +3516,7 @@ else
+ enable_killswitch_dell_wwan=yes
+ fi
+
+- if test x$enable_killswitch_dell_wwan == xyes; then
++ if test x$enable_killswitch_dell_wwan = xyes; then
+ BUILD_KILLSWITCH_DELL_WWAN_TRUE=
+ BUILD_KILLSWITCH_DELL_WWAN_FALSE='#'
+ else
+@@ -3532,7 +3532,7 @@ else
+ enable_killswitch_sony_bluetooth=yes
+ fi
+
+- if test x$enable_killswitch_sony_bluetooth == xyes; then
++ if test x$enable_killswitch_sony_bluetooth = xyes; then
+ BUILD_KILLSWITCH_SONY_BLUETOOTH_TRUE=
+ BUILD_KILLSWITCH_SONY_BLUETOOTH_FALSE='#'
+ else
+@@ -3548,7 +3548,7 @@ else
+ enable_killswitch_thinkpad_bluetooth=yes
+ fi
+
+- if test x$enable_killswitch_thinkpad_bluetooth == xyes; then
++ if test x$enable_killswitch_thinkpad_bluetooth = xyes; then
+ BUILD_KILLSWITCH_THINKPAD_BLUETOOTH_TRUE=
+ BUILD_KILLSWITCH_THINKPAD_BLUETOOTH_FALSE='#'
+ else
+@@ -3564,7 +3564,7 @@ else
+ enable_killswitch_ipw_wlan=yes
+ fi
+
+- if test x$enable_killswitch_ipw_wlan == xyes; then
++ if test x$enable_killswitch_ipw_wlan = xyes; then
+ BUILD_KILLSWITCH_IPW_WLAN_TRUE=
+ BUILD_KILLSWITCH_IPW_WLAN_FALSE='#'
+ else
diff --git a/sysutils/hal-info/pkg-descr b/sysutils/hal-info/pkg-descr
new file mode 100644
index 000000000000..dd42292fcc44
--- /dev/null
+++ b/sysutils/hal-info/pkg-descr
@@ -0,0 +1,3 @@
+hal-info contains device information for HAL.
+
+WWW: http://www.freedesktop.org/Software/hal
diff --git a/sysutils/hal-info/pkg-plist b/sysutils/hal-info/pkg-plist
new file mode 100644
index 000000000000..b48a5514f0db
--- /dev/null
+++ b/sysutils/hal-info/pkg-plist
@@ -0,0 +1,44 @@
+share/hal/fdi/information/10freedesktop/10-camera-ptp.fdi
+share/hal/fdi/information/10freedesktop/10-cd-dvd-burner.fdi
+share/hal/fdi/information/10freedesktop/10-dell-rfkill-switch-bluetooth.fdi
+share/hal/fdi/information/10freedesktop/10-dell-rfkill-switch-wlan.fdi
+share/hal/fdi/information/10freedesktop/10-dell-rfkill-switch-wwan.fdi
+share/hal/fdi/information/10freedesktop/10-ipw-rfkill-switch.fdi
+share/hal/fdi/information/10freedesktop/10-laptop-panel-hardware.fdi
+share/hal/fdi/information/10freedesktop/10-modem.fdi
+share/hal/fdi/information/10freedesktop/10-recall-battery-dell.fdi
+share/hal/fdi/information/10freedesktop/10-recall-battery-fujitsu.fdi
+share/hal/fdi/information/10freedesktop/10-recall-battery-gateway.fdi
+share/hal/fdi/information/10freedesktop/10-recall-battery-ibm.fdi
+share/hal/fdi/information/10freedesktop/10-recall-battery-lenovo.fdi
+share/hal/fdi/information/10freedesktop/10-recall-battery-toshiba.fdi
+share/hal/fdi/information/10freedesktop/10-sony-bluetooth-switch.fdi
+share/hal/fdi/information/10freedesktop/10-thinkpad-rfkill-switch-bluetooth.fdi
+share/hal/fdi/information/10freedesktop/10-usb-card-readers.fdi
+share/hal/fdi/information/10freedesktop/10-usb-music-players.fdi
+share/hal/fdi/information/10freedesktop/10-usb-pda.fdi
+share/hal/fdi/information/10freedesktop/10-usb-zip-drives.fdi
+share/hal/fdi/information/10freedesktop/10-usbcsr-mice.fdi
+share/hal/fdi/information/10freedesktop/20-video-quirk-pm-acer.fdi
+share/hal/fdi/information/10freedesktop/20-video-quirk-pm-apple.fdi
+share/hal/fdi/information/10freedesktop/20-video-quirk-pm-asus.fdi
+share/hal/fdi/information/10freedesktop/20-video-quirk-pm-dell.fdi
+share/hal/fdi/information/10freedesktop/20-video-quirk-pm-fujitsu.fdi
+share/hal/fdi/information/10freedesktop/20-video-quirk-pm-hp.fdi
+share/hal/fdi/information/10freedesktop/20-video-quirk-pm-ibm.fdi
+share/hal/fdi/information/10freedesktop/20-video-quirk-pm-lenovo.fdi
+share/hal/fdi/information/10freedesktop/20-video-quirk-pm-misc.fdi
+share/hal/fdi/information/10freedesktop/20-video-quirk-pm-samsung.fdi
+share/hal/fdi/information/10freedesktop/20-video-quirk-pm-sony.fdi
+share/hal/fdi/information/10freedesktop/20-video-quirk-pm-toshiba.fdi
+share/hal/fdi/information/10freedesktop/30-keymap-acer.fdi
+share/hal/fdi/information/10freedesktop/30-keymap-compaq.fdi
+share/hal/fdi/information/10freedesktop/30-keymap-dell.fdi
+share/hal/fdi/information/10freedesktop/30-keymap-hp.fdi
+share/hal/fdi/information/10freedesktop/30-keymap-lenovo.fdi
+share/hal/fdi/information/10freedesktop/30-keymap-misc.fdi
+share/hal/fdi/information/10freedesktop/30-keymap-module-asus-laptop.fdi
+share/hal/fdi/information/10freedesktop/30-keymap-module-sony-laptop.fdi
+share/hal/fdi/information/10freedesktop/30-keymap-module-thinkpad-acpi.fdi
+share/hal/fdi/preprobe/10osvendor/10-ide-drives.fdi
+share/hal/fdi/preprobe/10osvendor/20-broken-usb-sticks.fdi