aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/hal/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2008-04-21 14:38:07 +0800
committermarcus <marcus@FreeBSD.org>2008-04-21 14:38:07 +0800
commit8bf3e3e1268c7b980b6edd7f30bf75b3d09a5051 (patch)
treecf09189c94c1fa097ec1423a52cb08f51b89283a /sysutils/hal/Makefile
parenta3b6da0c61d2578dd56705e1ff2dad3ee4e505cc (diff)
downloadfreebsd-ports-gnome-8bf3e3e1268c7b980b6edd7f30bf75b3d09a5051.tar.gz
freebsd-ports-gnome-8bf3e3e1268c7b980b6edd7f30bf75b3d09a5051.tar.zst
freebsd-ports-gnome-8bf3e3e1268c7b980b6edd7f30bf75b3d09a5051.zip
Fix the pkg-install script to create the haldaemon user/group even when
PACKAGE_BUILDING is defined. This is consistent with how other ports do things, and it fixes hal's package installation through sysinstall.
Diffstat (limited to 'sysutils/hal/Makefile')
-rw-r--r--sysutils/hal/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/sysutils/hal/Makefile b/sysutils/hal/Makefile
index d139a0f19891..75c477abc6cd 100644
--- a/sysutils/hal/Makefile
+++ b/sysutils/hal/Makefile
@@ -8,7 +8,7 @@
PORTNAME= hal
DISTVERSION= 0.5.11rc2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= sysutils
MASTER_SITES= http://hal.freedesktop.org/releases/
@@ -105,11 +105,13 @@ post-install:
${MKDIR} ${PREFIX}/share/hal/fdi/policy/10osvendor
${INSTALL_DATA} ${FILESDIR}/10-mouse-sysmouse.fdi \
${PREFIX}/share/hal/fdi/policy/10osvendor
- @${SETENV} PKG_PREFIX=${PREFIX} PACKAGE_BUILDING=${PACKAGE_BUILDING} \
+.if !defined(PACKAGE_BUILDING)
+ @${SETENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.if !defined(PACKAGE_BUILDING) && defined(NEEDS_MEDIA)
+.if defined(NEEDS_MEDIA)
${MKDIR} /media
.endif
+.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/hald/freebsd/README \