aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/hal
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-03-31 10:19:58 +0800
committermarcus <marcus@FreeBSD.org>2009-03-31 10:19:58 +0800
commit3e1d67ec1e981c71f7e9d2666e2c6f9824b9f3e5 (patch)
tree59fc392e7e31d8131ab11ea3acae7823f37b728a /sysutils/hal
parenta84c1960edd92e1299ab598ffb67b976fd986054 (diff)
downloadfreebsd-ports-gnome-3e1d67ec1e981c71f7e9d2666e2c6f9824b9f3e5.tar.gz
freebsd-ports-gnome-3e1d67ec1e981c71f7e9d2666e2c6f9824b9f3e5.tar.zst
freebsd-ports-gnome-3e1d67ec1e981c71f7e9d2666e2c6f9824b9f3e5.zip
One more fix for hal and PolicyKit. Apparently haldaemon requires
org.freedesktop.policykit.read privilege to read the PK config. It's great they document this so well. This, plus the last PK fix should fix the various mounting problems some people have been seeing.
Diffstat (limited to 'sysutils/hal')
-rw-r--r--sysutils/hal/Makefile2
-rw-r--r--sysutils/hal/files/pkg-deinstall.in5
-rw-r--r--sysutils/hal/files/pkg-install.in2
3 files changed, 8 insertions, 1 deletions
diff --git a/sysutils/hal/Makefile b/sysutils/hal/Makefile
index f642ab27210d..4baa4b8fa56f 100644
--- a/sysutils/hal/Makefile
+++ b/sysutils/hal/Makefile
@@ -8,7 +8,7 @@
PORTNAME= hal
DISTVERSION= 0.5.11
-PORTREVISION= 21
+PORTREVISION= 22
CATEGORIES= sysutils
MASTER_SITES= http://hal.freedesktop.org/releases/
diff --git a/sysutils/hal/files/pkg-deinstall.in b/sysutils/hal/files/pkg-deinstall.in
index 96f8e9f91977..4650d60fe08b 100644
--- a/sysutils/hal/files/pkg-deinstall.in
+++ b/sysutils/hal/files/pkg-deinstall.in
@@ -2,6 +2,11 @@
[ "$2" != DEINSTALL ] && exit 0
+USER=haldaemon
+
+%%LOCALBASE%%/bin/polkit-auth --user ${USER} --revoke \
+ org.freedesktop.policykit.read
+
for pair in %%RC_FILES%%; do
file=`echo $pair | cut -f 1 -d :`
destdir=`echo $pair | cut -f 2 -d :`
diff --git a/sysutils/hal/files/pkg-install.in b/sysutils/hal/files/pkg-install.in
index 0935c06e157a..59505fc30505 100644
--- a/sysutils/hal/files/pkg-install.in
+++ b/sysutils/hal/files/pkg-install.in
@@ -35,6 +35,8 @@ POST-INSTALL)
/usr/bin/install -d -o ${USER} -g ${GROUP} /var/run/hald
/usr/bin/install -d -o ${USER} -g ${GROUP} /var/cache/hald
/usr/bin/install -d -o ${USER} -g ${GROUP} /var/lib/hal
+ %%LOCALBASE%%/bin/polkit-auth --user ${USER} --grant \
+ org.freedesktop.policykit.read
for pair in %%RC_FILES%%; do
file=`echo $pair | cut -f 1 -d :`