aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/hal
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2011-01-10 01:30:01 +0800
committermarcus <marcus@FreeBSD.org>2011-01-10 01:30:01 +0800
commit4e85fa0f4f31ca3317fed2c58ae0195545f9ea80 (patch)
tree810b3704d3dab928f308abc81b22b2fdf4b92737 /sysutils/hal
parent0eec26725ed001b63c0b5eeae677fd7d7e253455 (diff)
downloadfreebsd-ports-gnome-4e85fa0f4f31ca3317fed2c58ae0195545f9ea80.tar.gz
freebsd-ports-gnome-4e85fa0f4f31ca3317fed2c58ae0195545f9ea80.tar.zst
freebsd-ports-gnome-4e85fa0f4f31ca3317fed2c58ae0195545f9ea80.zip
Adjust the code to parse the USB devd notification to be a bit broader.
This ensures that the USB cdev notifications are not passed to the storage layer thus muting the USB device attach messages. Submitted by: hps
Diffstat (limited to 'sysutils/hal')
-rw-r--r--sysutils/hal/Makefile2
-rw-r--r--sysutils/hal/files/patch-hald_freebsd_hf-usb2.c4
2 files changed, 3 insertions, 3 deletions
diff --git a/sysutils/hal/Makefile b/sysutils/hal/Makefile
index c7cb99d21002..b7e556445346 100644
--- a/sysutils/hal/Makefile
+++ b/sysutils/hal/Makefile
@@ -8,7 +8,7 @@
PORTNAME= hal
DISTVERSION= 0.5.14
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= sysutils
MASTER_SITES= http://hal.freedesktop.org/releases/
diff --git a/sysutils/hal/files/patch-hald_freebsd_hf-usb2.c b/sysutils/hal/files/patch-hald_freebsd_hf-usb2.c
index af288291db4f..5e29b827b14c 100644
--- a/sysutils/hal/files/patch-hald_freebsd_hf-usb2.c
+++ b/sysutils/hal/files/patch-hald_freebsd_hf-usb2.c
@@ -133,8 +133,8 @@
+ (strcmp(type, "CREATE") && strcmp(type, "DESTROY")))
+ return FALSE;
+
-+ if (! strncmp(data, "cdev=ugen", strlen("cdev=ugen")) ||
-+ ! strncmp(data, "cdev=usb", strlen("cdev=usb")))
++ if (strstr(data, "cdev=ugen") != NULL ||
++ strstr(data, "cdev=usb") != NULL)
+ return TRUE;
+
+ return FALSE;