aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/hal
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2014-02-06 15:53:43 +0800
committerkwm <kwm@FreeBSD.org>2014-02-06 15:53:43 +0800
commit7fcbcb30f7aeca1919b1f3baf723047b9331b5c6 (patch)
tree8651c9f52c311b600ce2f2911664458fee7a3b31 /sysutils/hal
parentf783068bee3b680e2eb1fe404d817075e2fa6666 (diff)
downloadfreebsd-ports-gnome-7fcbcb30f7aeca1919b1f3baf723047b9331b5c6.tar.gz
freebsd-ports-gnome-7fcbcb30f7aeca1919b1f3baf723047b9331b5c6.tar.zst
freebsd-ports-gnome-7fcbcb30f7aeca1919b1f3baf723047b9331b5c6.zip
Switch to USES=libtool, stagify, use option helpers.
Fix shebang of a number of script, which need bash to run. Ignore the wsp (Apple trackpad) driver [1] Submitted by: Hans Selasky [1]
Diffstat (limited to 'sysutils/hal')
-rw-r--r--sysutils/hal/Makefile47
-rw-r--r--sysutils/hal/files/patch-hald_freebsd_hf-usb2.c6
-rw-r--r--sysutils/hal/pkg-plist14
3 files changed, 34 insertions, 33 deletions
diff --git a/sysutils/hal/Makefile b/sysutils/hal/Makefile
index 59a6aedb959e..cd818377139c 100644
--- a/sysutils/hal/Makefile
+++ b/sysutils/hal/Makefile
@@ -4,7 +4,7 @@
PORTNAME= hal
DISTVERSION= 0.5.14
-PORTREVISION= 22
+PORTREVISION= 23
CATEGORIES= sysutils
MASTER_SITES= http://hal.freedesktop.org/releases/
@@ -16,11 +16,12 @@ BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:${PORTSDIR}/multimedia/v4l
LIB_DEPENDS= libpolkit.so.2:${PORTSDIR}/sysutils/policykit \
libvolume_id.so:${PORTSDIR}/devel/libvolume_id \
libck-connector.so:${PORTSDIR}/sysutils/consolekit
-RUN_DEPENDS= ${LOCALBASE}/share/pciids/pci.ids:${PORTSDIR}/misc/pciids
+RUN_DEPENDS= ${LOCALBASE}/share/pciids/pci.ids:${PORTSDIR}/misc/pciids \
+ bash:${PORTSDIR}/shells/bash
-USES= pathfix gettext gmake pkgconfig
-USE_GNOME= intlhack ltverhack
-USE_AUTOTOOLS= libtool
+USES= pathfix gettext gmake libtool pkgconfig shebangfix
+USE_GNOME= intlhack
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_PYTHON= yes
CONFIGURE_ARGS= --disable-gtk-doc \
@@ -43,6 +44,7 @@ CONFIGURE_ARGS= --disable-gtk-doc \
CONFIGURE_ENV= GTKDOC="false"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+SHEBANG_FILES= tools/hal-*
#HALVERSION= 0.5.10
#SNAPVERSION= 20080218
@@ -61,21 +63,11 @@ PLIST_FILES= ${PRIV_FILES:S|^|%%DATADIR%%/dist/|}
SUB_FILES= pkg-install pkg-deinstall
SUB_LIST= RC_FILES="${RC_FILES}"
-MAN1= hal-disable-polling.1 hal-find-by-capability.1 \
- hal-find-by-property.1 hal-get-property.1 \
- hal-is-caller-locked-out.1 hal-is-caller-privileged.1 \
- hal-lock.1 hal-set-property.1 lshal.1
-MAN8= hald.8
+INSTALL_TARGET= install-strip
OPTIONS_DEFINE= FIXED_MOUNTPOINTS
FIXED_MOUNTPOINTS_DESC= use fixed mountpoints
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MFIXED_MOUNTPOINTS}
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-tools_hal-storage-mount.c
-.endif
+FIXED_MOUNTPOINTS_EXTRA_PATCHES= ${FILESDIR}/extra-patch-tools_hal-storage-mount.c
.include <bsd.port.pre.mk>
@@ -102,23 +94,20 @@ post-patch:
< ${FILESDIR}/README.fuse > ${WRKDIR}/README.fuse
post-install:
- ${MKDIR} ${DATADIR}/dist
- ${INSTALL_DATA} ${WRKSRC}/hal.conf ${DATADIR}/dist
- ${MKDIR} ${PREFIX}/share/hal/fdi/policy/10osvendor
+ @${MKDIR} ${STAGEDIR}${DATADIR}/dist
+ ${INSTALL_DATA} ${WRKSRC}/hal.conf ${STAGEDIR}${DATADIR}/dist
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/hal/fdi/policy/10osvendor
${INSTALL_DATA} ${FILESDIR}/10-mouse-sysmouse.fdi \
- ${PREFIX}/share/hal/fdi/policy/10osvendor
+ ${STAGEDIR}${PREFIX}/share/hal/fdi/policy/10osvendor
${INSTALL_SCRIPT} ${FILESDIR}/mount-fuse \
- ${PREFIX}/share/hal/mount-fuse
-.if !defined(PACKAGE_BUILDING)
- @${SETENV} PKG_PREFIX=${PREFIX} \
- ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.endif
+ ${STAGEDIR}${PREFIX}/share/hal/mount-fuse
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/hald/freebsd/README \
- ${DOCSDIR}/README.freebsd
+ ${STAGEDIR}${DOCSDIR}/README.freebsd
${INSTALL_DATA} ${WRKDIR}/README.fuse \
- ${DOCSDIR}/README.fuse
+ ${STAGEDIR}${DOCSDIR}/README.fuse
.endif
+ @${MKDIR} ${STAGEDIR}/var/lib/hal
.include <bsd.port.post.mk>
diff --git a/sysutils/hal/files/patch-hald_freebsd_hf-usb2.c b/sysutils/hal/files/patch-hald_freebsd_hf-usb2.c
index daa7b1d032ba..898530343146 100644
--- a/sysutils/hal/files/patch-hald_freebsd_hf-usb2.c
+++ b/sysutils/hal/files/patch-hald_freebsd_hf-usb2.c
@@ -1,5 +1,5 @@
---- ./hald/freebsd/hf-usb2.c.orig 2009-08-24 14:42:29.000000000 +0200
-+++ ./hald/freebsd/hf-usb2.c 2013-10-23 13:10:36.639758556 +0200
+--- hald/freebsd/hf-usb2.c.orig 2009-08-24 14:42:29.000000000 +0200
++++ hald/freebsd/hf-usb2.c 2014-02-06 08:22:11.000000000 +0100
@@ -22,7 +22,7 @@
**************************************************************************/
@@ -61,7 +61,7 @@
+ if (driver) {
+ if (!strcmp(driver, "ukbd"))
+ hf_device_set_input(device, "keyboard", "keys", NULL);
-+ else if (!strcmp(driver, "ums") || !strcmp(driver, "atp")) {
++ else if (!strcmp(driver, "ums") || !strcmp(driver, "atp") || !strcmp(driver, "wsp")) {
+ hf_device_set_input(device, "mouse", NULL, devname);
+ hf_runner_run_sync(device, 0, "hald-probe-mouse", NULL);
+ } else if (!strcmp(driver, "uhid")) {
diff --git a/sysutils/hal/pkg-plist b/sysutils/hal/pkg-plist
index 18696cefe73b..61708a26e7cc 100644
--- a/sysutils/hal/pkg-plist
+++ b/sysutils/hal/pkg-plist
@@ -18,10 +18,12 @@ lib/libhal-storage.a
lib/libhal-storage.la
lib/libhal-storage.so
lib/libhal-storage.so.1
+lib/libhal-storage.so.1.0.0
lib/libhal.a
lib/libhal.la
lib/libhal.so
lib/libhal.so.1
+lib/libhal.so.1.0.0
libdata/pkgconfig/hal-storage.pc
libdata/pkgconfig/hal.pc
libexec/hal-storage-cleanup-all-mountpoints
@@ -69,6 +71,16 @@ libexec/hald-probe-storage
%%USB2%%libexec/hald-probe-video4linux
libexec/hald-probe-volume
libexec/hald-runner
+man/man1/hal-disable-polling.1.gz
+man/man1/hal-find-by-capability.1.gz
+man/man1/hal-find-by-property.1.gz
+man/man1/hal-get-property.1.gz
+man/man1/hal-is-caller-locked-out.1.gz
+man/man1/hal-is-caller-privileged.1.gz
+man/man1/hal-lock.1.gz
+man/man1/hal-set-property.1.gz
+man/man1/lshal.1.gz
+man/man8/hald.8.gz
sbin/hald
share/PolicyKit/policy/org.freedesktop.hal.dockstation.policy
share/PolicyKit/policy/org.freedesktop.hal.killswitch.policy
@@ -111,7 +123,7 @@ share/PolicyKit/policy/org.freedesktop.hal.wol.policy
@dirrm %%DATADIR%%/fdi
@dirrm %%DATADIR%%/dist
@dirrm %%DATADIR%%
-@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry share/PolicyKit/policy
@dirrmtry share/PolicyKit
@dirrm libexec/hal/scripts/freebsd