aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/hal
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2008-04-14 07:38:02 +0800
committermarcus <marcus@FreeBSD.org>2008-04-14 07:38:02 +0800
commitb12468d0f25f9b9c7d85e607eb508c2390fa5338 (patch)
tree031ff009375943314ee802712fe6f949b17e65b9 /sysutils/hal
parentd5ecff0cd60cf2c1b08de5bd9118be9977e4f8af (diff)
downloadfreebsd-ports-gnome-b12468d0f25f9b9c7d85e607eb508c2390fa5338.tar.gz
freebsd-ports-gnome-b12468d0f25f9b9c7d85e607eb508c2390fa5338.tar.zst
freebsd-ports-gnome-b12468d0f25f9b9c7d85e607eb508c2390fa5338.zip
* Do not probe disc media unless the media is known to contain data
* Be less conservation about which device nodes are mountable volumes These patches were tested together by mezz, and individually by Andriy Gapon and Andreas Wetzel respectively.
Diffstat (limited to 'sysutils/hal')
-rw-r--r--sysutils/hal/Makefile2
-rw-r--r--sysutils/hal/files/patch-hald_freebsd_probing_probe-volume.c12
-rw-r--r--sysutils/hal/files/patch-hald_hf-storage.c18
3 files changed, 31 insertions, 1 deletions
diff --git a/sysutils/hal/Makefile b/sysutils/hal/Makefile
index be5b10ef7096..d139a0f19891 100644
--- a/sysutils/hal/Makefile
+++ b/sysutils/hal/Makefile
@@ -8,7 +8,7 @@
PORTNAME= hal
DISTVERSION= 0.5.11rc2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= sysutils
MASTER_SITES= http://hal.freedesktop.org/releases/
diff --git a/sysutils/hal/files/patch-hald_freebsd_probing_probe-volume.c b/sysutils/hal/files/patch-hald_freebsd_probing_probe-volume.c
new file mode 100644
index 000000000000..b9dc099e63b3
--- /dev/null
+++ b/sysutils/hal/files/patch-hald_freebsd_probing_probe-volume.c
@@ -0,0 +1,12 @@
+--- hald/freebsd/probing/probe-volume.c.orig 2008-04-07 00:41:22.000000000 -0400
++++ hald/freebsd/probing/probe-volume.c 2008-04-07 00:43:32.000000000 -0400
+@@ -502,7 +502,8 @@ main (int argc, char **argv)
+ hfp_cdrom_free(cdrom);
+ }
+
+- if (has_data)
++ if (has_data && vid && (! strcmp(vid->type, "iso9660") ||
++ ! strcmp(vid->type, "udf")))
+ hf_probe_volume_advanced_disc_detect(fd);
+ }
+ else
diff --git a/sysutils/hal/files/patch-hald_hf-storage.c b/sysutils/hal/files/patch-hald_hf-storage.c
new file mode 100644
index 000000000000..7f504c6c9a9e
--- /dev/null
+++ b/sysutils/hal/files/patch-hald_hf-storage.c
@@ -0,0 +1,18 @@
+--- hald/freebsd/hf-storage.c.orig 2008-04-07 00:40:06.000000000 -0400
++++ hald/freebsd/hf-storage.c 2008-04-07 00:40:37.000000000 -0400
+@@ -117,6 +117,7 @@ hf_storage_geom_has_partitions (const Ge
+ if (g_node_n_children(node) > 0)
+ return TRUE;
+
++ /*
+ if (hf_storage_class_is_partitionable(geom_obj->class) &&
+ g_node_next_sibling(node) != NULL)
+ {
+@@ -135,6 +136,7 @@ hf_storage_geom_has_partitions (const Ge
+ return TRUE;
+ }
+ }
++ */
+
+ return FALSE;
+ }