aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/hidesvn/Makefile
diff options
context:
space:
mode:
authored <ed@FreeBSD.org>2009-03-07 03:43:59 +0800
committered <ed@FreeBSD.org>2009-03-07 03:43:59 +0800
commitaedb03ba8ead80722b1a87b98e9cf62eef9b17a8 (patch)
tree41ab54cbccbb641f1d8c1a1f56a05d83c20fc4ce /sysutils/hidesvn/Makefile
parent18c7b44c4e2814b9a8055ebcde0db5be65545e6e (diff)
downloadfreebsd-ports-gnome-aedb03ba8ead80722b1a87b98e9cf62eef9b17a8.tar.gz
freebsd-ports-gnome-aedb03ba8ead80722b1a87b98e9cf62eef9b17a8.tar.zst
freebsd-ports-gnome-aedb03ba8ead80722b1a87b98e9cf62eef9b17a8.zip
Add new port: hidesvn.
Hidesvn is a small script that starts new processes with a library preloaded that hides .svn directories from readdir(). This is very useful when grepping the FreeBSD source tree. Reviewed by: garga
Diffstat (limited to 'sysutils/hidesvn/Makefile')
-rw-r--r--sysutils/hidesvn/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/sysutils/hidesvn/Makefile b/sysutils/hidesvn/Makefile
new file mode 100644
index 000000000000..98e93885631d
--- /dev/null
+++ b/sysutils/hidesvn/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: hidesvn
+# Date created: 6 March 2009
+# Whom: Ed Schouten <ed@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hidesvn
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= http://80386.nl/projects/${PORTNAME}/distfiles/
+
+MAINTAINER= ed@FreeBSD.org
+COMMENT= Utility that uses LD_PRELOAD to hide .svn directories
+
+MAKEFILE= BSDmakefile
+
+PLIST_FILES= bin/${PORTNAME} lib/lib${PORTNAME}.so
+MAN1= ${PORTNAME}.1
+
+USE_LDCONFIG= yes
+
+post-patch:
+ ${REINPLACE_CMD} 's|/usr/local|${PREFIX}|' ${WRKSRC}/${PORTNAME}.sh
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/lib${PORTNAME}.so ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>