aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/installwatch
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-03-12 22:16:27 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-03-12 22:16:27 +0800
commitb3738f9005d3da5440b8b72b18ad847461dd7af0 (patch)
treef0bb53486aa2489efbd606dd72b3b76f9e0c01e5 /sysutils/installwatch
parente0080493ed3accca9d2042edecc590acfda7f950 (diff)
downloadfreebsd-ports-gnome-b3738f9005d3da5440b8b72b18ad847461dd7af0.tar.gz
freebsd-ports-gnome-b3738f9005d3da5440b8b72b18ad847461dd7af0.tar.zst
freebsd-ports-gnome-b3738f9005d3da5440b8b72b18ad847461dd7af0.zip
- Clarify LICENSE
- Don't install unneeded docfile - Silence stripping - Switch to options helpers - Regenerate patches with `make makepatch`
Diffstat (limited to 'sysutils/installwatch')
-rw-r--r--sysutils/installwatch/Makefile9
-rw-r--r--sysutils/installwatch/files/patch-Makefile8
-rw-r--r--sysutils/installwatch/files/patch-installwatch.c4
3 files changed, 12 insertions, 9 deletions
diff --git a/sysutils/installwatch/Makefile b/sysutils/installwatch/Makefile
index 512a5a865eea..1c7d54ce0325 100644
--- a/sysutils/installwatch/Makefile
+++ b/sysutils/installwatch/Makefile
@@ -10,17 +10,20 @@ MASTER_SITES= http://asic-linux.com.mx/~izto/checkinstall/files/source/
MAINTAINER= ports@FreeBSD.org
COMMENT= File creation/modification logger
-LICENSE= GPLv2
+LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
USE_LDCONFIG= yes
PLIST_FILES= bin/installwatch lib/installwatch.so
-PORTDOCS= BUGS CHANGELOG INSTALL README TODO
+PORTDOCS= BUGS CHANGELOG README TODO
+
OPTIONS_DEFINE= DOCS
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/installwatch.so
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/installwatch.so
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
diff --git a/sysutils/installwatch/files/patch-Makefile b/sysutils/installwatch/files/patch-Makefile
index e6a486f37bef..7b4ac3298d62 100644
--- a/sysutils/installwatch/files/patch-Makefile
+++ b/sysutils/installwatch/files/patch-Makefile
@@ -1,5 +1,5 @@
---- ./Makefile.orig 2001-12-22 21:55:11.000000000 -0200
-+++ ./Makefile 2014-02-22 22:45:43.000000000 -0300
+--- Makefile.orig 2001-12-22 23:55:11 UTC
++++ Makefile
@@ -4,7 +4,6 @@
# Well, the only configurable part is the following variable.
# Make sure the directory you specify exists.
@@ -8,7 +8,7 @@
# End of configurable part
-@@ -16,19 +15,19 @@
+@@ -16,19 +15,19 @@ LIBDIR=$(PREFIX)/lib
all: installwatch.so
installwatch.so: installwatch.o
@@ -33,7 +33,7 @@
uninstall:
rm $(LIBDIR)/installwatch.so
-@@ -41,7 +40,7 @@
+@@ -41,7 +40,7 @@ tarball: clean
tar -czvC .. -f ../installwatch-$(VERSION).tar.gz installwatch-$(VERSION)
test: install
diff --git a/sysutils/installwatch/files/patch-installwatch.c b/sysutils/installwatch/files/patch-installwatch.c
index 9f8aa500dc05..8e9af81d0045 100644
--- a/sysutils/installwatch/files/patch-installwatch.c
+++ b/sysutils/installwatch/files/patch-installwatch.c
@@ -1,6 +1,6 @@
---- installwatch.c.orig
+--- installwatch.c.orig 2001-12-22 23:55:11 UTC
+++ installwatch.c
-@@ -574,7 +574,7 @@
+@@ -574,7 +574,7 @@ int open(const char *pathname, int flags
REFCOUNT;
va_start(ap, flags);