aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/lineak-xosdplugin
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-07-06 00:53:05 +0800
committertijl <tijl@FreeBSD.org>2014-07-06 00:53:05 +0800
commit00b2cb27b072b6f9d976eac8ec76fd6531f2d25c (patch)
tree75a61fbd1df3ecd54e752af85741aa520e0ae903 /sysutils/lineak-xosdplugin
parentff490bf8cc6e286756b5204c0656c6d16547009c (diff)
downloadfreebsd-ports-gnome-00b2cb27b072b6f9d976eac8ec76fd6531f2d25c.tar.gz
freebsd-ports-gnome-00b2cb27b072b6f9d976eac8ec76fd6531f2d25c.tar.zst
freebsd-ports-gnome-00b2cb27b072b6f9d976eac8ec76fd6531f2d25c.zip
- Convert to USES=libtool
- Add kde_cv_prog_cxx_fno_check_new=no to CONFIGURE_ARGS because -fno-check-new is not supported by Clang and that causes the -fPIC configure test to fail.
Diffstat (limited to 'sysutils/lineak-xosdplugin')
-rw-r--r--sysutils/lineak-xosdplugin/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/sysutils/lineak-xosdplugin/Makefile b/sysutils/lineak-xosdplugin/Makefile
index b6dd6cb04c84..8c987d059c84 100644
--- a/sysutils/lineak-xosdplugin/Makefile
+++ b/sysutils/lineak-xosdplugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lineak-xosdplugin
PORTVERSION= 0.9
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= sysutils deskutils
MASTER_SITES= SF/lineak/lineak_xosdplugin/${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= lineak
@@ -16,13 +16,12 @@ LICENSE= GPLv2
LIB_DEPENDS= libxosd.so:${PORTSDIR}/misc/xosd \
liblineak.so:${PORTSDIR}/sysutils/lineakd
-USE_XORG= x11 xext xt
USES= gmake libtool
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= ac_cv_path_xosd_config_script="${TRUE}"
USE_LDCONFIG= yes
-
-CFLAGS+= -fPIC
+USE_XORG= x11 xext xt
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= ac_cv_path_xosd_config_script="${TRUE}" \
+ kde_cv_prog_cxx_fno_check_new=no
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -32,7 +31,6 @@ PLIST_FILES= lib/lineakd/plugins/xosdplugin.so \
post-patch:
@${REINPLACE_CMD} -e \
's|"-O2 $$CXXFLAGS"|"$$CXXFLAGS"| ; \
- s|echo aout|echo elf| ; \
/LDFLAGS/s|-ldl||' ${WRKSRC}/configure
.include <bsd.port.mk>