aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/linux-crashplan
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-09-24 00:01:19 +0800
committerWilliam Grzybowski <wg@FreeBSD.org>2013-09-24 00:01:19 +0800
commit66c37ba55a7858ad3cbcf486e5a2c6cbb4cd9fd8 (patch)
tree33d60ba42b35f6bc73070dc71aa3dbae5aa9cbe9 /sysutils/linux-crashplan
parent611a27dced5bba8b771e96b19b99f5a454d5cb0a (diff)
downloadfreebsd-ports-gnome-66c37ba55a7858ad3cbcf486e5a2c6cbb4cd9fd8.tar.gz
freebsd-ports-gnome-66c37ba55a7858ad3cbcf486e5a2c6cbb4cd9fd8.tar.zst
freebsd-ports-gnome-66c37ba55a7858ad3cbcf486e5a2c6cbb4cd9fd8.zip
sysutils/linux-crashplan: backs up data to remote servers
CrashPlan backs up data to remote servers, other computers, or hard drives. WWW: http://www.crashplan.com/
Diffstat (limited to 'sysutils/linux-crashplan')
-rw-r--r--sysutils/linux-crashplan/Makefile52
-rw-r--r--sysutils/linux-crashplan/distinfo2
-rw-r--r--sysutils/linux-crashplan/files/crashplan.in22
-rw-r--r--sysutils/linux-crashplan/files/patch-CrashPlanDesktop17
-rw-r--r--sysutils/linux-crashplan/files/patch-CrashPlanEngine30
-rw-r--r--sysutils/linux-crashplan/pkg-descr3
-rw-r--r--sysutils/linux-crashplan/pkg-plist102
7 files changed, 228 insertions, 0 deletions
diff --git a/sysutils/linux-crashplan/Makefile b/sysutils/linux-crashplan/Makefile
new file mode 100644
index 000000000000..47ffb6d68429
--- /dev/null
+++ b/sysutils/linux-crashplan/Makefile
@@ -0,0 +1,52 @@
+# Created by: William Grzybowski <wg@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= linux-crashplan
+DISTVERSION= 3.5.3
+CATEGORIES= sysutils linux
+MASTER_SITES= http://download.crashplan.com/installs/linux/install/CrashPlan/
+DISTNAME= CrashPlan_3.5.3_Linux
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= wg@FreeBSD.org
+COMMENT= Backs up data to remote servers or hard drives
+
+RUN_DEPENDS= linux-sun-jre>=0:${PORTSDIR}/java/linux-sun-jre16 \
+ bash>=0:${PORTSDIR}/shells/bash
+
+WRKSRC= ${WRKDIR}/CrashPlan-install
+
+USE_LINUX= yes
+USE_LINUX_APPS= expat fontconfig xorglibs
+USE_RC_SUBR= crashplan
+USES= shebangfix
+
+SHEBANG_FILES= scripts/CrashPlanEngine scripts/CrashPlanDesktop
+
+ONLY_FOR_ARCHS= i386 amd64
+
+NO_BUILD= yes
+NO_STAGE= yes
+
+CRASHDIR= ${PREFIX}/share/crashplan
+
+pre-patch:
+ @${REINPLACE_CMD} -i '' 's,%%PREFIX%%,${PREFIX},' ${FILESDIR}/patch-CrashPlanDesktop
+
+post-patch:
+ @${REINPLACE_CMD} 's/SRV_JAVA_OPTS="/SRV_JAVA_OPTS="-Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.PollSelectorProvider /' ${WRKSRC}/scripts/run.conf
+ @${REINPLACE_CMD} 's/GUI_JAVA_OPTS="/GUI_JAVA_OPTS="-Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.PollSelectorProvider /' ${WRKSRC}/scripts/run.conf
+
+do-install:
+ @${MKDIR} ${CRASHDIR}
+ cd ${CRASHDIR} && ${CAT} ${WRKSRC}/CrashPlan_${DISTVERSION}.cpi | ${GZIP_CMD} -d -c - | ${CPIO} -i --no-preserve-owner
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/CrashPlanDesktop ${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/CrashPlanEngine ${CRASHDIR}/bin/
+ ${CP} ${WRKSRC}/scripts/run.conf ${CRASHDIR}/bin/
+ ${ECHO_CMD} > ${CRASHDIR}/install.vars
+ ${ECHO_CMD} "TARGETDIR=${CRASHDIR}" >> ${CRASHDIR}/install.vars
+ ${ECHO_CMD} "BINSDIR=${CRASHDIR}/bin" >> ${CRASHDIR}/install.vars
+ ${ECHO_CMD} "JAVACOMMON=${LOCALBASE}/linux-sun-jre1.6.0/bin/java" >> ${CRASHDIR}/install.vars
+ ${CAT} ${WRKSRC}/install.defaults >> ${CRASHDIR}/install.vars
+
+.include <bsd.port.mk>
diff --git a/sysutils/linux-crashplan/distinfo b/sysutils/linux-crashplan/distinfo
new file mode 100644
index 000000000000..04b9285f4f0e
--- /dev/null
+++ b/sysutils/linux-crashplan/distinfo
@@ -0,0 +1,2 @@
+SHA256 (CrashPlan_3.5.3_Linux.tgz) = 4ba6e7144b6184192e16fd1cd93ff342bd333e8e7080baaa9f8f46410cffa9df
+SIZE (CrashPlan_3.5.3_Linux.tgz) = 21404033
diff --git a/sysutils/linux-crashplan/files/crashplan.in b/sysutils/linux-crashplan/files/crashplan.in
new file mode 100644
index 000000000000..58dfb0295359
--- /dev/null
+++ b/sysutils/linux-crashplan/files/crashplan.in
@@ -0,0 +1,22 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+# PROVIDE: crashplan
+# REQUIRE: DAEMON
+
+. /etc/rc.subr
+
+name="crashplan"
+rcvar=${name}_enable
+
+command="%%PREFIX%%/share/crashplan/bin/CrashPlanEngine"
+
+pidfile="/var/run/CrashPlanEngine.pid"
+
+start_precmd="install -d /var/log/crashplan"
+start_cmd="${command} start"
+stop_cmd="${command} stop"
+
+load_rc_config ${name}
+run_rc_command "$1"
diff --git a/sysutils/linux-crashplan/files/patch-CrashPlanDesktop b/sysutils/linux-crashplan/files/patch-CrashPlanDesktop
new file mode 100644
index 000000000000..4f2652351864
--- /dev/null
+++ b/sysutils/linux-crashplan/files/patch-CrashPlanDesktop
@@ -0,0 +1,17 @@
+--- scripts/CrashPlanDesktop.orig 2013-09-23 11:40:09.770062319 -0300
++++ scripts/CrashPlanDesktop 2013-09-23 12:08:29.635060972 -0300
+@@ -4,9 +4,11 @@
+ SCRIPTDIR=$(dirname $SCRIPT)
+ TARGETDIR="$SCRIPTDIR/.."
+
+-. ${TARGETDIR}/install.vars
+-. ${TARGETDIR}/bin/run.conf
++. /usr/local/share/crashplan/install.vars
+
+ cd ${TARGETDIR}
+
+-${JAVACOMMON} ${GUI_JAVA_OPTS} -classpath "./lib/com.backup42.desktop.jar:./lang:./skin" com.backup42.desktop.CPDesktop > ${TARGETDIR}/log/ui_output.log 2> ${TARGETDIR}/log/ui_error.log &
++. bin/run.conf
++: ${LOGDIR=/var/log/crashplan}
++
++${JAVACOMMON} ${GUI_JAVA_OPTS} -classpath "./lib/com.backup42.desktop.jar:./lang:./skin" com.backup42.desktop.CPDesktop > ${LOGDIR}/ui_output.log 2> ${LOGDIR}/ui_error.log &
diff --git a/sysutils/linux-crashplan/files/patch-CrashPlanEngine b/sysutils/linux-crashplan/files/patch-CrashPlanEngine
new file mode 100644
index 000000000000..783698ed7e53
--- /dev/null
+++ b/sysutils/linux-crashplan/files/patch-CrashPlanEngine
@@ -0,0 +1,30 @@
+--- scripts/CrashPlanEngine.orig 2013-04-08 20:36:04.000000000 -0300
++++ scripts/CrashPlanEngine 2013-09-23 10:54:57.806062403 -0300
+@@ -11,7 +11,7 @@
+
+ cd $TARGETDIR
+
+- nice -n 19 $JAVACOMMON $SRV_JAVA_OPTS -classpath $FULL_CP com.backup42.service.CPService > $TARGETDIR/log/engine_output.log 2> $TARGETDIR/log/engine_error.log &
++ nice -n 19 $JAVACOMMON $SRV_JAVA_OPTS -classpath $FULL_CP com.backup42.service.CPService > $LOGDIR/engine_output.log 2> $LOGDIR/engine_error.log &
+
+ if [[ $! -gt 0 ]]; then
+ echo $! > $PIDFILE
+@@ -80,7 +80,7 @@
+ }
+
+ _findpid() {
+- /bin/ps -eo 'pid,cmd'| grep 'app=CrashPlanService' | grep -v grep | awk '{ print $1 }'
++ /bin/ps -ewwo 'pid,command'| grep 'app=CrashPlanService' | grep -v grep | awk '{ print $1 }'
+ }
+
+ SCRIPT=$(ls -l $0 | awk '{ print $NF }')
+@@ -91,7 +91,8 @@
+ DESC="CrashPlan Engine"
+ NAME=CrashPlanEngine
+ DAEMON=$TARGETDIR/lib/com.backup42.desktop.jar
+-PIDFILE="$TARGETDIR/${NAME}.pid"
++PIDFILE="/var/run/${NAME}.pid"
++: ${LOGDIR=/var/log/crashplan}
+
+ if [[ -f $TARGETDIR/install.vars ]]; then
+ . $TARGETDIR/install.vars
diff --git a/sysutils/linux-crashplan/pkg-descr b/sysutils/linux-crashplan/pkg-descr
new file mode 100644
index 000000000000..07d835748f86
--- /dev/null
+++ b/sysutils/linux-crashplan/pkg-descr
@@ -0,0 +1,3 @@
+CrashPlan backs up data to remote servers, other computers, or hard drives.
+
+WWW: http://www.crashplan.com/
diff --git a/sysutils/linux-crashplan/pkg-plist b/sysutils/linux-crashplan/pkg-plist
new file mode 100644
index 000000000000..730a16299067
--- /dev/null
+++ b/sysutils/linux-crashplan/pkg-plist
@@ -0,0 +1,102 @@
+bin/CrashPlanDesktop
+share/crashplan/libjniwrap64.so
+share/crashplan/libjtux.so
+share/crashplan/libjtux64.so
+share/crashplan/lang/txt_da.properties
+share/crashplan/lang/txt_zh_TW.properties
+share/crashplan/lang/txt_pt.properties
+share/crashplan/lang/txt_es_ES.properties
+share/crashplan/lang/txt_fr.properties
+share/crashplan/lang/txt_es.properties
+share/crashplan/lang/txt_nl.properties
+share/crashplan/lang/txt_pl.properties
+share/crashplan/lang/txt_en.properties
+share/crashplan/lang/txt_zh.properties
+share/crashplan/lang/txt_pt_BR.properties
+share/crashplan/lang/txt_ca.properties
+share/crashplan/lang/txt_es_AR.properties
+share/crashplan/lang/txt_es_MX.properties
+share/crashplan/lang/txt_sv.properties
+share/crashplan/lang/txt_it.properties
+share/crashplan/lang/txt_hu.properties
+share/crashplan/lang/txt_th.properties
+share/crashplan/lang/txt_de.properties
+share/crashplan/lang/txt_fi.properties
+share/crashplan/lang/txt_tr.properties
+share/crashplan/lang/txt_no.properties
+share/crashplan/lang/txt.properties
+share/crashplan/lang/txt_ja.properties
+share/crashplan/bin/run.conf
+share/crashplan/bin/CrashPlanEngine
+share/crashplan/bin/.keepme
+share/crashplan/bin/restartLinux.sh
+share/crashplan/lib/c42_protolib.jar
+share/crashplan/lib/com.jniwrapper.winpack.jar
+share/crashplan/lib/sbbi-upnplib-1.0.4.jar
+share/crashplan/lib/commons-collections-3.2.1-mini.jar
+share/crashplan/lib/protobuf-java-2.4.1.jar
+share/crashplan/lib/miglayout15-swt.jar
+share/crashplan/lib/swt-64.jar
+share/crashplan/lib/swt.jar
+share/crashplan/lib/jtux.jar
+share/crashplan/lib/trove-3.0.2.jar
+share/crashplan/lib/org.eclipse.osgi_3.8.1.v20120830-144521.jar
+share/crashplan/lib/slf4j-log4j12-1.6.1.jar
+share/crashplan/lib/org.eclipse.jface_3.8.101.v20120817-083647.jar
+share/crashplan/lib/log4j-1.2.16.jar
+share/crashplan/lib/com.jniwrapper.macpack.jar
+share/crashplan/lib/slf4j-api-1.6.1.jar
+share/crashplan/lib/com.backup42.desktop.jar
+share/crashplan/lib/json-20070829.jar
+share/crashplan/lib/commons-jxpath-1.1.jar
+share/crashplan/lib/json-lib-2.4.jar
+share/crashplan/lib/twitter4j.jar
+share/crashplan/lib/rhino-1.7r3.jar
+share/crashplan/lib/org.eclipse.core.commands_3.6.1.v20120814-150512.jar
+share/crashplan/lib/org.eclipse.equinox.common_3.6.100.v20120522-1841.jar
+share/crashplan/lib/jna-3.2.5.jar
+share/crashplan/lib/com.jniwrapper.jniwrap.jar
+share/crashplan/jniwrap.lic
+share/crashplan/upgrade/startLinux.sh
+share/crashplan/upgrade/startFirst.sh
+share/crashplan/upgrade/startSolaris.sh
+share/crashplan/upgrade/startDesktopSolaris.sh
+share/crashplan/upgrade/start.sh
+share/crashplan/upgrade/startDesktop.sh
+share/crashplan/upgrade/startDesktopLinux.sh
+share/crashplan/upgrade/start.bat
+share/crashplan/upgrade/startDesktop.bat
+share/crashplan/libjniwrap.so
+share/crashplan/libmd5.so
+share/crashplan/install.vars
+share/crashplan/skin/logo_main.png
+share/crashplan/skin/splash_default.png
+share/crashplan/skin/icon_app_16x16.png
+share/crashplan/skin/icon_app_128x128.png
+share/crashplan/skin/splash_plus.png
+share/crashplan/skin/skin.properties
+share/crashplan/skin/window_bg.jpg
+share/crashplan/skin/icon_app_64x64.png
+share/crashplan/skin/icon_app_32x32.png
+share/crashplan/conf/ui.properties
+share/crashplan/conf/ui.log.properties
+share/crashplan/conf/upgradeui.log.properties
+share/crashplan/conf/upgradeui.properties
+share/crashplan/conf/default.service.xml
+share/crashplan/conf/custom_sample.properties
+share/crashplan/conf/service.log.properties
+share/crashplan/libmd564.so
+share/crashplan/doc/readme.rtf
+share/crashplan/doc/readme.html
+share/crashplan/doc/readme.pdf
+share/crashplan/doc/readme.odt
+@dirrm share/crashplan/log
+@dirrm share/crashplan/doc
+@dirrm share/crashplan/conf
+@dirrm share/crashplan/skin
+@dirrm share/crashplan/upgrade/UpgradeUI
+@dirrm share/crashplan/upgrade
+@dirrm share/crashplan/lib
+@dirrm share/crashplan/bin
+@dirrm share/crashplan/lang
+@dirrm share/crashplan