aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/metalog/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-11-26 01:00:46 +0800
committermiwi <miwi@FreeBSD.org>2011-11-26 01:00:46 +0800
commitbe990f8d946e79c03fa79fd7502d23848f7f980e (patch)
treea8da73d35664f76337e2ca8704ef1560f06a8f9d /sysutils/metalog/Makefile
parentba87527f05ff532fb3a1531955c8e60cb3b5103e (diff)
downloadfreebsd-ports-gnome-be990f8d946e79c03fa79fd7502d23848f7f980e.tar.gz
freebsd-ports-gnome-be990f8d946e79c03fa79fd7502d23848f7f980e.tar.zst
freebsd-ports-gnome-be990f8d946e79c03fa79fd7502d23848f7f980e.zip
- Fix MASTER_SITES
- Add LICENSE - Add MAKE_JOBS_SAFE - Support PORTDOCS/PORTEXAMPLES/PLIST_FILES PR: 162850 Submitted by: Ports Fury Feature safe: yes
Diffstat (limited to 'sysutils/metalog/Makefile')
-rw-r--r--sysutils/metalog/Makefile23
1 files changed, 18 insertions, 5 deletions
diff --git a/sysutils/metalog/Makefile b/sysutils/metalog/Makefile
index 96bbbe2b55cb..b1856f1aeb9e 100644
--- a/sysutils/metalog/Makefile
+++ b/sysutils/metalog/Makefile
@@ -9,33 +9,46 @@ PORTNAME= metalog
DISTVERSION= 0.8
PORTEPOCH= 1
CATEGORIES= sysutils
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/old
MAINTAINER= ports@FreeBSD.org
COMMENT= Modern syslogd replacement with PCRE support
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_BZIP2= yes
USE_RC_SUBR= ${PORTNAME}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc
+MAKE_JOBS_SAFE= yes
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAN5= metalog.conf.5
MAN8= metalog.8
-DOCS= AUTHORS NEWS README
+PORTDOCS= AUTHORS NEWS README
+PORTEXAMPLES= metalog.conf
+PLIST_FILES= sbin/metalog
post-patch:
@${REINPLACE_CMD} -e 's|/etc/|${PREFIX}/etc/|' ${WRKSRC}/man/*[58]
post-install:
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/metalog.conf ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
+.for doc in ${PORTDOCS}
@${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for ex in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${ex} ${EXAMPLESDIR}
+.endfor
.endif
.include <bsd.port.mk>