aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/modules
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-08-20 06:09:44 +0800
committerpawel <pawel@FreeBSD.org>2016-08-20 06:09:44 +0800
commit6e450878ebf83903510c75a583373baa3fa43a46 (patch)
treeddde45b0bf0e6d1f2a2887b563fd09e4961e73c0 /sysutils/modules
parent0a6d45e4363a0c46bfb6a787b326376287f1d7e0 (diff)
downloadfreebsd-ports-gnome-6e450878ebf83903510c75a583373baa3fa43a46.tar.gz
freebsd-ports-gnome-6e450878ebf83903510c75a583373baa3fa43a46.tar.zst
freebsd-ports-gnome-6e450878ebf83903510c75a583373baa3fa43a46.zip
- Convert to USES=tcl changing version of TCL
port depends on to 8.6, bump PORTREVISION - Add patch fixing build with TCL 8.6 - Regenerate patches with make makepatch PR: 211690 Submitted by: Matthieu Volat
Diffstat (limited to 'sysutils/modules')
-rw-r--r--sysutils/modules/Makefile13
-rw-r--r--sysutils/modules/files/patch-Makefile.in22
-rw-r--r--sysutils/modules/files/patch-cmdModule.c21
-rw-r--r--sysutils/modules/files/patch-configure16
-rw-r--r--sysutils/modules/files/patch-doc__module.1.in6
-rw-r--r--sysutils/modules/files/patch-doc__modulefile.5.in4
-rw-r--r--sysutils/modules/files/patch-etc__Makefile.in6
-rw-r--r--sysutils/modules/files/patch-init__Makefile.in6
8 files changed, 56 insertions, 38 deletions
diff --git a/sysutils/modules/Makefile b/sysutils/modules/Makefile
index eb8bf7ff23e3..2f2b8730579a 100644
--- a/sysutils/modules/Makefile
+++ b/sysutils/modules/Makefile
@@ -3,6 +3,7 @@
PORTNAME= modules
PORTVERSION= 3.2.10
+PORTREVISION= 1
CATEGORIES= sysutils tcl
MASTER_SITES= SF/${PORTNAME}/Modules/${PORTNAME}-${PORTVERSION}
@@ -11,20 +12,16 @@ COMMENT= Dynamic modification of a user environment
LICENSE= GPLv2
-LIB_DEPENDS= libtcl84.so:lang/tcl84
-
-TCL_DVER?= 8.4
-TCL_VER= ${TCL_DVER:S/.//}
+USES= tcl
HAS_CONFIGURE= yes
-
CONFIGURE_ARGS= --prefix=${LOCALBASE} \
--without-x \
--with-version-path=${LOCALBASE}/Modules/versions \
--mandir=${MANPREFIX}/man \
- --with-tcl-ver=${TCL_VER} \
- --with-tcl-inc=${LOCALBASE}/include/tcl${TCL_DVER} \
+ --with-tcl-ver=${TCL_VER:S/.//} \
+ --with-tcl-inc=${TCL_INCLUDEDIR} \
--with-tcl-lib=${LOCALBASE}/lib \
- --with-tclx-ver=${TCL_VER}
+ --with-tclx-ver=${TCL_VER:S/.//}
PLIST_SUB= MODULES_VERSION=${PORTVERSION}
diff --git a/sysutils/modules/files/patch-Makefile.in b/sysutils/modules/files/patch-Makefile.in
index 24aaa16a9ce0..297fe32d6929 100644
--- a/sysutils/modules/files/patch-Makefile.in
+++ b/sysutils/modules/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2012-12-19 18:02:26.000000000 +0100
-+++ Makefile.in 2014-09-04 12:15:49.912860562 +0200
-@@ -74,7 +74,7 @@
+--- Makefile.in.orig 2012-12-19 17:02:26 UTC
++++ Makefile.in
+@@ -74,7 +74,7 @@ CONFIG_CLEAN_FILES = modules.lsm .spec e
ext/common/.profile
CONFIG_CLEAN_VPATH_FILES =
am__installdirs = "$(DESTDIR)$(bindir)" "$(DESTDIR)$(man1dir)" \
@@ -9,7 +9,7 @@
PROGRAMS = $(bin_PROGRAMS)
am_modulecmd_OBJECTS = modulecmd-ModuleCmd_Avail.$(OBJEXT) \
modulecmd-ModuleCmd_Clear.$(OBJEXT) \
-@@ -150,7 +150,7 @@
+@@ -150,7 +150,7 @@ am__uninstall_files_from_dir = { \
$(am__cd) "$$dir" && rm -f $$files; }; \
}
man1dir = $(mandir)/man1
@@ -18,7 +18,7 @@
NROFF = nroff
MANS = $(man_MANS)
RECURSIVE_CLEAN_TARGETS = mostlyclean-recursive clean-recursive \
-@@ -320,7 +320,7 @@
+@@ -320,7 +320,7 @@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
ACLOCAL_AMFLAGS = -I config
@@ -27,7 +27,7 @@
SUBDIRS = . init modulefiles @EXTDIR@ doc
DIST_SUBDIRS = . init modulefiles etc ext doc
SOURCES_H = modules_def.h getopt.h config.h
-@@ -1087,10 +1087,10 @@
+@@ -1087,10 +1087,10 @@ uninstall-man1:
} | sed -e 's,.*/,,;h;s,.*\.,,;s,^[^1][0-9a-z]*$$,1,;x' \
-e 's,\.[0-9a-z]*$$,,;$(transform);G;s,\n,.,'`; \
dir='$(DESTDIR)$(man1dir)'; $(am__uninstall_files_from_dir)
@@ -41,7 +41,7 @@
{ for i in $$list; do echo "$$i"; done; \
l2='$(man_MANS)'; for i in $$l2; do echo "$$i"; done | \
sed -n '/\.4[a-z]*$$/p'; \
-@@ -1103,26 +1103,26 @@
+@@ -1103,26 +1103,26 @@ install-man4: $(man_MANS)
sed 'N;N;s,\n, ,g' | { \
list=; while read file base inst; do \
if test "$$base" = "$$inst"; then list="$$list $$file"; else \
@@ -75,7 +75,7 @@
# This directory's subdirectories are mostly independent; you can cd
# into them and run `make' without going through this Makefile.
-@@ -1498,7 +1498,7 @@
+@@ -1498,7 +1498,7 @@ check: check-recursive
all-am: Makefile $(PROGRAMS) $(MANS) config.h
installdirs: installdirs-recursive
installdirs-am:
@@ -84,7 +84,7 @@
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
done
install: install-recursive
-@@ -1570,7 +1570,7 @@
+@@ -1570,7 +1570,7 @@ install-info: install-info-recursive
install-info-am:
@@ -93,7 +93,7 @@
install-pdf: install-pdf-recursive
-@@ -1603,7 +1603,7 @@
+@@ -1603,7 +1603,7 @@ ps-am:
uninstall-am: uninstall-binPROGRAMS uninstall-man
@@ -102,7 +102,7 @@
.MAKE: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) all check-am \
ctags-recursive install-am install-strip tags-recursive
-@@ -1619,14 +1619,14 @@
+@@ -1619,14 +1619,14 @@ uninstall-man: uninstall-man1 uninstall-
info-am install install-am install-binPROGRAMS install-data \
install-data-am install-dvi install-dvi-am install-exec \
install-exec-am install-html install-html-am install-info \
diff --git a/sysutils/modules/files/patch-cmdModule.c b/sysutils/modules/files/patch-cmdModule.c
new file mode 100644
index 000000000000..b344eaea1ed8
--- /dev/null
+++ b/sysutils/modules/files/patch-cmdModule.c
@@ -0,0 +1,21 @@
+--- cmdModule.c.orig 2016-08-09 09:37:36 UTC
++++ cmdModule.c
+@@ -640,8 +640,16 @@ int Execute_TclFile( Tcl_Interp *interp
+ case TCL_OK: gotPartial = 0;
+ continue; /** while **/
+
+- case TCL_ERROR: interp->errorLine = ((linenum-1)-gotPartial) +
+- interp->errorLine;
++ case TCL_ERROR:
++#if (TCL_MAJOR_VERSION > 8) \
++ || (TCL_MAJOR_VERSION == 8 && TCL_MINOR_VERSION >= 6)
++ Tcl_SetErrorLine(
++ interp,
++ ((linenum-1)-gotPartial) + Tcl_GetErrorLine(interp));
++#else
++ interp->errorLine =
++ ((linenum-1)-gotPartial) + interp->errorLine;
++#endif
+ /* FALLTHROUGH */
+
+ case TCL_LEVEL0_RETURN:
diff --git a/sysutils/modules/files/patch-configure b/sysutils/modules/files/patch-configure
index e8310c4d6e02..cfaa8291cf03 100644
--- a/sysutils/modules/files/patch-configure
+++ b/sysutils/modules/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2012-12-19 18:02:25.000000000 +0100
-+++ configure 2014-09-04 12:13:33.328870000 +0200
-@@ -1480,7 +1480,7 @@
+--- configure.orig 2012-12-19 17:02:25 UTC
++++ configure
+@@ -1480,7 +1480,7 @@ Optional Packages:
specify a pattern for trace [[no]]
--with-tcl=<dir> directory containing tcl configuration
(tclConfig.sh) [[searches]]
@@ -9,7 +9,7 @@
--with-tcl-lib=<dir> directory containing tcl libraries (libtclX.Y)
[[none]]
--with-tcl-inc=<dir> directory containing tcl include files
-@@ -1518,7 +1518,7 @@
+@@ -1518,7 +1518,7 @@ PREFIX/Modules/($MODULES_VERSION/ if mod
init/
man/
man1/
@@ -18,7 +18,7 @@
modulefiles/
PREFIX/Modules/
modulefiles/
-@@ -7099,9 +7099,9 @@
+@@ -7099,9 +7099,9 @@ else
em_cv_tclver=${with_tclver}
fi #}}
@@ -30,7 +30,7 @@
fi #}
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: ${em_cv_tclver}" >&5
$as_echo "${em_cv_tclver}" >&6; }
-@@ -7375,9 +7375,9 @@
+@@ -7375,9 +7375,9 @@ else
em_cv_tclxver=${with_tclxver}
fi #}}
@@ -42,7 +42,7 @@
fi #}
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using ${em_cv_tclxver}" >&5
$as_echo "using ${em_cv_tclxver}" >&6; }
-@@ -7657,7 +7657,7 @@
+@@ -7657,7 +7657,7 @@ else
EXTDIR="etc"
fi
@@ -51,7 +51,7 @@
ac_config_commands="$ac_config_commands default"
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
-@@ -8398,7 +8398,7 @@
+@@ -8398,7 +8398,7 @@ do
"init/Makefile") CONFIG_FILES="$CONFIG_FILES init/Makefile" ;;
"init/.modulespath") CONFIG_FILES="$CONFIG_FILES init/.modulespath" ;;
"doc/module.1") CONFIG_FILES="$CONFIG_FILES doc/module.1" ;;
diff --git a/sysutils/modules/files/patch-doc__module.1.in b/sysutils/modules/files/patch-doc__module.1.in
index 22ca4d1da0bc..6677327cbcc6 100644
--- a/sysutils/modules/files/patch-doc__module.1.in
+++ b/sysutils/modules/files/patch-doc__module.1.in
@@ -1,6 +1,6 @@
---- doc/module.1.in.orig 2014-09-04 09:36:20 UTC
+--- doc/module.1.in.orig 2012-11-08 22:45:02 UTC
+++ doc/module.1.in
-@@ -120,7 +120,7 @@
+@@ -120,7 +120,7 @@ command is defined with:
Upon invocation \fImodulecmd\fP sources rc files which contain global, user
and modulefile specific setups. These files are interpreted as modulefiles.
See
@@ -9,7 +9,7 @@
for detailed information.
.LP
Upon invocation of modulecmd module RC files are sourced in the following
-@@ -498,4 +498,4 @@
+@@ -498,4 +498,4 @@ If this defines a valid filename, it ser
.SH VERSION
@VERSION@
.SH SEE ALSO
diff --git a/sysutils/modules/files/patch-doc__modulefile.5.in b/sysutils/modules/files/patch-doc__modulefile.5.in
index dc428ffcb2cc..ef5aae642149 100644
--- a/sysutils/modules/files/patch-doc__modulefile.5.in
+++ b/sysutils/modules/files/patch-doc__modulefile.5.in
@@ -1,4 +1,4 @@
---- doc/modulefile.5.in.orig 2014-09-04 09:37:33 UTC
+--- doc/modulefile.5.in.orig 2012-12-06 22:51:08 UTC
+++ doc/modulefile.5.in
@@ -1,6 +1,6 @@
-.\" .TH MODULEFILE 4 "1 July 1994"
@@ -9,7 +9,7 @@
.nh
.SH NAME
modulefile \- files containing Tcl code for the Modules package
-@@ -656,7 +656,7 @@
+@@ -656,7 +656,7 @@ to your shell.
.RE
.RS
.I a syslog facility
diff --git a/sysutils/modules/files/patch-etc__Makefile.in b/sysutils/modules/files/patch-etc__Makefile.in
index b5d23a22b6c4..c65dd546dcc5 100644
--- a/sysutils/modules/files/patch-etc__Makefile.in
+++ b/sysutils/modules/files/patch-etc__Makefile.in
@@ -1,6 +1,6 @@
---- etc/Makefile.in.orig 2014-09-04 14:00:45.808429028 +0200
-+++ etc/Makefile.in 2014-09-04 14:02:10.225903882 +0200
-@@ -403,8 +403,8 @@
+--- etc/Makefile.in.orig 2012-12-19 17:02:26 UTC
++++ etc/Makefile.in
+@@ -403,8 +403,8 @@ install-data-local : $(EXTRA_scripts)
@list='$(EXTRA_scripts)'; for p in $$list; do \
if test -f $$p \
; then \
diff --git a/sysutils/modules/files/patch-init__Makefile.in b/sysutils/modules/files/patch-init__Makefile.in
index 4f735087d9cb..158a03dcafc1 100644
--- a/sysutils/modules/files/patch-init__Makefile.in
+++ b/sysutils/modules/files/patch-init__Makefile.in
@@ -1,6 +1,6 @@
---- init/Makefile.in.orig 2012-12-19 18:02:26.000000000 +0100
-+++ init/Makefile.in 2014-09-04 14:32:46.863296746 +0200
-@@ -437,9 +437,10 @@
+--- init/Makefile.in.orig 2012-12-19 17:02:26 UTC
++++ init/Makefile.in
+@@ -437,9 +437,10 @@ uninstall-inits :
# We need to filter the *.in files to produce the init scripts
# since we don't know the value of '@prefix@' until Make time.
# (We can not rely on configure to give us correct values.)