aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils/monit
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-10-11 10:50:45 +0800
committermnag <mnag@FreeBSD.org>2005-10-11 10:50:45 +0800
commit76a91b6d4e33e4e2c73e08761354e7486b09bb4b (patch)
tree81b039da62abeba0cb706cfbf38e67896c474620 /sysutils/monit
parent7255a8f75915ad5c02cc578d79e52b0fcd5b521b (diff)
downloadfreebsd-ports-gnome-76a91b6d4e33e4e2c73e08761354e7486b09bb4b.tar.gz
freebsd-ports-gnome-76a91b6d4e33e4e2c73e08761354e7486b09bb4b.tar.zst
freebsd-ports-gnome-76a91b6d4e33e4e2c73e08761354e7486b09bb4b.zip
Update to 4.6
PR: 87231 Submitted by: Martin Pala <martinp@tildeslash.com> (maintainer)
Diffstat (limited to 'sysutils/monit')
-rw-r--r--sysutils/monit/Makefile91
-rw-r--r--sysutils/monit/distinfo4
-rw-r--r--sysutils/monit/files/monit.sh.in (renamed from sysutils/monit/files/monit.sh)10
-rw-r--r--sysutils/monit/files/pkg-message.in13
-rw-r--r--sysutils/monit/pkg-descr2
-rw-r--r--sysutils/monit/pkg-message5
6 files changed, 57 insertions, 68 deletions
diff --git a/sysutils/monit/Makefile b/sysutils/monit/Makefile
index 2a62976830ee..93dacb3d7c62 100644
--- a/sysutils/monit/Makefile
+++ b/sysutils/monit/Makefile
@@ -5,72 +5,59 @@
# $FreeBSD$
#
-PORTNAME= monit
-PORTVERSION= 4.4
-CATEGORIES= sysutils
-MASTER_SITES= http://www.tildeslash.com/monit/dist/
+PORTNAME= monit
+PORTVERSION= 4.6
+CATEGORIES= sysutils
+MASTER_SITES= http://www.tildeslash.com/monit/dist/
-MAINTAINER= martinp@tildeslash.com
-COMMENT= Unix system management and monitoring tool
+MAINTAINER= martinp@tildeslash.com
+COMMENT= Unix system management and monitoring
-MAN1= monit.1
+MAN1= monit.1
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_BISON= yes
-USE_RC_SUBR= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_BISON= yes
+USE_RC_SUBR= monit.sh
-CONFIGURE_ENV= CC="${CC}" CPPFLAGS="${CPPFLAGS}" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" CONFIG_SHELL="${SH}" \
- LOCALBASE="${LOCALBASE}"
+CONFIGURE_ENV= CC="${CC}" CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" CONFIG_SHELL="${SH}" \
+ LOCALBASE="${LOCALBASE}"
-OPTIONS= MONIT_SSL "Enable SSL support" on
+OPTIONS= MONIT_SSL "Enable SSL support" on
-PLIST_FILES= bin/monit \
- etc/monitrc.sample \
- etc/rc.d/monit.sh \
- share/doc/monit/CHANGES.txt \
- share/doc/monit/CONTRIBUTORS \
- share/doc/monit/FAQ.txt \
- share/doc/monit/LICENSE \
- share/doc/monit/README \
- share/doc/monit/README.SSL \
- share/doc/monit/STATUS \
- share/doc/monit/examples.html \
- share/doc/monit/monit.html
-PLIST_DIRS= share/doc/monit
+PLIST_FILES= bin/monit \
+ etc/monitrc.sample
-.include <bsd.port.pre.mk>
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
-pre-install:
- @${SED} -e 's|%%PREFIX%%|${PREFIX}|g' \
- -e 's|%%RC_SUBR%%|${RC_SUBR}|g' \
- ${FILESDIR}/monit.sh > ${WRKDIR}/monit.sh
+PORTDOCS= *
-post-install:
- @${INSTALL_SCRIPT} -m 755 ${WRKDIR}/monit.sh ${PREFIX}/etc/rc.d/monit.sh
- @${INSTALL_SCRIPT} -m 600 ${WRKDIR}/${DISTNAME}/monitrc ${PREFIX}/etc/monitrc.sample
- ${MKDIR} ${DOCSDIR}
- @${INSTALL_SCRIPT} -m 644 ${WRKDIR}/${DISTNAME}/CHANGES.txt ${PREFIX}/share/doc/monit/CHANGES.txt
- @${INSTALL_SCRIPT} -m 644 ${WRKDIR}/${DISTNAME}/CONTRIBUTORS ${PREFIX}/share/doc/monit/CONTRIBUTORS
- @${INSTALL_SCRIPT} -m 644 ${WRKDIR}/${DISTNAME}/FAQ.txt ${PREFIX}/share/doc/monit/FAQ.txt
- @${INSTALL_SCRIPT} -m 644 ${WRKDIR}/${DISTNAME}/LICENSE ${PREFIX}/share/doc/monit/LICENSE
- @${INSTALL_SCRIPT} -m 644 ${WRKDIR}/${DISTNAME}/README ${PREFIX}/share/doc/monit/README
- @${INSTALL_SCRIPT} -m 644 ${WRKDIR}/${DISTNAME}/README.SSL ${PREFIX}/share/doc/monit/README.SSL
- @${INSTALL_SCRIPT} -m 644 ${WRKDIR}/${DISTNAME}/STATUS ${PREFIX}/share/doc/monit/STATUS
- @${INSTALL_SCRIPT} -m 644 ${WRKDIR}/${DISTNAME}/doc/examples.html ${PREFIX}/share/doc/monit/examples.html
- @${INSTALL_SCRIPT} -m 644 ${WRKDIR}/${DISTNAME}/doc/monit.html ${PREFIX}/share/doc/monit/monit.html
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG} " ${PREFIX}/etc/monitrc.sample"
- @${ECHO_MSG} " ${PREFIX}/share/doc/monit/examples.html"
+.include <bsd.port.pre.mk>
.if defined(WITH_MONIT_SSL)
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
-CONFIGURE_ARGS+= --enable-ssl \
- --with-openssl="${OPENSSLBASE}"
+CONFIGURE_ARGS+= --enable-ssl --with-openssl="${OPENSSLBASE}"
.else
CONFIGURE_ARGS+= --without-ssl
.endif
+post-install:
+ ${INSTALL_SCRIPT} -m 600 ${WRKDIR}/${DISTNAME}/monitrc ${PREFIX}/etc/monitrc.sample
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_SCRIPT} -m 644 ${WRKDIR}/${DISTNAME}/CHANGES.txt ${PREFIX}/share/doc/monit/CHANGES.txt
+ ${INSTALL_SCRIPT} -m 644 ${WRKDIR}/${DISTNAME}/CONTRIBUTORS ${PREFIX}/share/doc/monit/CONTRIBUTORS
+ ${INSTALL_SCRIPT} -m 644 ${WRKDIR}/${DISTNAME}/FAQ.txt ${PREFIX}/share/doc/monit/FAQ.txt
+ ${INSTALL_SCRIPT} -m 644 ${WRKDIR}/${DISTNAME}/LICENSE ${PREFIX}/share/doc/monit/LICENSE
+ ${INSTALL_SCRIPT} -m 644 ${WRKDIR}/${DISTNAME}/README ${PREFIX}/share/doc/monit/README
+ ${INSTALL_SCRIPT} -m 644 ${WRKDIR}/${DISTNAME}/README.SSL ${PREFIX}/share/doc/monit/README.SSL
+ ${INSTALL_SCRIPT} -m 644 ${WRKDIR}/${DISTNAME}/STATUS ${PREFIX}/share/doc/monit/STATUS
+ ${INSTALL_SCRIPT} -m 644 ${WRKDIR}/${DISTNAME}/doc/examples.html ${PREFIX}/share/doc/monit/examples.html
+ ${INSTALL_SCRIPT} -m 644 ${WRKDIR}/${DISTNAME}/doc/monit.html ${PREFIX}/share/doc/monit/monit.html
+.endif
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.post.mk>
diff --git a/sysutils/monit/distinfo b/sysutils/monit/distinfo
index 67984bcd8314..63027c879cd1 100644
--- a/sysutils/monit/distinfo
+++ b/sysutils/monit/distinfo
@@ -1,2 +1,2 @@
-MD5 (monit-4.4.tar.gz) = 671e1882ae342118a2138a3468589967
-SIZE (monit-4.4.tar.gz) = 458083
+MD5 (monit-4.6.tar.gz) = 4e53aa44e4ca264e61c7c401cee4e697
+SIZE (monit-4.6.tar.gz) = 549238
diff --git a/sysutils/monit/files/monit.sh b/sysutils/monit/files/monit.sh.in
index a7739da45555..a380cc9bbb92 100644
--- a/sysutils/monit/files/monit.sh
+++ b/sysutils/monit/files/monit.sh.in
@@ -20,7 +20,6 @@ rcvar=`set_rcvar`
restart_precmd="monit_checkconfig"
reload_precmd="monit_checkconfig"
-stop_cmd="monit_stop"
default_config=%%PREFIX%%/etc/monitrc
required_files=${default_config}
@@ -34,13 +33,8 @@ load_rc_config $name
monit_checkconfig()
{
- echo "Performing sanity check on monit configuration:"
- ${command} ${command_args} -t
-}
-
-monit_stop() {
- ${command} ${command_args} quit
- run_rc_command poll
+ echo "Performing sanity check on monit configuration:"
+ ${command} ${command_args} -t
}
extra_commands="reload"
diff --git a/sysutils/monit/files/pkg-message.in b/sysutils/monit/files/pkg-message.in
new file mode 100644
index 000000000000..98ef1ce8b170
--- /dev/null
+++ b/sysutils/monit/files/pkg-message.in
@@ -0,0 +1,13 @@
+**************************************************************************
+
+USAGE:
+
+To enable monit you need to add monit_enable="YES" to rc.conf file.
+Before running monit you have to configure monitrc file. There is
+example configuration file monitrc.sample, you can find many
+samples for particular services in examples.html:
+
+%%PREFIX%%/etc/monitrc.sample
+%%PREFIX%%/share/doc/monit/examples.html
+
+**************************************************************************
diff --git a/sysutils/monit/pkg-descr b/sysutils/monit/pkg-descr
index 93aba19d7835..64fe43f27181 100644
--- a/sysutils/monit/pkg-descr
+++ b/sysutils/monit/pkg-descr
@@ -17,7 +17,7 @@ monit supports:
* Remote network services monitoring (ping, response time, protocol, etc.)
* System load average monitoring
* Flexible and customizable email alert messages and notifications
- * Protocol verification such as HTTP, FTP, SMTP, POP, IMAP, NNTP, etc.
+ * Protocol verification such as HTTP, FTP, SMTP, POP, IMAP, NNTP, NTP, etc.
* A HTTP interface with XML output option
and many more features :)
diff --git a/sysutils/monit/pkg-message b/sysutils/monit/pkg-message
deleted file mode 100644
index ef86d0296ac1..000000000000
--- a/sysutils/monit/pkg-message
+++ /dev/null
@@ -1,5 +0,0 @@
-===> USAGE:
- To enable monit you need to add monit_enable="YES" to rc.conf file.
- Before running monit you have to configure monitrc file. There is
- example configuration file monitrc.sample, you can find many
- samples for particular services in examples.html: